Templates Plugins Courses

PayStack Plugin Error - Not Working

Hello,

I just bought the Paystack plugin and I copied the same workflow you have on your demo to try in my app. See the picture below for the error I am getting each time I try to use it. I tried using my public test API key and private test API key, yet I was still getting the same error for both. Later, I copied the test API key on the zeroqode demo just to confirm if the problem was with my own key. And it was still not working for me. Please help me solve this issue.

image

Hi @asolpshinning14,

Thanks for reaching out. Unfortunately, this error is not reproducing on our side. We have tried to replicate it, and we get the same error if we introduce the API key in the following format based on this error:

Authorization Bearer Your_Secret_Key

The right format should be as in our demo app, without the ‘Authorization’ before:

Bearer Your_Secret_Key

Please check plugin’s documentation here https://docs.zeroqode.com/plugins/paystack-payments-in-nigeria-plugin for more information. Also, please make sure that you are using your own and the right API key. For more information, check Paystack docs here https://developers.paystack.co/docs/authorization.

Hope it helps.

Best,
Alex

I have already checked the documentation and did replicated exactly what is on your demo version. It is still not working and giving the same error message. And just so you know, I am using my API key. It was when it did not work, and I wanted to troubleshoot if it was a problem with my key, that was when I tried to use the key on the demo. So none of the keys are working. And I was told the problem is with the plugin. Please kindly help correct this problem.

Hi @asolpshinning14, thanks for your feedback. Unfortunately, after another round of testing, this issue is still not reproducing on our side. Could you please share screenshots/screecast of your app and the workflow settings when this error is triggered. It would be best to also share console logs of your browser and plugin configurations with your own key, but with its secret_key value being blurred. This way, we can investigate and provide with a better solution. Thank you. :pray:

I simply added the same button Zeroqode on their demo with the same workflow

Please see my screenshots below:

image

Hi @asolpshinning14, thanks for your feedback. So, based on the provided screenshots, the issue seems to be in the way your API Key is inserted. So, as I can see it is missing the Bearer before the key value:

Actually, it has to be placed this way, with a space between:

Thanks!

Hello @alexandru.rusnac,

Thanks for looking into this.

I have just added "Bearer " as you have suggested, and it is still producing the same error:

Hi @asolpshinning14,

Thanks for your feedback. Unfortunately, this issue is still not reproducing on our side. Please go to Settings - Collaboration tab within your editor. Add our [email protected] account to your collaborator’s list. Also, please tell us your app name and page name where this problem occurs on test.

Note: avoid the warning message regarding plan, as we are an agency and you can easily add us to your collaborators.

We’ll investigate it inside your app and get back to you with a feedback asap.