Templates Plugins Courses

Paystack plugin not responding

Hi guys,

I am using the paystack plugin for my bubble app, I created a payment page that is called when the sign-up button is clicked… but it never works. It shows the attached error message

Hi @kyraacademy.ng

Thanks for reaching out.

I would like to kindly ask you to share a bit more information on how you set up the plugin, particularly the workflows, and the settings of “Create Page” action(screenshots). Please do also check out our setup in the demo editor, specifically take a closer look at the amount parameter, and make sure that it is filled in.

Looking forward to your reply.

Hi Kirill,

Thank you for the swift response,

I have attached screenshots
Uploading: 20220708_111320.jpg…
Uploading: 20220708_111327.jpg…
Uploading: 20220708_111335.jpg…
Uploading: 20220708_111345.jpg…
to show all you require

Unfortunately, the screenshots can’t be viewed, can you please try uploading them again? or use a service such as Lightshot and try to screenshot :slight_smile:




Please try to have an input on the page, and use the dynamic parameter in the settings of the create page action. Also, add “00” at the end of the dynamic field, and then try again. Write the number that you would like to charge in the input that you put on the page and then click signup, and follow our step-by-step instructions here: https://docs.zeroqode.com/plugins/paystack-payments-in-nigeria#_IK0C

Hi Krill,

Thank you for the support so far but it’s not working .

So this is what I did;

  1. Install the plugin and add my test API key (I added bearer before pasting the keys)

  2. Create a workflow for my singup button

  3. The first step of the workflow is “paystack -payment pages-create page”

  4. I filled in the name, description, and I input the amount. And that’s all

With the step above when I preview it doesn’t work.

So how do I get the link to this page I just created? So that I can add another step which is to open external site(just like in the doc)

What is wrong with my page creation and why is it not working.

Please assist as this is the only thing delaying our go live

Hi Kril,

I have been able to get the link.

But see error I am still experiencing

Can you please replicate this workflow and let me know if the issue still persists?


If the issues still persist, the problem is probably in the API keys, so please do check these.

Looking forward to your reply.

Thank you Krill,

You have been so helpful.

The plugin works perfectly now and I also know how to set it up properly.

Please how do I redirect the URL to one of my pages on bubble?

1 Like

Glad to hear that everything works well, and thanks for the kind words :slight_smile:

The redirect URL can be changed in “Create Page” action (param.) redirect_url. You can dynamically input the Website home URL and after that write the name of the page you would like to redirect the user.

In case you have any other questions, just let me know!

Have a great day.

Hi Krill,

Thank you for the support so far. My app is almost live. But there is a little challenge.

Once the paystack create page is setup it is only accessible after a click.

A second click will show “slug already exist”… do I have to make it dynamic?

Hi @kyraacademy.ng

Thanks for the feedback.

Can you please let me know what you mean by “it is only accessible after a click”

When exactly does it says slug already exist? Yes, you can try using a dynamic value and see if the error still persists.

Looking forward to your reply.

Hi Krill,

I tried the dynamic option and it works perfectly fine now

Thank you so much for the help and support. This gives me lot of confidence

Thanks for the feedback @kyraacademy.ng. I appreciate it :slight_smile:

If you like the plugin and enjoy the support you are getting, please do not hesitate to leave a review! It motivates us to build more plugins and provide awesome support.
To leave a review:

  1. Go to plugins tab > find the Paystack plugin > Share your thoughts.

If you have any other questions, just let me know.

Regards,

Kirill