Templates Plugins Courses

(Print Pro) Print Elements in Repeating Group

I’m having difficulty trying to print an element which is part of a repeating group.

I’ve given the element an ID Attribute (A1), however when I try to print the same element in other cells in the repeating group it always prints the top cell.

Can anyone suggest a way to fix this please!

Thanks

Below is a screenshot for reference

Hi @chris.b.m, thanks for reaching out.

In case you would like to print the whole RG, please indicate the RG attribute ID in the related plugin action.

If in plugin action it is indicated only an ID of a single element - it will print only indicated element.

Hope the provided hint helps. Please drop a message if additional support is required.

Regards,

Hey Serg, thanks for the reply!

Below is a link to an example of what I’m trying to achieve. The print button is within the RG cells and I’d like to print the element for that specific cell (In this case the product name on the left). The problem is that it always prints the top cell.

Hope this makes sense and there is a solution.

Thanks

Hi @chris.b.m, thanks for the additional details provided.

I’ve passed this case to the developer team for investigation. Once any results will become available, I will let you know asap.

Thank you for understanding.

Regards,

A solution in such a case would be to use current cell index as id, see the example for guidance:


Hope the provided hint will help. Drop a message if there is anything else that I can help with :wink:

Regards,

Thanks again for getting back to me Serg,

The problem is that it won’t let me insert dynamic data into the Element ID field. That’s why I’m having such difficulty. I can give an element a dynamic ID attribute but not the Print Element by Id feild in workflow.

Hi @chris.b.m, sorry for the delayed reply (due to the weekend).

Here is a little trick, in both related fields first insert a static value, then a dynamic one:
dynamic field

Hope it helps.

Have a nice week ahead!
Regards,

Hi Serg,

Still nothing… It doesn’t give me the option to insert dynamic data at all, the blue box just doesn’t appear.

Is there any way of setting up a zoom call to resolve this or do you have any other ideas?

Thanks

Please share (here or in DM) a screencast (I suggest using the Loom tool) with your case, when you try to set up the plugin following the example above, it will allow us to identify any possible issue much faster.

Looking forward to your reply.

Regards,

I’m actually having this exact same issue. The dynamic data button doesn’t pop up when I go to enter the Element ID in the Print Element by ID workflow. Was there a resolution?

Loom | Free Screen & Video Recording Software | Loom here is a loom for reference

Hi @quinn, thanks for your messages and provided video.
Strange case, I’ve tried the same on my side and it worked as it should. Loom | Free Screen & Video Recording Software | Loom

Please check that the workflow trigger button is placed in the RG cell too.
drop me a message.
Regards,

The workflow trigger is definitely in the RG cell. Should the Print Toolkit go in the RG as well? I’ve tried it both ways and it didn’t seem to make a difference.

@quinn, thanks for the reply.
Can you please add our Support Team email to the list of collaborators to your application and provide me a link to your application? This will allow us to check your settings and run some tests to fix the mentioned problem.

To add our Support Team as a collaborator, you need to do the following steps in the Bubble Editor:

Settings > Collaboration > Add email support@zeroqode.com

Note: avoid the warning message regarding the plan, as we are an agency and you can easily add us to your collaborators.

Looking to hear you soon.

Regards,

Alright, added, thanks for letting me know about the warning message. The relevant page is print_order.

Hi @quinn, thanks for the provided access.
Indeed a strange thing with the dynamic value missing. I’ve passed it to the developer team for research. Once any results will become available, I will let you know asap.

Thank you for understanding :pray:

Regards,

Hi @quinn, thanks for your patience.
The above-mentioned issue might be related to the fact that in your app you are also using the '“Print HTML” plugin, which interfere with our plugin (not allowing to insert dynamic value in “Print Element” action).
A solution, in this case, might be to remove both of them and install back only our plugin.

In case after this change the issue will persist, please contact the Bubble support team as this issue appears only within your app.

Meanwhile, as a workaround, you can use another plugin action, which works.

Hope this helps. If there will be any other questions, please let me know.

Regards,

Hi Serghei,

That workaround worked. Thank you so much for helping with that. Have a great day!

Sincerely,

Quinn

1 Like

Hi @quinn, glad to hear that our solution helped :hugs:

If you like our plugin, we would be grateful if you can rate it by going to the Plugins tab in Bubble editor. Find the plugin by name and it gives it as many stars as it deserves

The more feedback we get, the more motivated we are to make things better in Bubble.

And, of course, if you will need any other help with our plugin default functionality, please let me know :wink:

Regards,