Templates Plugins Courses

Quickbooks Oauth 2.0 Plugin for Bubble application authorization failed errorcode=003100; statuscode=403

Need Help with Quickbooks Oauth 2.0 Plugin for Bubble. We’ve had great success testing it with a sandbox company. After testing multiple API calls we linked it to our production company and completed the necessary scopes and authorization’s on the intuit developer page.
We are able to generate Access tokens, so the refresh token and authorization works correctly.
However we are unable to do any API call as we keep receiving this error: {“warnings”:null,“intuitObject”:null,“fault”:{“error”:[{“message”:“message=ApplicationAuthorizationFailed; errorCode=003100; statusCode=403”,“detail”:"",“code”:“3100”,“element”:null}],“type”:“SERVICE”},“report”:null,“queryResponse”:null,“batchItemResponse”:[],“attachableResponse”:[],“syncErrorResponse”:null,“requestId”:null,“time”:1669840143023,“status”:null,“cdcresponse”:[]}
403
Here’s the workflow :arrow_down:


The realm ID is Correct and the authorization bearer is correct so what could be the problem?

Hello @benjamin,
Apologies for the trouble. :pray:t2:

Today, we made an update for Quickbooks. I assume this will solve the problem on your side. Could you please let me know if the issue still persists?

If this did not help you, I would like to kindly ask you to share all the setup (plugins tab), workflows, and your console. Particularly we would like to see the video recordings of this issue. For the screencast recording, let me please suggest using the Loom tool.

Looking forward to your reply.

Regards,
Gulce

Here’s a screen recording, The refresh token is not shown but it is there.
The Basic -Autorization code-, and refresh token both work because an access token is being generated without problem. The API call works with the same setup on intuits developer testing page. And all the scopes (excluding payment) are selected.

Hello @benjamin,
Thank you for the video. :pray:t2:

I’ve checked carefully the screencast you’ve provided and I should point out that your setup looks correct. Due to the fact that we have some additional questions regarding your settings, can you please add our Support Team email to the list of collaborators to your application and provide me a link to your application? This will allow us to check your settings and run some tests to fix the mentioned problem.

To add our Support Team as a collaborator, you need to do the following steps in the Bubble Editor:

Settings > Collaboration > Add email support@zeroqode.com

Note: avoid the warning message regarding the plan, as we are an agency and you can easily add us to your collaborators.

Thank you!

Regards,