Templates Plugins Courses

Renaming GoogleDrive file


#1

Hi, I wonder if there is any way to rename the file stored on Google Drive using Bubble workflows? I can see the file in my application, even i can delete it. But there is no rename method. I’m using Google Drive (Service Acc.) plugin. Please help.


#2

hello @marceli i have just added “Rename File” call to the plugin and pushed an updated. Please upgrade to the plugin’s latest version, then refresh the browser and give it a try.
Thanks!


#3

That’s awesome! thanks! but only version 1.0.1 is available. Is there any other way to update than choosing version from Bubble plugins page dropdown?


#4

which plugin are you using exactly? we have a few Google Drive plugins


#5

Google Drive (Service Acc.)


#6

oops, i updated in a different plugin. I will do in Service Acc and will inform you when it’s done
thanks


#7

excelent! I’m looking forward :smile:


#8

Done please give it a try


#9

Unfortunately it does not work. I’ve updated the plugin, I see already a new Rename File Action. I’m calling it but as a result the file does not change its name. It also does not show any error. Debugging step by step go through the action with no result :frowning:

maybe some hint: on “Upload Action” there is “(body) File Name” field but on the rename is “fileTitle”

35 --> 41


#10

are you trying to change the document which was created under the same service account? Service account is different from your personal gmail account. Also according to docs you can’t change the name of files stored in a root directory, only in a second-tier folders. Please give it another try
thanks


#11

Yes, the same Service Account ([email protected][something].iam.gserviceaccount.com)

I did steps:

  1. uploading the file (PDF) steps using:
    a) upload with Upload a File (base64) - success, the file is visible everything ok.
    b) Add file to a subfolder, remove it from root. Everything ok. Parent folder is not root (checked on “.parent.isRoot” property)

then I have tried:
2) rename file (new name ‘theFile.jpg’) - failure, nothing has happened,
3) delete file - success, file was deleted

All above steps using the same Service Account :frowning:


#12

We’ll check this out and let you know


#13

we are going to reach out to Google support as we didn’t find any information relevant to this issue and we tried all the options. I’ll keep you posted once we hear back from them


#14

Thanks! Did you reproduce this issue?


#15

yes, we did, the filename doesn’t change although google returns success