Templates Plugins Courses

Reviewly Template Map Location Question

How do I get the map to populate with locations that I type in the search box, currently it only populates with places of the location that I’m physically in. I’d like to be located in NYC and search for places in Houston for example. For some reason if I’m in NYC it only shows results for NYC without regards for the city I type into the search box.

Hello, @iracrayton. Thanks for reaching out.

The logic of the Reviewly’s search page is the following:

  1. when the index page loads, the app asks you to see your current location > once you accepted this, the address input field fills with your current address > you press “search” and get the results for your current address (the nearest places);
  2. when you type the next address into the search field and press “search” - you will see the list of places on the map, related to the indicated address.

Do you mean here that when you are trying to change the search input and press “search” - you do not get the results for the searched address? Can you please record a video of reproducing this issue, because I can’t reproduce it on our demo page:

Regards,

Here’s the video you requested, when I do multiple searches on the demo app it works correctly. But when I search for other places on my app, I can only receive hits from my current location.

Review App Issue

Hey, @iracrayton. Thanks for the video :slightly_smiling_face:

Regarding your Google API error (one of those 5 issues you have in the editor) - it might help to check this bubble manuals link and set up your Google API keys:
https://manual.bubble.io/working-with-data/setting-up-google-api-keys

Regarding your trouble with the unclickable search button, that you have shown - can you please clarify a few things for me:

  1. have you made any changes to the template, especially to the index page workflows?
  2. have you tried to compare the same workflow reproducing, using your current app and new blank template copy?
  3. have you tried to click step-by-step in the debugger to see what action is being triggered when you’re searching for some restaurant after you have changed the address?

Why I’m asking - I was trying to reproduce step by step your actions on the plugin demo page, but still, when you change the search address or category - the result will always be displayed on the map and below the repeating group. :slightly_frowning_face:

There are 2 more things that I can ask you for, to make it a bit more clear about what could cause your issue:

  1. create almost the same video where you’re reproducing your issue, but in step-by-step mode, just like this:https://ttprivatenew.s3.amazonaws.com/pulse/73s7zq-gmail/attachments/14887670/TinyTake07-10-2020-05-44-57.mp4

  2. create a template copy (new app and using the template as a base), make no changes to it, preview it and check if your issue is possible to reproduce within the blank template copy. The point of this - to make sure the issue you’re facing is or is not a template related bug. Depending on the result I will be able to choose the next troubleshooting step.

As I may presume, the error may be in the workflow for the Search button, but also with the new entries you have created in the database. Can you please re-check your workflow for the Search button, check the step-by-step workflow reproducing via the debugger and make sure you have not changed nothing in the corresponding workflow?

Thank you for your patience and cooperation. :pray:

I got working :grinning: :grinning: :grinning: :grinning:
It was the API Keys :man_facepalming: Thanks for your assistance :pray:

1 Like

@iracrayton,

Oh, I’m glad you make it work :smile:
You are always welcome and feel free to reach us out any time you need some assistance.

Take care.