Templates Plugins Courses

RG to CSV Plugin bug, help!

I have one of my users who’s having trouble with exporting the RG to CSV. Basically:
On some instances it works well
"Pedro Wunderlich","5","3","7","6","210","3","27","Jul 22"

One of my users, the export comes out with extra " and wrong coma placements
"Josue Martínez,""27"",""26"",""1"",""6"",""750"",""10"",""27"",""Jul 22"""

He’s working on a PC. Tried it with Chrome and IE, same results.

Can you guys check to see if there’s any issues?

Hello, @alejandrowunderlich. Thanks for reaching out.

To be honest, this is quite a complicated condition for the issue investigation :smiley:

Without any info on the cases, details of the plugin action setup, features of the data placed in the repeating group, the repeating group setup details - I can suggest you pay attention to the following list of things:

  1. type of a content surrounded symbol you have in your plugin action;
  2. type of a data you have in your repeating group (some dynamic values can be displayed on the table preview, but be empty and in the converted CSV file you’ll get the “”,);
  3. the presence of the character " in the data string.

Apologies, but it’s quite difficult to locate a root cause of a problem with the small amount of details on it.
If you provide us with some more details that can help us understand what causes your issue, we will be able to investigate your case more efficiently.

I hope this info will be useful for you :pray:
Regards,
Kate

1 Like

Hi Kate, looking forward to getting this solved. Here’s the settings I’m using. Standard suff:

  1. The content surrounded symbol I left as is. However, in the case of some users, it is getting added twice.
  2. Most of my data is calculated. I have conditions in place that if the data is either empty or 0, display 0. Anyways, getting a data point as “”, would be ok. The issue seems to be that data is getting double “” and wrong coma placement as in the first column: "Josue Martínez,""27"", <— notice the first column doesn’t have a closing " and the next column has double "" so the data gets messed up.
  3. There are no " " in the data

Simply put, it exports well on a few computers and not in others.

What can we do?

@alejandrowunderlich,

Thanks for the provided details. We will investigate the plugin work/structure in order to find any prerequisites that may cause your issue. It can take some time, so please be patient.

I will let you know once there is any useful update for you or if I need more details on your case.

Thank you for understanding :pray:
Regards,
Kate

1 Like

Thanks Kate! Looking forward to a bug-free world!

1 Like

@alejandrowunderlich,

Our dev team has tried lots of different scenarios and can’t reproduce your issue. The problem you’ve faced is most likely caused not by our plugin.

As you have said, for some instances the conversion of the RG to CSV works well, I can suggest that the main reason which causes the bug is enabled browser extension or any other interfering in the plugin work by the third party library.

There is a probability, that your user has some libraries with text styles (browser extension) or your application has some additional plugin that affects our plugin work.

The last thing I can suggest you is to add our [email protected] email as a collaborator of your app. We will test your application (convert RG to CSV feature) on different browsers in different conditions and investigate the plugin/RG/workflow.

So, if you don’t mind, please indicate the page where you have a problem and provide the access to your app.

Thank you :pray:
Regards,
Kate

Hi Kate, I’ve tried a ton of things and tried to debug the issue myself, but still can’t get it to work for my client. Can I get one of the support members to help me out? I’ll give them access.

@alejandrowunderlich,

Yes, sure. As I’ve suggested to you previously, you can add out [email protected] email as a collaborator of your app to let us test it out and try to reproduce your case and find the solution for it.

Would you kindly add a bit more details also: on what page you have the plugin element and what the scenario to reproduce your case (what to click, what are the preconditions, etc)?

Regards,
Kate

1 Like

Awesome, I’ve emailed @support with all the info needed to access the plugin and view my setup. They’re also now collaborators.

Also interesting note, my customer is using a Windows computer, if that makes any difference. He’s tried all browsers, including downloading new ones and it still comes out messed up.

@alejandrowunderlich,

Thank you for the details! The email is well received. Now I need some time for your issue investigation, testing, and figuring out how your problem can be solved. I rely on your understanding and patience :pray: :slightly_smiling_face:

Once I have any useful updates on your case - I let you know.

Regards,
Kate

1 Like

Thanks Kate, that would mean the world to me!

@alejandrowunderlich,

Apologies, but there is no way I can reproduce your issue. :pray:

I have tried 5 different browsers on 2 different Windows devices (Chrome, Firefox, Opera, Vivaldi, Edge) with numerous extensions added to the browser, and each time I tried converting the repeating group with the user’s statistics - each time the resulting CSV file was without any errors in it.

The case with errors in the CSV file is simply not reproducing on my devices, within your app.

That’s why I’m almost sure that the problem is not in the app or the plugin. The issue can be in the device/environment that your user has.

Can you please ask your user to provide as much details as possible on his case:

  • OS version of the device he’s using;
  • browsers and their versions, that he was using while getting that error;
  • list of extensions, used in the browser, while getting that error;
  • video of reproducing the error.

@alejandrowunderlich, this case is caused not by the plugin - it works well within your app on my devices and the converted CSV file has no errors. The last thing I can suggest is to ask your user for more details. Perhaps the problem is in his device.

Sorry for not being helpful :slightly_frowning_face:
Regards,
Kate

1 Like

You have been very helpful. I’ll gather more data about the issue and get back to you guys. You guys are great, thanks for taking the time to check it out.

1 Like