Templates Plugins Courses

Salesforce Plugin Error

I recently purchased the Salesforce plugin but receive this error when attempting to run a Create Lead call.

The service SalesForce - Create Lead just returned an error (HTTP 401). Please contact the plugin author directly for feedback. Raw error:

[{"message":"Session expired or invalid","errorCode":"INVALID_SESSION_ID"}]

Hello Nick. @nonofrio

Thanks for reaching, let us check this out and be back to you asap.

Regards,
Dumitru.

Is there any update…it has been over 5 days.

hello @nonofrio

Sorry for taking so long, but we do need some time with the plugin here.
There seems some updates were made on Salesforce side which impacted the plugin.
Please bear with us on this one.
Thanks for understanding.

Do you have an ETA on delivery?

Hello @nonofrio

Sorry for late response.
We checked out the demo which works fine one our side. As well we worked through issue you’re getting, there may seem a problem with your salesforce dashboard setup.
Most likely related to your instance which was set. Please check out if you enabled API access for the user/profile?

Setup/Manage Users/Profiles/ < edit the appropriate profile > Administrative Permissions < check API enabled >
It should be the instance_url you got along with access_token (something like na3.salesforce.com, not login.salesforce.com)

https://developer.salesforce.com/forums?id=906F000000099x7IAA

Please do give it a try.

Best,
Dumitru.

API is enabled for my users profile:
52%20AM

is the cURL hardcoded? Is a subdomain supported? ie. https://subdomain.my.​salesforce.com

Hello @nonofrio

We updated the plugin setup documentation for plugin, which seem to mislead users. Please check out - https://docs.zeroqode.com/plugins/salesforce-api-plugin
Sorry for this.

Please check out the setup documentation , and try out our demo setup to replicate - https://bubble.io/page?type=page&name=salesforce_demo&id=zeroqode-demo-11&tab=tabs-1

Once it’s set, wait around 10-15 minutes in order to establish the connection between app and salesforce.

There shouldn’t be any issues, at the moment.

Thanks for patience and understanding.