Templates Plugins Courses

🍏 Sign in with Apple - New Plugin from Zeroqode

Hello @kate, is there a way to catch the error from the plugin? I keep running into an error, but have no visibility on Apple’s end ("…code=400&message=Plugin%20action%20Apple%20SignIn%…"). All configurations in apple are correct. Thanks!

Hello, @pasquale. Thanks for reaching out.

It is. For example, if you’re trying to catch the error while you’re on the app page, where the plugin is used, - use the debugger seep-by-step/investigate mode. But, I’m afraid, it is not possible to catch the error via debugger if you’re on the Apple redirect page or so.

To enable the debugger, add the ?debug_mode=true to the end of your app URL, just like this:

Besides, you can go to the browser’s console and check out the errors in the list, just like this:

I hope this suggestion will be useful for you :pray:
Regards, Kate

@kate thanks for the help! Heads up to anyone having issues - make sure to use your Key that is downloaded from Apple inside of the back-end workflow to log the user in! This fixed my issue. I would also recommend double checking that all of your sign-in configurations are enabled.

1 Like

@Kate I’m running into another issue after the successful login. I’ve tried every configuration possible and the “Remove Params” action and plugin are not working. The element is not automatically removing the parameters. I tried configuring a workflow triggered by “Get data from URL” as well and it still is not working! I’ve added [email protected]qode.com to my app can I please have some assistance with this?

@pasquale,

Thanks

Can you please tell how currently the “Remove Params” action is working on your side now? What is the actual issue - you’re receiving the error message or the the user data is not being removed after the button is clicked? Would you kindly show the debugger screenshots if this trouble? It can help investigate your case.

I have tested the Remove URL params action on our demo page - works OK:


Thank you :pray:
Regards, Kate

@kate - I’ve attached some images of whats going on on my end. In the Logs - it is showing that the user is being signed in successfully, though the user is not actually logged in after the steps. The Authenticate step is successfully going back to the home page, however when the workflow to remove the parameters is triggered, the parameters are not being removed. I noticed in your demo the user wasn’t actually logged in until the parameters are removed. Maybe this has something to do with it? I’ve added Zeroqode as a collaborator so if your team would like to look into whats going on they have visibility. Thanks!

@pasquale,

Thank you for the details :pray:
We will investigate this case with our devs. Please do not remove access to your app. We might need to test your workflows :slightly_smiling_face:

Investigation takes some time, so please wait a bit more.
Regards, Kate

@pasquale,

Thank you for your patience :pray:

We have re-checked carefully the plugin work on our demo page in comparison with your app. Here is the result of the investigation.

To make the Remove URL params action (and plugin at all) work, you need to:

  1. set the endpoint with all settings, guided in the plugin documentation, then hit Detect data;
  2. copy the initialize URL and paste it into plugin element’s Redirect URI field;
  3. now you can preview the app for the first time and hit Sign in with Apple

Please, read carefully this documentation article:
https://docs.zeroqode.com/plugins/sign-in-with-apple-plugin#plugin-api-workflow
You should follow all of the listed recommendations to make the plugin work properly.

Besides, you can recreate our demo page workflow within your app for the test purposes to make sure it will work well on your side as well after you set the plugin correctly.

I hope it helps.
Regards, Kate

Is it Possible to make the Sign In button responsive ? Because for the moment it’s a fixed size :confused: . I have tried a classic Html on it. And it is still not working

Hi, @seeyu.pro!

Thanks for reaching out and for reporting this to us!

We have taken into consideration the possibility of making the plugin element responsive. We need to see how possible it is to implement, but you can be sure that we’ll notify you as soon as we have relevant info. Thanks for understanding :pray:

Best, Julia.

Hi, @seeyu.pro!

So, unfortunately, there is no way to change the button size, because Apple has requirements to their branding and button styles. Please, have a look at human interface guidelines related to Sign in with Apple button.

Hope this helps!
Best, Julia.

Hello Julia,
Thanks for answering !
there is a maximum and a minimum size for the button. But nothing tells us is not possible use the minimum width for a small screen and the maximum one for a big screen.
For mobile responsive for example it could be helpful.

Hi, @seeyu.pro!

Thanks for your feedback. :pray: We did a minimum recommended style that works and quite cheerfully fits into any current (and old) resolutions of Apple mobile devices.

Best, Julia.

Hello Julia,
Thank for that information.
I received two negative answer from Apple just because my sign in with apple button is not working.

Nevertheless, it is working on my side but only for my account. My associate do not succeed to connect via Apple. Would you know where the problem comes from ?

It says identification succeeded and then go to the error page.

PS : And it is not a problematic of version test or version live.

Finally I understand that it is only working to link an existing account but not to create a new one.
I have to publish my app on the App Store and there is only this thing blocking.

I would need some help please @Julia

Hi, @seeyu.pro!

Yes, that’s right, this button is used for Sign in with existing Apple account.

To help you better, could you please share more details like a screenshot of the error message, steps to reproduce the issue and screenshot of the plugin settings.

Meanwhile please make sure that all the plugin settings are configured properly according to the documentation.

Looking forward to hearing from you!
Best, Julia.

Hello @Julia

I was unclear, what I wanted to say , was the plug in was only working when the user already had an existing account on my application. For sure you need an Apple account before.

Ok so first, I have this screen :

Secondly the authentification is ok :

Then I go to the redirection link :

However it goes wrong, so it goes back to the redirection error :

Concerning the settings on Bubble
Here are the captures :

Yes I already checked it three times :blush:

Thank you for helping !
Best , Hervé

Hi, there!

Thanks a lot for the additional info. So, the problem could hide in the first step - Apple Signin-Another user. But anyway, in order not to guess, would be better if you could add our [email protected] account to your collaborator’s list in Settings -> Collaboration so we could check the issue inside your application. Plus, please tell us the name of your Bubble application and page name where you develop it, it would be way easier for us to help you solve the issues.

Note: avoid the warning message regarding Professional plan, as we are an agency and you can easily add us to your collaborators.

Looking forward to hearing from you!
Best, Julia.

Hello @Julia,
Thank you a lot for answering, the only problem is that I am on personal plan not professional plan so I cannot add a collaborator for now.
Maybe the easiest way is to plan a call and I share my screen or I can give you the access to my account if you want so.
The name of my Bubble Application is : Seeyu-V6
And the Page name is Index inside of the group page and the group Inscription g.

Here s the sign in additional details :

Hey, @seeyu.pro!

I’m afraid I can help only via forum (or e-mail, or chat), but don’t worry about the plan. As I mentioned above you just can avoid this message :slightly_smiling_face:

Looking forward to hearing from you!
Best, Julia.