Templates Plugins Courses

Sign In with apple not working- help required

Hi Zeroqode,
I’m having a problem with plugin sign in with apple.
I have followed all the setup guidelines you provided but it seems the the authorize the action Apple SignIn - Authorize User is not working properly or I have set up something in a wrong way.
Every time I sign in it takes me back to my site with this kind of URL Jittr)%0A%20%20%20%20at%20eval%20(eval%20at%20build_function%20(%2Fvar%2Ftask%2Findex.js%3A86%3A21)%2C%20%3Canonymous%3E%3A52%3A32)%0A%20%20%20%20at%20Object.async_fn%20%5Bas%20async%5D%20(%2Fvar%2Ftask%2Findex.js%3A307%3A13)%0A%20%20%20%20at%20eval%20(eval%20at%20build_function%20(%2Fvar%2Ftask%2Findex.js%3A86%3A21)%2C%20%3Canonymous%3E%3A50%3A20)%0A%20%20%20%20at%20%2Fvar%2Ftask%2Findex.js%3A349%3A23&code=400

It would be so nice if you could help me with resolution of this error.

A short video of the issue I am facing.

Hello, @waleed.mudassar
Thanks for using our plugin and sorry for my long reply to you.

As I can see from the recorded video, some of your settings are incorrect, especially the Generated Token.
Due to the fact that we have some additional questions regarding your settings, can you please add our Support Team email to the list of collaborators to your application and provide me a link to your application? This will allow us to check your settings and run some tests to fix the mentioned problem.

To add our Support Team as a collaborator, you need to do the following steps in the Bubble Editor:

Settings > Collaboration > Add email [email protected]

Note: avoid the warning message regarding the plan, as we are an agency and you can easily add us to your collaborators.

Looking to hear you soon.
Regards,

1 Like

Hi @Ecaterina,
The problem was resolved by using version 1.3.0 of this plugin. Please take a look at your end there might be a problem in the latest release of the plugin.
Thankyou.

1 Like

Hello, @waleed.mudassar
Happy to hear that.

I’m afraid that I tested the latest plugin version and it works properly right now. Anyway, in case I can help you with any additional information - let me know.

Best regards,

Hi @Ecaterina,
I have also tested and the latest version is not returning user when returning from apple signin page.

Hello, @waleed.mudassar
Thanks for your investigation :pray:

We will analyze once again the plugin performance and will notify all the users in case we update the plugin.
Thank you for your involvement.

Best regards,

Hello, @waleed.mudassar

By this message, I would like to notify you that the issue, mentioned above, was fixed on our side ( in the current plugin’s version).
Thus, in order to verify it on your side, we propose you add our Support Team email to the list of collaborators to your application :pray:

As we strive to provide the best support to our users, it will be a pleasure to help you with the configuration of the plugin.

Best regards,