Templates Plugins Courses

Stripe Connect- Help

I am attempting to create a stripe marketplace transfer. When I run the workflow, I receive this error: the parameter destination is empty and is mandatory. I’ve attached a screenshot that shows where I’m trying to send the transfer. Can anyone help me with this?


I’ve checked my Stripe dashboard and the connected account shows up… but I’m not able to complete the transfer. I’ve even tried to enter in their account number directly and it doesn’t work that way either.

Hi @troy,

Thanks for reaching out. Without knowing more about your workflows, I can give you a couple of hints that might help. Based on the error, it has to be an ID of a connected Stripe account that is going to receive the funds. However, it is crucial to understand what your Customer ID value is and how you are retrieving it.
Please do check plugin’s documentation here https://docs.zeroqode.com/plugins/stripe-marketplace-express-plugin and pay close attention to each step. Also, this forum thread might be helpful Stripe Connect- Holding Transactions for a Marketplace as lots of questions have been addressed here. Especially, it depends what type of accounts, the sequence of workflow actions, how and where you save the IDs etc.
However, if you still experience the same or any other issue, please share more details, especially screenshots of workflows, describing what you are trying to accomplish, steps to reproduce the issue etc.

Hope it helps.


2 questions @alexandru.rusnac:

  1. If I’m using the Oauth link do I still need to use the Stripe marketplace token? I’m currently not using it in any of my workflows.
  2. The documentation says to save the resulted " stripe_user_id " to the database for future use. I’m not sure how to do that- Is there documentation on that?

Currently users charge customers on my platform, the money goes to my stripe account. I’m trying to setup a button on my platform that will allow a user to withdraw their earnings. I’m trying to accomplish this by using the Stripe marketplace- create a transfer.

Hi @troy,

It really depends on the type of account you use. However, it is not an issue, because you have to set a workflow step where you save the ID in the database. It can be done with Make changes to current user.
If you use Create a seller action, you can check our demo editor here to preview the settings - Zeroqode-demo-19 | Bubble Editor.

Also, sorry for misleading, but I noticed that it’s the Customer ID inserted, rather than the Seller ID, which actually has to be passed here:


The Seller ID of your user has to be a value in the following format: acct_xxxxxx. So, when you make the transfer, you have to be sure that the destination is the value of this type. This value/account you can locate in your dashboard/connected accounts on Stripe platform.

Hope it helps.

@troy Thanks for asking the question. We’re implementing a similar flow and learned from @alexander‘s response.

If you don’t mind, could you share how you configured your transaction workflow? Most of the inquiries here (demo included) seem to implement the Shopify model where the seller charges the customer directly. Our approach is more along the lines of Lyft, where we as the platform charge the customer and disburse to the seller at a later date.

In this model, Stripe recommends starting with a paymentIntent. Did you go this route or something more simple?


1 Like

Hi @ben2, thanks for tagging me and sorry for delayed response. Let us check on this use case and I’ll come back with a reply asap. Thanks :pray:

Hi @ben2,

I can see that my colleague has already replied to your request here Platform Transactions and Purchase Error and your cofounder’s request here 💳 Stripe Marketplace Express Checkout - New Plugin from Zeroqode.
Additionally, you could check this thread Stripe Marketplace Plugin Help: Trouble Configuring + Setting App Fee in Cents perhaps for some more insights.

Hope it helps.

1 Like

Hey Alex,

Long time no talk :wink:

I went to test with real payments today in the non-test environment. For some reason the button that turns on express connect is generating an invalid link on the deployed version but not the test. Any idea why this may be?

This is what it generates: Stripe

Hi @alex4,

Long time no talk, indeed. I hope you are doing well. So, in order to try and eliminate this issue, please check our docs and please make sure that you are using Live API keys for the live version of your app, and Test API keys for the version-test. Also, this refers to the secret ones and the client ID as well.

Hope it helps.

Looks like it matches what is in the docs. Probably should have mentioned that it wasn’t the keys.

To further plan in advance, here is a screenshot of the present workflow, in case it helps. I also tried with adding a redirect_uri, but it didn’t make a difference (still worked on test but not live).

I contacted Stripe support as well to see if that helps but the language is a bit advanced for my understanding:

Looking into your account the logs show that the error being passed is “Unrecognized request URL (GET: /v1/accounts/). If you are trying to list objects, remove the trailing slash. If you are trying to retrieve an object, make sure you passed a valid (non-empty) identifier in your code.”

Hi @alex4,

Thanks for this feedback. Unfortunately, this issue is not reproducing on our side. We have tested multiple times, and if the API keys + client IDs are configure properly, you should be good to go. Please make sure that the Client ID one is different than Client ID - dev., because these IDs should be copied from your Stripe dashboard, first one you get based on live data, then the second one you copy from viewing in test mode.

This issue isn’t related to the redirect_uri, so you should be good so far.

As for this reply, I’m afraid it doesn’t relate to the mentioned issue, unfortunately.

Please check on the API keys and Client IDs again, then give it a try!


Double-checked and the codes are all correct.

However, the error code I looked into more. Looks like that code is happening on the test end as well. Yet the live end just doesn’t link anywhere, whereas the test link still takes you to the express link.

here is the error bar associated with the above error message.

Looks like I had successfully connected one account before so I’m not sure what’s going on…

I’ll add you as a collaborator again. To inspect. As a reminder, it is found in userprofile page and the workflow is green.

This results in “this link is invalid or expired”

In test, this happens and shows the test express connect:


Hi @alex4, thanks for this feedback! Please let us check on it with our development team again and I’ll come back with another update on this matter asap. :pray:

1 Like

Hi @alex4,

Thanks for sharing your app. We’ve found an issue that should’ve caused the problems. The Client ID has been entered with a space, before the actual value. Please give it a try again, as it should be working properly by now, if all Keys/IDs are correct.

Hope it helps.

oh wow. That is so minor. Kind of hilarious, but also exasperating.

Thanks so much for finding that!

Hey there again,

It’s Alex4 with the Error of the Day! Wowza. Looking forward to knowing what all these errors mean when we’ve faced them all.

Was testing payments again to make 100% sure they work and this error occurred:

Workflow error - The service Stripe marketplace - Seller charge a customer just returned an error (HTTP 400). Please contact the plugin author directly for feedback. Raw error: { "error": { "code": "parameter_invalid_integer", "doc_url": "Error codes | Stripe Documentation", "message": "Invalid integer: 800 500", "param": "amount", "type": "invalid_request_error" } }

Here are the two associated screenshots.

What do you think is happening?

Hi @alex4,

No worries, let me shed some light, as the reason is clear:

As I can see, you’re trying to add two values and calculate:

But, the way it is implemented:

It doesn’t recognize it as an addition operation. It just adds the “+” symbol. So, the way it has to be done properly, is after Current USer’s activeprice * 100 you have to click More… and actually select the Bubble’s + operator, and it will be colored in blue, which is the correct indicator. (similar to the * operator, which is blue as well)


1 Like

Oh wow. Definitely gotta watch out for that in the future. Thanks!