Templates Plugins Courses

Stripe Marketplace Express and Saving stripe_user_id

We are currently using the Gigster template and attempting to integrate the Stripe Marketplace Express template. We want sellers to be able to register using the Connect Express experience. We have implemented the Connect express/standard account action using a button on the profile page and Stripe marketplace - Complete express/standard account connection on the redirect_url page (index). We can click on the connect account button and bring up the Stripe Express UI. When we compete the flow, the page redirects back to index page with the code query parameter set.
The issue we are facing is that we are not able to save the returned stripe_user_id to the associated user data type. Below are screenshot of our config:

screenshot-bubble.io-2020.05.27-16_56_23 screenshot-bubble.io-2020.05.27-16_56_01 .

1 Like

Hello @john1, thank you for reaching out!

Could you please check if you have the parameter in the URL after the redirect on the index page? Also, did you enabled Connect in the Stripe dashboard?

Best Regards,
Alex

Thank you for the reply @alex.grimacovschi. It was user error. I didn’t have the "Bearer " prefix in the plugin config. I will say that it’s odd that you need to put that in the field that asks for an API get. The auth implementation should be hidden IMO. It wasn’t very obvious in the docs.

Hello @john1, got it. Glad to hear that the problem is solved. I will send to our team that the process of editing the key is not obvious and that documentation needs improvement.

Best Regards,
Alex

Hello,

can you please tell me how to find which redirect uri I should use. I’ve tried Stripe Authentication but after stripe express connect record all my information, I’m redirected to bubble with this address and the code but it says “sorry, impossible to connect with stripe”.

It seems that you got another redirect uri in the previous screen shot, I would be happy to know where I’m supposed to find for my platform.
In addition, is it the same redirect uri that should be on stripe side in connect parameters?

Thanks a lot for your help,

Steph

Hi again,

it there something to configure also in the bubble settings?

Hello, @stephanie.novain. Apologies for the delayed reply :pray:

Stripe Authentication URI is used for the Bubble Stripe plugin.
But if you are using Stripe Marketplace Express plugin by Zeroqode, you can indicate the URI of your app’s page, where you want to redirect your users after completing the authorization (after Stripe Express Connect record all your information).

Would you kindly check and confirm?

P.S.: some useful info:
Stripe Marketplace Express Plugin - Zeroqode Documentation
https://stripe.com/docs/connect/oauth-reference

Regards,

1 Like

hi, @kate
I instolled Stripe Marketplace Express plugin, and facing same trouble.
As @john1 attemped for the 1st picture, I can input Redirect URi wherever I want.
And how about this page?
https://dashboard.stripe.com/test/settings/applications
Which uri should I set?

Now, I set
https://myapp/version-test/poststripeauth and
https://myapp/poststripeauth

What I am facing is I reach to https://myapp/version-test/poststripeauth page, which my app doesn’t have such a page and cause 404 error.
so, I made /poststripeauth page, but nothig happen.
I mean I can’t get Seller ID.
Beacuse of this trouble, I can’t transfer money to the sellers.

I need your help, Kate

Thank you,
Keitaro.

Hello, Keitaro.

Let me investigate your request. It might take some time, so please wait a bit :pray:
I will let you know the result once I have any useful guidance/tips for you.

Regards,

Hi @kate
Thank you so much for your kind.
I am looking dorward to hearing the solutions

@immortal.solution.kn, thanks for your patience :pray:

First of all, let me please make sure that you have done the following steps correctly, to register your user as a seller:

  1. Preconditions:
  • add the “Bearer” text into your secret API leys;
  • enable Stripe Connect.

You can leave the Redirect URI field (in the Connect express/standard account action) empty:


If you do so, the plugin will be redirecting the user to the URL you have set as a default in your Connect Settings section (in the Stripe account). The “Redirect URI” field is used when you have a lot of URIs in your Connect Settings section.

  1. How to get the Seller ID:

I hope this info will be helpful.
Regards,

Hi, thanks.
First of all, I confirmed that I added “Bearer” into my API keys.

What does this sentense mean?

Do you mean I need fill in with all of the URLs, bucause my app user can access from the header of all page?
As I said before, my app doesn’t have “/poststripeauth” page. Do I need make “/poststripeauth” page?

I understand the second step (but not test yet. I will after my questions of step1 are solved.)

I have really poor knowledge of the web development, because I am not an enginnerm but am a bubbler (lol).
So I really appriciarte your support. Thank you.


Now, I added these URIs into my Stripe dashbord.

You told me that I need add all of the uris from which the app user access?
So, the URIs I need add is
https://myapp/version-test and https://myapp
https://myapp/version-test/a and https://myapp/a
https://myapp/version-test/b and https://myapp/b
https://myapp/version-test/c and https://myapp/c … and so on?

Again,
I changed my app that user only can access registration to stripe from a specific page.
(https://myapp/version-test/profile)
When I test, the 404 error doesn’t happen, because there is a page, of course.
BUT, nothing happen.

According to your explanation and link, I need use workflow of “Complete express/standard account connection”. Yes, I did.

I was thoght that the "Stripe Seller ID"is automatically registerd.(not manually)
If we should do it manualy, how can I make workflow?
make cahnge current user’s “Stripe Seller Account’s ID” can be made.
We can’t access.

Also, I have one more question,


I can’t understand the meaning of this document.
I think “complete express/standard account connection” is the last workflow of connecting seller, but this sentense seems that I should send “code” to stripe after this action.

@immortal.solution.kn, apologies for the delayed reply :pray:

“Enable” Stripe Connect means that you have activated the Connect functionality (for the live version - you need to activate your Stripe account, but for test version, it is not needed) - in the previous Stripe version it was needed to enable/activate the Connect functionality, before creating Sellers in your app:


A useful thread to read:
💳 Stripe Marketplace Express Checkout + SCA 3D Secure - New Plugin from Zeroqode - #96 by ZeroqodeSupport - Showcase - Bubble Forum

I mean here, that in the Redirect URI field you need to indicate the exact page to which you want to redirect your user after completing the Stripe registration. If you leave that field blank, the app will redirect your user to the default URI, that you’ve set in your Stripe Connect settings.

In your Stripe dashboard you should indicate URIs for both live and test mode of the page, where you’d like to redirect your user, like:
https://example.io/redirect_page;
https://example.io/version-test/redirect_page;
https://example.io/version-test/redirect_page?debug_mode=true

One more useful thread to read:
Stripe Marketplace Plugin Help: Trouble Configuring + Setting App Fee in Cents - #3 by alexander

The Stripe seller ID is being created once the Create a Seller action is completed successfully - you can find the Seller ID in your Stripe Dashboard > Connected Accounts > Account. You can save the Seller ID to your database by creating an action “Make changes to current user”.

Some more info here:
Stripe Connect- Holding Transactions for a Marketplace - #15 by alexander

You are right, this is the last step of the Seller registration. Once the Connect express/standard account action is completed successfully, the user is redirected from Stripe to your platform (by the redirect URI link you’ve indicated). And once a user is redirected from Stripe, the URI already contains the code.

To “send this code to complete the onboarding”, you need to create the Complete express/standard account connection action and into the (param)code field type the Get code from page URL value - this is how you send the “code” to Stripe.

I hope this helps :pray:
Regards,

hi @kate

Great thanks for your kind.
I finally install stripe workflow properly.
I appreciate your help!

Best regards,

1 Like

Hi Kate, Do you guys have any templates that used the Stripe Marketplace Express? Thanks.

Hello, @AlkamTursun.

No, I’m afraid, we don’t. Generally, we use Bubble’s Stripe plugin and some custom Stripe API calls.

:slightly_smiling_face:

1 Like

Hi there,

I’m having the same issue discussed above saving the Stripe seller ID back to the StripeSellerID user attribute. I’ve verified the following.

  1. Confirmed Stripe Connect is enabled in Stripe Dashboard (Both Live and Dev)
  2. Get url parameter is set to code, and the Seller account is being created in Stripe.
  3. I created a data type for users- Stripe_SellerID, the Get url parameter is updating this field, however I cannot update the StripeSellerID (Thats hardcoded to the Marketplace Express plugin) attribute through a workflow.
  4. The complete express/standard account connect is set up

Is there anything else that could be stopping this from updating? I see the accounts being created in Stripe dashboard and the Stripe seller ID matches the value thats being updated to the user attribute i created to update the Stripe seller ID. However, the StripesellerID (Hardcoded) remains blank… What am i missing?

Hello, @jebrathwaite
Thanks for reaching out and sorry for my long reply.

First of all, please allow me to recommend you this tutorial, which was created by our team for the correct plugin configuration:

Also, please check the "Bearer " prefix in the plugin configuration.
In order to investigate your issue in more detail, can you please share with me the screenshots of the error and the settings of the step, that reproduced the error?

Looking to hearing from you soon.
Best regards,