Templates Plugins Courses

Stripe Marketplace Express Error with Saving Stripe Seller ID

Hi -

I’m having an issue with my platform saving the stripe Seller ID once someone connects. This was a template “Booky” that I am trying to convert to your plugin Stripe Marketplace Express just so I can have users connect as an Express account. I have setup the below workflows:




The seller’s ID is successfully being captured in my database per the above workflow, however, when I go to use the formula “Current User’s Stripe Seller account’s Id” which can be found on the page ‘Instructor_profile’ from the booky template, it is empty. However, like I said before, the seller_id is being captured in my db and demonstrated in the below screenshot:


The reason this is becoming an issue is because when I follow the rest of the workflows for charging a user/transferring payment to sellers, I get the below error. This error does not appear when a user’s “Stripe’s Seller Account’s ID” populates correctly:

I know this is a ton of screenshots but hopefully it will help you understand the issue I’m having. Also, I’ve gone through the template and pluging documentation thoroughly so please don’t suggest that as a solution :slight_smile:

Thanks,

Hello @anthony.woodard91

Thank you for reaching out.

I would like to kindly ask you to check if you have the following things and make some changes to your settings:

  1. Please have a look if you have “Bearer” written in the API settings, see this screenshot: Screenshot by Lightshot
  2. Remove the “debug_mode=true” from Redirect URI.
  3. Please check that the Redirect URI you have in your Bubble settings is also present in your Stripe Dashboard.

Also, please can you specify what you use “Create ID Number Token action” for?

Please let me know if it solves your issue.

Looking forward to your reply!

Hi @Kirill -

  1. Yes, I have confirmed that “Bearer” was added to all of my secret keys.
  2. I’ve removed the “?debug_mode=true” from my redirect URI’s in both my app and from stripe.
  3. Confirmed the links are in both bubble and stripe. I even double checked that it is in the test mode of stripe.
  4. For some reason, I thought this was required based on the documentation and some videos I watched for setting it up from Lachlan Kirkwood. However, I just removed it and tried again but no luck.

Is the statement “Current User’s Stripe Seller Account’s ID” being used through the bubble stripe plugin and not Zeroqode’s Marketplace Express plugin? Could this be the reason why they’re not talking to each other? I would think that it should still have the same connection to stripe though.

Sorry for the late reply @anthony.woodard91

The Stripe Marketplace Express has a built-in data field that you can refer to in order to show the ID, and it is the "Current User’s stripe_SellerID.

Due to the fact that we have some additional questions regarding your settings, can you please add our Support Team email to the list of collaborators to your application and provide me a link to your application? This will allow us to check your settings and run some tests to fix the mentioned problem.

To add our Support Team as a collaborator, you need to do the following steps in the Bubble Editor:
Settings > Collaboration > Add email [email protected]

Note: avoid the warning message regarding the plan, as we are an agency and you can easily add us to your collaborators.

Looking forward to hearing from you!

@Kirill Thank you and I completely understand the delay considering the holiday weekend.

I have just added your team as collaborators now and you should have access.

I’ve made some changes over the weekend that has now lead me to this error:

{
“error”: {
“message”: “You cannot create a charge on a connected account without the card_payments capability enabled.”,
“type”: “invalid_request_error”
}
}

In addition, here is a screenshot of all the test connected accounts in my test instance of Stripe:

Hopefully you all can figure it out.

Thanks,

@Kirill It looks like I was able to resolve this error now as I was missing the add capabilities of “card_payments” when creating a seller.

However, I do have two followup questions that I’m hoping you can assist with:

  1. To add another capability such as transfers, what is the delimiter I should add after “card_payments”
  2. When I’m signed in as a seller account who has already signed up through stripe but I click the button again, it doesn’t take me to a login screen, it brings me through the whole sign-up process again.

Thank you for your questions @anthony.woodard91

It’s great that you have found a fix for the card payments capability issue.

  1. To add additional capabilities, you need to write them as an array-like card_payments,transfers. Please make sure that these capabilities are also enabled in your Stripe account, otherwise, it will not work.

  2. You will have to customize the workflow for the button which signs up the user with Stripe, for this you can use the “only when option” in the action you are trying to customize. You can also add workflow to bring the user to the page you want to go with the action go to the page/only when the user is logged in as Stripe seller.

Please let me know if it helps.

Wishing you a wonderful holiday season :slight_smile:

@Kirill

  1. I was successfully able to add the card_payments capability, however whenever I try to add “transfers” as you’ve suggested above (separated by a comma), I am getting this error:

Here is a screenshot of the settings for connect:

  1. I understand having to use the “only when option” but am unsure on which element action to use for users that have already registered and just want to login to update their settings. For this case, should I be using the Connect express/standard account action and changing the action type to “login”? Only issue I found with this option is that it still redirects users to the register page of stripe rather than logging in. On the other hand, there is the Stripe marketplace - Create dashboard link (Express only) action, but again am running into an issue where it doesn’t do anything except for the load bar at the top going. Here’s a screenshot of the workflow and settings.

Am I supposed to add another action after this one?

Really appreciate your help!

Hi @anthony.woodard91

Thank you for your questions.

  1. The action "connect express/standard account works only with one capability, which is “card_payments”. Other capabilities such as transfers, card_payments should be written in the “Create seller” action or “Update seller” action. The bank account, create seller, and update seller action only work with the customer accounts. Therefore, you should have the capabilities set to “card_payments” only, as you are using connect express account action, but if you want to use custom accounts, then you can replicate the way it is done in our demo editor.

  2. Please allow me to mention that we are not able to customize each of our user’s app, we are only allowed to point the user in the right direction if the user is confused or doesn’t know how to set up a plugin. However, I’ve tried to reproduce your use case with the following workflow, have a look at these screenshots: first action, second action, third action, fourth action. Please try to replicate this workflow into your own app and see if it works

Please let me know if you have any other questions.

Happy Holidays :christmas_tree:

@Kirill

  1. Thanks, so to confirm, since I am already registering users as express accounts I don’t need to add the “transfers” capability, just the “card_payments”?

  2. Thanks for the screenshots I have it setup now! It’s sometimes cumbersome referring to just the demo as there are numerous workflows on the main page.

Thank you for the questions @anthony.woodard91 :slightly_smiling_face:

  1. Yes, in this case, you should only add card_payments capability.
  2. I am glad you have set it up! It might be time-consuming but it is definitely worth it.

Please let me know if you have any other questions.

I hope you have a nice and warm holiday season :snowflake:

1 Like