Templates Plugins Courses

Trouble With Twillo Integration (Send Text Message Bubble)


#1

Hey there,

I’ve followed all of the instructions and still getting the following error:

Raw error from Twilio - Send Text Message: {“code”: 20003, “detail”: “Your AccountSid or AuthToken was incorrect.”, “message”: “Authentication Error - No credentials provided”, “more_info”: “https://www.twilio.com/docs/errors/20003”, “status”: 401}

This was the base encode generated which I’ve put in the plugin as the authorization header - is there something that i’m missing?:
QUMzNDg5ODI2ZWU3NTJkMWZiYTMwNTY0ZDVhMTgxNmE3MDo0MTY1MjIwNDViNTdiZDY1ZmEwMGFhYzllMzdiMDAzZA==

Also, I’ve added the account SID in the workflow.


#2

Figured it out needs to be Basic in front - have another error but think i can figure that out - thanks!


#3

Glad you found the way to fix it, if still in trouble let us know! :slight_smile:

Levon Terteryan
Founder @ Zeroqode & Bubblewits

let’s stay in touch on twitter!

zeroqode-for-web-160x120

Bubble Templates
Bubble Plugins
Bubble Courses
Convert Web to iOS & Android
No-code Development Services


#4

hello
I’m getting the same error. How can we get it to work?
Thank you!!!


#5

What do you mean by this?


#6

@jlaufer1989 would you kindly share a screenshot of your twilio settings? it would save us time to help @heidy
thanks!


#7

Hi Thanks for the fast response. These are the settings on the workflow


#8

But you also need to setup the authorization credentials in the plugin


#9

This is how we set it up


#10

In the authorization header you should write
Basic (then space, and then the secret key) so it would be something like this
Basic ASf2r2fWef2fgopjp5835nF


#11


tried this and getting the same error.
Ae we doing anything else wrong?


#12

It worked. Thank you!!!


#13

I am also getting this error. I have updated the Authentication key to say “Basic” followed by the key. Here are some screenshots:

(more screenshots to follow in seperate posts as I can only post one image per post)

I just activated Twilio today, is it possible things just need a bit to get synced?


#14

56%20AM


#15

38%20AM


#16

yes, try waiting a day or so, perhaps it’s not active yet, and also check their dashboard for any hints (maybe you are using development keys instead of live or didn’t get a from number etc.)


#17

Hi, I am still having this issue. I am using the only Auth and SID codes I can find in Twilio.