Templates Plugins Courses

Twilio Plugin Not Responding

Hey there. I’ve installed the Bubble Twilio plugin, but it’s not displaying any error messages or messages whatsoever.

Here’s what I did:

  1. Copied and pasted by Sid and Authtoken into https://www.base64encode.org/, like this: [mySid]:[myAuth] (in other words, 1234:1234)

  2. It spit out a code, and I pasted that in my Authentication Header settings in the plugin, like this:

  1. I then set up a workflow when I click a button:

Can you tell me what I’m doing wrong? The documentation was really difficult to follow, and I could only find one other support topic on this. I’m not sure if:

1 - You aren’t actually supposed to use the Base 64 encoder.
2 - You are supposed to use the encoder, but not actually type the “:”
3 - You’re supposed to only use the Live key

Some screenshots or a video would be really helpful. I worked at it for an hour, but can’t get anywhere.

Hi,
you should encode the credentials and put the word Basic before the encoded key with a space between them
the sender phone might actually start with 1? (12153302164)

Hi @levon thanks for answering so quickly! Unfortunately, I did that and it didn’t work. Here’s exactly what I did, let me know if I missed anything:

  1. I copied and pasted my Account SID and Auth Token, into the Base64 Encoder, as such:

AccountSID:AuthToken
AC5652987465:RC568734587432

  1. The Base 64 encoder spit out something like this: QUMzNjU0NmY1MGdskljSDJFDSAsdjkfljdsklfdSJDFDJSjk4OQ==

  2. I went to plugin settings, and wrote: "Basic " (including the space)

  3. I pasted the code after, like this: Basic QUMzNjU0NmY1MGdskljSDJFDSAsdjkfljdsklfdSJDFDJSjk4OQ==

  4. In the workflow, I pasted my Account SID in the path(Account Sid) field, and filled out the body, receipient, etc.

  5. When I click the button, I get no message at all - not any errors, no Bubble pop-up, or anything.

we’ll check it out but meanwhile you could also try Copilot’s twilio plugin

@levon, @jeremiah: Was his issue ever resolved? I don’t understand the step #4 and #5 in Zeroquode documenation for Twilio. What URL is being referred to here:

  1. Insert the Account SID parameter for the URL

  2. Fill out the senderphonenumber, recipient and message parameters (don’t use hyphens for these fields or “+” for the phone

Thanks

Greetings, @dhawan_30!

Thank you for contacting us.

I’ve tested it a couple of times and the issue was not reproducing on our Demo page. Using the trial number from Twilio as a senderphonenumber and my own number (which I have verified) as a recipient, I am getting the messages.

These steps are requiring actions in your editor. Using our Demo page as an example, you can build inputs for inserting senderphonenumber, recipient, and message text: https://prnt.sc/13o1fk7

In the workflow trigger the plugin action “Twilio - Send text message”. In the action fields, you indicate the dynamic data - input value https://prnt.sc/13o1i0w.

Regarding URL it was a bit confusing, so, based on your feedback, we’ve changed it in our Demo page:)

Hope I’ve managed to clarify these points for you.

If you’ll have any additional questions, please, let me know.

Best regards.