Templates Plugins Courses

Twillio API for Whatsapp

Hi, it’s there any possibility of allow to send media (photo or video) trough the message body ?

Hello @mors.zr, hope you are doing well.

Unfortunately, there is no possibility to send media files with the plugin at the moment. I will get with the Devs team regarding the feasibility of such improvement. Once there will be any updates on the topic I will get back to you with a message.

Thanks you for your patience.
Have a good day!

Hi @mors.zr, hope my message finds you well :slightly_smiling_face:

Following your suggestion, we have added the requested feature (send media through the message body) and pushed a plugin update.

To check changes, please upgrade your plugin to the latest version (Version 1.4.0: Added media field) and give it a try.

Please note that if you use the default Bubble uploader element for file upload, within the related field it is required to write https:before upload element value (because the link for the uploaded file doesn’t contain https part).

In case there will be any other plugin-related questions, just drop a message here :wink:
Regards,

1 Like

Hi @Serg ,

This will be invaluable but, I can’t get it to work. I’ve tried hardcoding a URL into it and nothing comes through in my message.

This is the URL I’m using: https://cdn.sci.news/images/enlarge9/image_10688e-Rainbow-Lorikeet.jpg

Please help and tia.

Hi @cousens, thanks for your message.

Please share the used setup for your use case, it will allow identifying any issue much faster.

Looking forward to your reply.

Regards,

Hi @Serg

Thanks for your reply.

I’m using my SID and Token repeated in those fields which are blanked out. I initially only had them in Username and Password but through I’d try in the others too. It also didn’t help.

And then this is how I’ve configured it to send a message with an attachment.

I have also tried the other send method with no luck either (Whatsapp with Media).

Thanks in advance for your help,

Chris

Hi @cousens, thanks for the provided details.
Allow me to check this internally, and come with feedback asap.

Thank you for understanding.

Regards,

1 Like

Hi @Serg

Any luck in checking this out?

I still can’t get it working.

Hi @cousens, sorry for the delayed answer.

Today, we’ve have pushed a plugin update, that has fixed the issue with sending media files enclosed to message, so the “Send message” action should work properly now.

To check changes, please upgrade your plugin to the latest version (Version 1.5.0: “Updated plugin actions and deprecated Autopilot”) and give it a try.

If there is anything else that I can help with about our plugin, please let me know.

Regards,