Templates Plugins Courses

Using Finnish addresses - AirBNB template

Hi all!

I’m trying to use some Finnish locations with my AirBNB template, but not having much luck. Trying to add a new property with eg. Tampere (city), or any specific street address as location results in an empty listing… I’m not exactly sure why, so it’s hard to try fix it.

The documentation has mention of this, but I don’t have enough experience yet to understand how to make it work. Could anyone be able to help out? I’ve just set-up a new template and haven’t touched it further, so I can get this working before I continue. HomeBNB - Rentals like AirBNB Template

Finnish address example:
Yliopistonkatu 2, 33100 Tampere (street name, street number, zip code, city or municipality)

Thank you!

Hi @skirwick,
Thanks for reaching out!

We’ve checked your app using the provided link and everything appears to be working fine on our side (Screenshot by Lightshot). If we have misunderstood the problem, it would be helpful if you could share a screen recording showing the issue you’re experiencing. :pray:

Looking forward to your reply.

Best regards,

Hi @Gulce !
Sorry I could have been clearer with my explanation. So, the search and input fields all work yes, but if you go through with adding the property, the listing itself will be empty. No images, no description, no anything!

Edit: Now testing with Paris and New York, they’re not workin either… woott
Edit 2: I now even made a test site and just connected the map API, nothing else. And still the same thing, even with using Paris as location, which at least used to work yesterday :’) HomeBNB - Rentals like AirBNB Template

Hi @skirwick,

Thanks for the clarification. :pray:

Due to the fact that we have some additional questions regarding your settings, can you please add our Support Team email to the list of collaborators to your application? This will allow us to check your settings and run some tests to better understand the problem.

To add our Support Team as a collaborator, you need to do the following steps in the Bubble Editor:

Settings > Collaboration > Add email support@zeroqode.com

Note: avoid the warning message regarding the plan, as we are an agency and you can easily add us to your collaborators.

Looking to hear you soon.


Hi @Gulce ,
the support team should now be added as collaborator!
Site names is “AAAAA”, beautiful I know. :slight_smile:

Thanks for taking a look :pray:

Hi @skirwick,
Thanks for providing access!

Please allow us some time to thoroughly examine your app. I will personally reach out to you as soon as possible with our findings and any necessary updates. Thank you in advance for your patience and cooperation. :pray:

Best regards,

1 Like

Hi @skirwick,
Thank you for your patience. :pray:

I apologize for the delay in investigating the issue you’re experiencing. Upon further investigation, we have identified that the problem is related to your “Geocode API Keys”. Please see the error message in the server logs:

To resolve this issue, I kindly ask you to double-check your API keys and ensure they are properly configured. Here are some useful links that can assist you in this process:

Hope this helps. If you need any further assistance, please don’t hesitate to reach out.

Best regards,

1 Like

Hi @Gulce , thanks for checking it out!
I suspected it might be the API:s but wasn’t sure what in them… Turns out I had put website restrictions on both of the Server and Client keys, when it should only be on the Client key… 8’) Such a silly problem asdlakjs.

Well this solves it, and wasn’t related to finnish addresses afterall. :joy:
Thank you!

@skirwick Glad to know it is sorted now! :slightly_smiling_face:

Let me know if I can help you with anything else.

Have a good day!