Templates Plugins Courses

Video Connector Plugin for Bubble (missing)

Hi. I have purchased the Agora Video Connector plugin for Bubble.io, but cannot get it to work.

The steps I took were as follows:

  1. I copied the demo page from the following link and pasted it into my project: https://bubble.io/page?type=page&name=agora_connector&id=zeroqode-demo-19&tab=tabs-1

  2. Entered my app ID from Agora into the plugin settings.

  3. The Agora Connector Plugin says “missing” when I load the preview.

Liam

Having the same problem… Purchased it and it’s not working

Hello, @bloom3799.

First of all, please make sure that when you copied the page from the demo, you did not miss the workflows and plugin elements. Also, please check if the Agora plugin setup was correct (all IDs in the plugin section were set correctly).

@Nicuzz, hello!

Can you please describe in detail your issue? How did you set up your plugin - the same way as @bloom3799? If no - could you share what exactly is not working and what steps you have taken.

Friends, I have tested the plugin on the demo page and it is fully workable. Thus, I presume that there is something wrong on your end.

Please add our [email protected] email as a collaborator of your app.

The support email can be added as a collaborator even if your Bubble subscription plan is not a Professional.

I will check if there is something wrong on your side, by investigating your apps as a collaborator. Thank you for understanding :pray:
Regards,

@Nicuzz & @bloom3799
just wanted to also share the link to the plugin documentation in case you missed it: https://docs.zeroqode.com/plugins/agora-api-connector-plugin

and this demo page: https://bubble.io/page?type=page&name=agora_connector&id=zeroqode-demo-19&tab=tabs-1

Hi Kate,

When I copied and pasted the page, the workflows and plugin elements also got carried over. I am attaching a screen shot of the plugin credentials (img 1), the design view (img 2) and the page preview (img 3).

I am also attaching a shot of my elements tree and workflows view.

Furthermore, I have contacted customer service at Bubble.io. They asked me to delete the page and the plugin and reinstall it, then try pasting the page again. Those steps did not work, so they suggested I contact you.

As far as I can see, everything should be working as it should, so I’m lost of answers at this point.

I hope you can help!

Liam

@bloom3799, thank you for your screenshots. But I’m afraid we need more information on your issue, to figure out its root cause.

The plugin documentation contains the Error management section, which can be useful for error inspecting: https://docs.zeroqode.com/plugins/agora-api-connector-plugin#error-management

You can check what kind of an error has occurred within your app by adding to the end of your page URL the ?debug_mode=true text and pressing the “Inspect” button for checking the element: http://prntscr.com/sf7m39

Please inspect the element “missing” within your page and share the screenshot from debug_mode.

Also, I would like to suggest you add our support email as a collaborator of your app, so we can check and find the root cause of your issue faster [email protected].

Thank you for understanding :pray:
Regards,

Is it possible to move the agora API to another bubble account? I purchased it with the wrong account and was wondering if I can transfer it to another bubble account.

Hi Kate. I am on the personal plan and would need to upgrade to the professional plan in order to add collaborators. I’d be willing to do that as a last resort. Would you be willing to login to my account directly if I give you my credentials instead?

I ran the debugger and have attached the screenshot. In the first screen shot, I selected the Agora Connector A element. In the second screen shot, I clicked on the red exclamation mark (the alert box) in the debugger window. Does this information help you at all?

@bloom3799,

The General error you’ve shared tells that the plugin was not loaded (something caused a failure of the loading). The main guidance on this matter - is a simple page refresh. Or, you may have indicated the element IDs incorrectly.

I think it will be better to doublecheck the settings of the plugin within your app in comparison with our demo page.

As I have said, our support email can be added as a collaborator of the app, even if the app owner subscription plan is not a Professional (just ignore that red notification in the Collaboration tab in your Editor).

If you add [email protected] as a collaborator of your app, please do not forget to grant the edit rights :slight_smile: It will be needed for plugin testing.

@Nicuzz,

Unfortunately, we can not help you with this. But you can contact Bubble support team and ask if they can transfer the plugin license to another application. I hope this will help :pray:

Regards,

Ok, I have added [email protected] as a collaborator in the app settings. Hopefully it works.

I tried refreshing the page, but it didn’t make a difference. The plugin still says missing.

Thanks for all your help so far. I hope you’ll be able to figure it out once you login.

1 Like

@bloom3799,

First of all, thank you for adding our support email as a collaborator of your app. It helped me to find out the issues, that prevented you from using the Agora plugin properly:

  1. It is useful to check the Editor Issue alert section to find out the errors within your app (pay attention to these alerts): http://prntscr.com/shk3mf

  2. You had to try to delete the plugin element and create a new one. Actually, this helped me to get rid of the “missing” message.

  3. As I have advised you, you ought to compare your page with the agora setup (design and workflow) with our demo page. You copied our page layout to your app but you did not set the workflows.

I have resolved the errors of your app and fixed the “missing” element.

Please, in future, make sure that all the workflows are set correctly and don’t hesitate to doublecheck the plugin documentation :slight_smile:

Regards,

Hi Kate…

I feel like we’re making progress here, but there are more issues. Let me explain the steps I’ve taken since your recent fixes:

  1. Since the Agora Connector plugin was no longer “missing,” I attempted to join a room while in preview mode. The browser asked if it could access my camera and I allowed it. However, nothing showed up afterwards. I could not see any video at all, but my webcam light was on. That’s when I noticed that the bottom section of the page (“see as host” and “see as audience”) was completely missing.

  2. I then deleted that page, recopied the page from the demo again – with workflows – and made sure the bottom of the page was included. After creating a new page pasting it (with the workflows), the plugin element was missing like before. I deleted it like you suggested, added a new one from the visual elements menu and then manually reconstructed the workflows from the demo.

  3. The Agora Plugin no longer says missing, but I still cannot join a room or access my webcam when in preview mode. Furthermore, when in design mode, the section next the “peers online” says missing.

  4. I also noticed that a certificate and video calls ID have been added to the plugin settings that were not there before. Where did you retrieve these numbers from?

@bloom3799,

Thank you for your reply. I will manage to investigate the issues, you have informed me about, and will bet back to you shortly.

Thank you for understanding :pray:
Regards,

Hi Kate… I’d like to get this project moving if possible. Could your team please just setup the demo page for me? I’ve tried everything and can’t get it to work. My Agora ID number is already entered in the settings. The certificate and video calls ID were taken from the ZeroCode demo page I believe. I do not know how to generate those 2 numbers from my Agora account.

I’m not sure what’s better at this point: coding it from scratch myself or continuing with your plugin. I’ve already spent the money, though, and would like to see it work.

@bloom3799,

I’m sorry that you have such trouble with the Agora plugin setup :pray:
I’m afraid we cannot do any work for you, but we can point on your mistakes (within the plugin setup) in order to help in its resolution.

I have recommended you a few times to recheck the demo page plugin setup and the things you have copied to your page. The last time I have checked your app, there were incorrect/uncompleted workflows in it, which made me think you have simply copied the demo page without adjusting the workflows. If you are going to replicate our demo page in your app, you have to make sure you’ve done the same setups.

As the plugin demo page is working correctly, I assume your issue is under your app settings (but not in the plugin).
Still, I have opened a ticket on checking your last request -

So I hope to inform you asap on the solution to this issue. Thank you for understanding :pray:
Regards,

@bloom3799,

The answer is appeared even faster than I expected :slightly_smiling_face:

The reason why the video was not displayed on your page after you clicked the “Join room” button and so on - you have not specified the ID attribute for the video container element. This is an obliged setting which is described in plugin documentation:

We have added the ID for your Group A (video element) https://prnt.sc/skzkao so your issue is resolved.

Dear @bloom3799, would you kindly check the plugin documentation and pay your attention to the plugin demo page workflow setups? This will help you to set your plugin correctly and save a lot of time.
https://docs.zeroqode.com/plugins/agora-api-connector-plugin

I hope this will help you :pray:
Regards,

1 Like

Issue resolved. Thank you, Kate.

1 Like

You are always welcome, @bloom3799. Sorry that this issue took so long :slight_smile: