Templates Plugins Courses

Wasabi Cloud Storage - folder path and file prefix information are not resetting

The folder path and file prefix information are not resetting when the WasabiS3 Reset File Uploader action is performed.

Furthermore, in the “Upload WasabiS3” event, the file prefix information is ignored and only the information contained in the element is used.

Therefore, if a user sends 2 different files, but which have the same name and file extension, the file ends up being overwritten.

Even though a prefix with unique information is added to the file name, as this information is not reset when performing a “Reset File Uploader WasabiS3”, the 2 files end up having the same name.

I also tried changing the file prefix using conditionals, but once it received a value it is no longer changed until the screen is completely reset.

I look forward to hearing back as soon as possible. Thanks!

Best Regards,
Marcello

Hello @marcello_pessoa ,
Thank you for your message and purchase.

Would it be convenient for you to provide more details regarding your use case?

Namely, screenshots and screencasts of your workflow setup, plugin element, the issue you see, and the expected result, for screencast recording I can suggest using the Loom tool.

Please record a video in step-by-step mode with the browser’s console enabled, in case there are any error messages there, and share a link with us so we can understand better your use case.

These details will help us reproduce your setup on our side and look into it.

Thank you once again and looking forward to your reply.
All the best, :slightly_smiling_face:

1 Like

Thanks, I just dm a video detailing the problem.

tks

Hello @marcello_pessoa,
Happy to hear back from you :slightly_smiling_face:

I’ve responded back to you in dm, please check it when you have to opportunity.

Have a nice day ahead!
Best regards,

1 Like

Hello @marcello_pessoa,
Hope your day is going well :slightly_smiling_face:

I’ve responded back to you in DM, please check it when you have the possibility.

Have a nice day ahead!
Best regards,

Hi @marcello_pessoa ,
Thank you for bringing this issue to our attention.

After testing on our end, we’ve located the problem and our dev team is working on an improvement to fix the issue.

Once I get any news from them I’ll make sure to get back to you, so that you can check if the update solved your issue.

Once again thank you for your understanding and valuable feedback, it means a lot for us!
Have a nice day!

1 Like

Thank you Vasile… I’m waiting for the update. Have a nice day!

1 Like

Hello @marcello_pessoa ,
Hope this message finds you well. :slightly_smiling_face:

After thoroughly investigating the matter, our dev team concluded that the root cause was in the date/time format “mmyyHHMMssL_”. Unfortunately, this format isn’t recognized by our plugin, leading to the errors you encountered.

Please try using one of the following date/time formats to avoid this error in the future IBM Documentation.

Could you please try updating the format in your application and let us know if it resolves the problem? Your feedback is valuable to us.

For any other plugin-related questions feel free to reach out to us at any time.
Have a nice day!

hi Vasile,

I tried the format (hh:mm:ss) in the list you sent me and it still didn’t work.

The same occurs with standard bubble formats.

The problem continues to occur as previously reported.

The problem is not recognizing the format, this is happening correctly the first time, but updating the element with the new value (updating the seconds) once the element refresh is requested

Hello @marcello_pessoa ,
Thank you for reaching out and updating us on your case.

We are currently looking into your question and will respond to you as soon as possible.

We appreciate your patience and cooperation.
Warm regards.

Hello @marcello_pessoa,
Hope this message finds you well. :slightly_smiling_face:

Our devs looked one more time into this issue and concluded that it’s Bubble related issue, and it wasn’t caused by the way our plugin works.

After carefully testing we found out that Bubble doesn’t actualize the current date/time every second which leads to the fact that when wasabi Folder Name Prefix was set up as Current/date time it didn’t manage to update properly so the prefixes were the same.

As a workaround, if you need to use Current/Date time to generate to obtain a unique file’s name we can advise you to use a plugin that will count the time for you, and with the help of custom states, you can achieve each prefix to be unique. We have an example on our test page.

The wasabi element is located in pop-up A, in there you can see how it was configured also please check the workflows to see how the custom states are set up.

Thank you for your patience and understanding while we worked through this matter. :pray:
Warm regards!

Hi Vasile,

I added a custom state that I use as a prefix for the files.

I update the custom state with the current date time every time I open the window and it worked perfectly.

thanks!

Hello @marcello_pessoa ,

You’re very welcome! I’m thrilled to hear that the Wasabi Cloud Storage is working properly now.

If you find our service great, we’d be incredibly grateful if you could leave us a review. Your feedback not only helps us but also motivates our team to continue providing excellent service and support.:pray:

If you like our plugin, you can rate it by going to the Plugins tab in the Bubble editor and sharing your experience with the rest of the Bubble community. You can find the plugin by name and give it as many stars as it deserves.

In case you would like to share your experience with the rest of the world, here you can find our link for Trustpilot: Zeroqode Reviews | Read Customer Service Reviews of zeroqode.com

If you have any more questions or need further support down the line, don’t hesitate to reach out. I am here to help!

Enjoy your day, and thank you for your willingness to collaborate and communicate openly it has greatly contributed to our ability to solve this issue.
Best regards,