Templates Plugins Courses

With the "Advanced Twitter API" plugin, how to get users to authorize the Twitter API?

Hi Zeroqode team,

I’m using the Advanced Twitter API plugin, but been facing an issue.

Through my app (clicking the button below), I can’t seem to go through as done in your demo app.

Instead, it only shows me an error message as below reading;
“Whoa there! The request token for this page is invalid. It may have already been used, or expired because it is too old. Please go back to the site or application that sent you here and try again; it was probably just a mistake.”

Could you tell me how I might be able to fix this?


What I’ve tried

Any tips would be much appreciated.
Thanks in advance!
Jun

Looking for help…! :pray: @serg @Ecaterina @alexander

@tanaka.jun.jp, thanks for reaching out, and please accept my apologies for the late reply. :pray:

Please be sure to introduce the related callback URLs into your Twitter development account.

Within the “Callback URLs” section you should include all pages where the Twitter plugin is used/included, and on “Website URL” you need to indicate the general URL address of the application.
See the example on our demo page:


For example, we’ve created a zq_twitter_test page on your app, and its address https://magnele.com/version-test/zq_test_twitter should be also included in Callback URLs.

After that, within the “Keys and tokens” tab, please regenerate and insert all the related fresh API keys and tokens in corresponding fields.

Please try the suggested variant and let me know how it goes.
Hope it helps!

Thanks @kate,

Within the “Callback URLs” section you should include all pages where the Twitter plugin is used/included, and on “Website URL” you need to indicate the general URL address of the application.
See the example on our demo page:
After that, within the “Keys and tokens” tab, please regenerate and insert all the related fresh API keys and tokens in corresponding fields.

I tried all that (screenshot ↓), but it still gives me the exact same error message mentioned above.
Or what else can I do to possibly solve this?
(I hope the “Request email address from users is disabled” setting is not causing the issue?)

The URLs I put in as Callback URLs should be fine:

For example, we’ve created a zq_twitter_test page on your app, and its address https://magnele.com/version-test/zq_test_twitter should be also included in Callback URLs.

magnele.com is not my app. But I understand your point.

Thanks again,
Jun

@kate or maybe @serg @Ecaterina @alexander
Hope to hear back on this before the end of the day. :pray:

@kate @serg @Ecaterina @alexander, or anyone from @zeroqode
Help please. Been left more than a week…

@tanaka.jun.jp,

Please accept my sincere apologies for this awful delay. I’m sorry for this :pray:
Let us please check the details you’ve provided and get back to you tomorrow.

Once again, sorry for the delay. :cry:

1 Like

Hi @tanaka.jun.jp, sorry again for the delayed reply.
Allow me to reply on behalf of my colleague.

If the issue persists, kindly note that inserted API keys & and tokens possibly are inserted wrong and/or are not regenerated considering the newly inserted URL link.
We’ve checked the authorization process on the settings page of your app using out API keys & tokens and all was working well.

To fix the issue, please:

  • insert related page URL to the corresponding project on Twitter

  • within the “Keys and tokens” tab, please regenerate and insert all the related fresh API keys and tokens in corresponding fields.

  • make sure that the link inserted in the callback URL - is the same that you obtain on preview, and Bubble is not adding anything else to the link end.

So, for testing purposes, please use any registered user profile from your app
image

Hope it helps. Please apply the proposed solutions and tell if the issue will disappear.

Looking forward to your reply.
Regards,

Hi @serg

Thank you for the reply!

  • insert related page URL to the corresponding project on Twitter

My apologies, I was missing the last " / " - I should have had “XXXX.bubbleapps.io/version-test/settings/” on Twitter Developer settings in my case.

  • make sure that the link inserted in the callback URL - is the same that you obtain on preview, and Bubble is not adding anything else to the link end.

The URL I get right after hitting the “Preview” button is like this;
https://XXXX(my app name).bubbleapps.io/version-test/settings/Lorem%20ipsum…?debug_mode=true
With this URL, it wouldn’t work through to Twitter authorization.
But when I drop “Lorem%20ipsum…?debug_mode=true” and make it to https://XXXX.bubbleapps.io/version-test/settings/ it does work through just fine.

Now, my question is, when I deploy the app to live, will the “Lorem%20ipsum…?debug_mode=true” part be removed without me doing anything? Or will I have to do something to have it removed when live?

Excuse me if my question is now out of your work scope.
Thank you again!
Jun

Hi @tanaka.jun.jp, sorry for the delayed reply (due to the weekend).

If the “settings” page will be accessible only for logged-in users - then no actions are required.
By now, before going live, to have a proper testing process, please run your page from any particular user profile from your app database.

Hope it helps. If there is anything else that I can help with, please let me know.
Regards,

Hi @serg,

I think now it’s solved, thank you again!

The followings are just for note -

If the “settings” page will be accessible only for logged-in users - then no actions are required.

I just made this Workflow, which does kick me out when not logged in. I believe this is good enough.

And I found that, if I blank Type of content in the Settings page, the unwanted “Lorem%20ipsum…?” bit out of “https://XXXX(my app name).bubbleapps.io/version-test/settings/Lorem%20ipsum…?debug_mode=true” is gone, because that way the Settings page doesn’t require any data sent into the page :smiley:

Thank you again for answering my questions!
Jun

1 Like