Templates Plugins Courses

Xero Accounting - API plugin update to OAuth 2.0

I am thinking about developing an app which will need to make calls to Xero. Is there an expected timescale for the zeroqode Xero API Bubble plugin to be updated to use OAuth 2.0?

Hello @marek1

Thanks for reaching out!

Unfortunately, we can not commit on a definite timeline right now. However we are working in the plugin at the moment, once it will be available I’ll provide an update regarding the release.

As an alternative, I believe you can use and create your own API connections using Bubble’s API Connector - https://bubble.io/reference#Plugins.apiconnector2
More about API Connections - https://manual.bubble.io/building-plugins/adding-api-connections

Hope this helps.
:pray:

Regards,
Dumitru.

Hi @Dumitru,
I’m just following up on this thread, whether you you have any news on this Xero plugin updates. I’m interested in purchasing it. Many Thanks Peter Grabec

Hello @peter.grabec

Thanks for checking back with us. I understand that there is a need the plugin, and we’re trying to bring the update to existing version. Though I can not commit on a timeline since there were changes in API since we’ve encountered some challenges, we’ve had to rebuild the authorization process during migration.
We’ll provide an update as soon as possible.

Thanks for understanding.

Okay. Thank you @Dumitru. I look forward to future updates. Would you think that perhaps an option of using Integromat to connect Bubble and Xero might be the way to go for the time being? https://www.integromat.com/en/integrations/bubble/xero
https://lab.zeroqode.com/course/automation-of-processes-with-integromat-1574853989221x532120637230809100

Hello @peter.grabec @marek1

Thanks for patience and feedback.

We’ve updated our Xero Plugin to latest Oauth 2.0 by migrating the type of authentication accordingly.
Please check out the plugin - https://zeroqode.com/plugin/xero-accounting-1546872666890x498865460961869800
And documentation on how to setup - https://docs.zeroqode.com/plugins/xero-accounting-plugin
:pray:

Kind regards
Dumitru

Hi @Dumitru,

Thanks s lot for the much awaited update! I went to the plugin demo page, and tried to run the demo connecting to my Xero account, but it didn’t let me connect. So I tried clicking in the Connected apps link but it also through an error (please see attached screenshots). Then I went to my Xero account >Settings>Connected Apps, it didn’t allow me to get in either, and through an error as well. I’m not sure whether the bug is within the zeroqode plugin, or on my Xero account side, I’ll get in touch with Xero to investigate.
Update a few hours later (last attachment - no.7) - this makes me think the bug is within this plugin.

Regards, Peter


Last atatchment - no.7

Hi @peter.grabec,

Let me jump in here to help. We just checked on our plugin and I’m afraid there isn’t an issue on our side. We tried to replicate it but with no luck, unfortunately.

Are you actually using the newest element and actions of this plugin? Because the old oauth 1.0 are deprecated and might not function properly, even causing unexpected plugin behavior.

Please try to make sure it is all set up properly as per our docs but if you still encounter the same trouble, we shall check on it within your Bubble app then.

Best,
Alex