Templates Plugins Courses

Zoom: Feature Request (Easy)

Regarding your excellent Zoom Meetings and Webinars plugin: When creating a meeting, could you to expose the settings object on the create meeting API call? That way I could enforce mute_upon_entry.

It would literally save me forever trying to figure out the API calls and oAuth for API connector.

:smile:

1 Like

Hi @justin.hume, thanks for your appreciation and suggestion :slightly_smiling_face:.
We will check how feasible it will be to add the requested feature to the future plugin update, thank you for suggesting it.

In case any other plugin-related questions will appear, please let us know.

Regards,

Seeing this too…When creating a meeting, could we please expose the settings object on the create meeting API call? It would help enforce mute_upon_entry. lots of need for this around zoom meetings…

Figuring out the API calls and oAuth for API connector takes a ton of work

1 Like

Hi @c.volpert1, thanks for your message.
Your request is noted too. In case any update for the Zoom plugin will come to live, I will let you know :slightly_smiling_face:

Thank you for understanding.

Regards,

thanks serg, please let me know if there’s anything i could do to expedite this update…is this update particularly difficult?

@serg Please keep us posted on how we can enforce mute_upon_entry for the zoom plugin. Thank you in advance!

1 Like

hey serg, did you end up seeing how feasible this is?

thanks so much for your help!

cary

Hi @c.volpert1 & @lindylive, thanks for your attention to this topic.

Presently, I cannot provide the exact time/effort estimates on this matter, sorry.
Once the plugin will be updated, I will let you know for sure.

Thank you and have a nice day!

Regards,

ok, thanks serg, please let me know how i can help :), its v important to us

2 Likes

Hey serg, any new updates ?

I’ve found a bug in the refresh token workflow: subsequent workflows that save the refresh token and zoom token do not wait until the zoom: auth has finished running.

Is there a workaround to force the make changes to user to wait?

Hi @c.volpert1, apologies for the late reply. Sorry to tell you but there are no news so far.

Hi @justin.hume, thanks for reaching out. The reported issue might be related to the fact that Zoom tokens expire every hour. So we need to set up a workflow that will run every hour, to refresh tokens, but only if the ‘zoom_token’ for the Current User is not empty.

Kindly check the related compartment of the supporting documentation for a possible solution in your case: https://docs.zeroqode.com/plugins/zoom-meetings-and-webinars-plugin#4-set-refresh-token-workflow

In case the issue will persist, or any other question will appear, please let me know.

Regards,

Hey serg, the zoom token needing to be refreshed is not the issue. I am able to refresh, though setting it to refresh every hour in the way outlined in your documentation does not work – unless the user is sitting on the same page for an entire hour. When a workflow is set to repeat after x amount of seconds, that workflow stops executing once the page has been changed. It is much more reasonable to set an “expiry date” on the user that will then check when you need to take an action requiring zoom. This may be the reason why your plugin has very few apps using it – the documentation is incorrect.

The issue here is that when I refresh the token, it saves information to the database before the zoom auth - refresh token action has returned any values. This means that my token, refresh token, and zoom_error fields end up being blank.

For anyone else having the same issue, I was able to resolve this by saving the information (result of step 1 - refresh token, token & error) to states on the page, and then scheduling a custom workflow after three seconds to save that information to the database on the current user.

You should know that the way outlined in your documentation only works in debug mode. Debug mode slows down the workflow enough that it is able to return the API call information before saving to the database. Your documented method does not work without debug mode enabled.

Hi @justin.hume, thanks for the additional details provided.
Allow us to analyze them and as soon as a possible solution will be available, I will let you know.

Thank you for understanding and have a nice weekend!
Regards,

I just want to note that I’ve had this same exact problem on two Zeroqode plugins in the last two months - Agora livestreaming and this one.

Hi @justin.hume, thanks for your patience.

We’ve checked the issue both in debug mode and without it, and in both cases, token data are refreshed without delay.
Kindly note that the issue mentioned above may appear in case if refresh and access tokens are indicated wrong.

Allow me to recommend the following:

  • please check if the relevant data are refreshed, in refresh token action are sent only relevant access token and refresh token. In the case of a new user - these are authorization data, in the case of an old user - these are data of the last refresh token request.
  • please add a conditional check “error is empty” before the database data refresh

Hope it helps. In case the issue will persist or any other plugin-related question will appear, please let me know.

Thank you and have a nice day!
Regards,