Templates Plugins Courses

ZQ Fuzzy Search & Autocomplete plugin is not working

I have the ZQ Fuzzy Search & Autocomplete plugin installed in my app. it keeps returning this error, is there a fault on my end or is the plugin?

Hi, @xttechnology!
Thank you for reaching out!
Unfortunately mentioned error is not reproducing on our side. Could you please provide us as more details, as possible?
For example OS/browser, screenshots of workflows and settings, steps to reproduce the issue so we could try and help you out better.
Thanks for understanding. :pray:

HI Julia,
Thank you so much for getting back to me. Unfortunately I don’t have anymore information but I have attached some screenshots of the settings for the plugin.

Thank you so much.

Hi, @xttechnology!

Unfortunately, this issue is not reproducing on our side by replicating your settings . In order to help you better we’d need more details on the issue, like the step by step how to reproduce, browser/os, console.logs, workflow /setup.
Also please check our demo editor here: https://bubble.io/page?type=page&name=fuzzy&id=zeroqode-demo-16&tab=tabs-1 to preview the plugin settings and see how the plugin works and try to replicate it.
Hope this helps.
Regards, Julia.

I am facing the same problem

Hi, @markhallak!

Thanks for reaching out!

Apologies for the inconvenience. I can give a hint that might help.
Please verify couple of things such as:

  1. if the element “Search&Autocorrect” is configured properly, specifically “Data type”, “Data source”-> “Type”: https://prnt.sc/spf93k , which means “Data Type” and “Type” should be the same.
  2. make sure whether the element "RepeatingGroupFlight’, the field “Type of content” and “Type” are the same too: https://prnt.sc/spfn1v .
  3. please check “RepeatingGroupFlight”-> tab “Conditions” settings with configurations on your side: https://prnt.sc/spdtil , they should match.
  4. as the element “Search&Autocorret” is connected to the element “Input Search Flight” then the field “Input box ID” : https://prnt.sc/spg4qi should be similar to the “ID Atribute” : https://prnt.sc/spg3hm , please check these settings too.
  5. Please make that both plugin element and RG/inputs are in the same Group Container.

Also please check our demo editor here: https://bubble.io/page?type=page&name=fuzzy&id=zeroqode-demo-16&tab=tabs-1 to preview the plugin settings and see how the plugin works and try to replicate it.

Hope this helps!
Regards, Julia!

1 Like

Hello @julia.minacova, thanks for your assistance! I changed my mind, I need it fuzzy because the database will be filled with files so it is useful to do fuzzy search. It is working properly and doing its purpose. However, there is a downside when I changed the type of the RG. Usually when I upload many files per log, each file will be in a separate cell of the RG. But now all the files are in one cell of the RG. Is there a way to fix this problem? Also if I click on that cell that contains many files, they are not opening. It is opening all of them in one tab as you can see in the URL of the tab.


Looking forward for your assistance!
Thanks in advance!

Hi, @markhallak!

To help you with your issue better, can you please provide more details of your setup, like screenshots of Plugin element settings, database, workflow etc.
Also the result that you’re getting when searching through db entries.

Best regards, Julia.

Hi, here are the details of my setup. When I add a post that it doesn’t have an attached files with it, it is shown as empty clearly becase it is searching for files. I need to solve these issues.


`
If you need the editor link, I can give it to you no problem.

Hi, @markhallak!

So, I analyzed provided screenshots. Let me give you some insights that might help you. RG has to have the same type of content you are going to display. In your case it should be file instead of posts.
Also, in order the search to work properly, there should be the field of type text which the plugin will be able to process and find matches - so there is a need to restructure your current DB a bit.

First: I would suggest you create the separate table in DB called, for example “File”, and it should contain two fields - 1) field name: attached_file (type file) and 2) field name: file_name (type text): https://prnt.sc/stsrfk .

Second: add new field to the table “Post” -> field name: file_list (type “File” - the one created in the first step and check the checkbox “this field is a list”: https://prnt.sc/stsu5w ) : https://prnt.sc/stst0c .

Third: in the WorkFlow you are creating your post, the second step should be “create a new File” and on the third step you need to add just created file to the post you just created: https://prnt.sc/stte3r .

As for RG’s settings you choose type of content- “File” and data search- “Search for Post’s file_list”: https://prnt.sc/stt6cp and in tab “Conditional (1)” define another condition: https://prnt.sc/strxl7 . Please be sure that you made changes and for Search&Autocorrect as well: https://prnt.sc/stt5z9 .

Hope this helps!
Best regards, Julia!

1 Like

Hello @julia.minacova, thanks for replying.The problem still exists. When I upload many files once, they all appear in one cell.

Hi, @markhallak!

Thank you for provided editor link!

So, as I can see from the settings you’re trying to add a lot of files with MultiUploader in field which can except only one, single file. Please see screenshot here:


(you’ve created the field “Attached_file” which can record only one file). In that case MultiUploader is recording the first file it sees and ignore the rest files: .
You should use a single file uploader instead of MultiUploader here:

.

Also, make sure that you didn’t missed the Third step that I mentioned in a previous mail.

Just in case: Third: in the WorkFlow you are creating your post, the second step should be “create a new File” and on the third step you need to add just created file to the post you just created: https://prnt.sc/stte3r .

As for RG’s settings you choose type of content- “File” and data search- “Search for Post’s file_list”: https://prnt.sc/stt6cp and in tab “Conditional (1)” define another condition: https://prnt.sc/strxl7 . Please be sure that you made changes and for Search&Autocorrect as well: https://prnt.sc/stt5z9 .

If you have more questions regarding Bubble development itself, please post your request here https://forum.bubble.io/ where you can find more help from the community.

I hope this helps!
Kind Regards, Julia!

1 Like

Thanks. I have solved it!

1 Like

Glad to hear that! :slight_smile:
Have a nice weekend!

Best, Julia!

you too! Thanks again!