Templates Plugins Courses

ZQ Rich Text Editor - My App is Down!


#1

I have posted this in the Bubble Forum as well, but as I am experiencing a problem that is making my app unusable - literally text input/editing is one of the core features of my app - I wanted to share this here too.

I have been using version 1.34.0 of the ZQ Rich Text Editor on my development and live versions because there is a particular problem with the more recent versions that I had not previously brought to your attention. Today, randomly and out of nowhere, the RTE input box has stopped displaying on both my development and live versions (even though I have not pushed any updates to my live version).

So the reason why I had not updated to the most current version is because a problem with using the RTE editor in the context of a Repeating Group which you had previously fixed for me in December of 2018 started recurring with more recent updates. This problem is outlined in detail in post number 65 on this Bubble Form Thread: https://forum.bubble.is/t/zq-rich-text-editor-new-plugin-from-zeroqode/30469/66

I have also made a loom video of both problems (nothing displayed with the RTE in version 1.34.0 and the Repeating Group display problem in the current version).

Please respond as soon as possible.

Thank you


#2

Hello @accounting

Please upgrade to latest version of plugin, place the element on page refresh the app and give it a try.
We pushed a fix recently which should fix it!
Thanks.

Regards,
Dumitru.


#3

No, its not working. As shown in my video, I am now using version 1.42 and the content is not updating correctly.


#4

We’ll check this out! Sorry for trouble, however have you tried reinstalling the plugin, placing a new rte element on page, and this? Have you checked the console logs if there are any errors, providing us with as much details as possible will help debug it much easily.
Also please revert to a version which is stable! Thanks for understanding and patience while we check it.

KR,
Dumitru.


#5

There is no version that is stable for me! When I use ANY version other than 1.42, I get a blank space where the RTE box is supposed to be. It doesn’t display the editor options. It doesn’t display the text content. It doesn’t let me type new content. Its literally like nothing is there. When I use version 1.42 my content doesn’t update correctly. Both of these problems are shown in my loom video.

At your suggestion, I removed the plugin from my app, reinstalled the plugin, and placed a new RTE element on the page. These actions made no difference whatsoever.

I don’t know what console logs are.


#6

Hello!

We are still looking into the issues due to reports, however while we are working on issue could please check the version 1.35, since it was reported by the devs to be a stable release.
Thanks for understanding and patience.

best,
Dumitru.


#7

No, version 1.35 does not work. When I use 1.35, I get the empty box with no editor, no text, etc. exactly like my loom video shows. I’d be happy to give you access to my app so you can see this for yourself if the video isn’t enough documentation. Are there other users who are having issues with the plugin? Do you have any indication as to when this might be fixed?


#8

We have reports on the issue with plugin, however there seems to be inconsistency in reporting from users which shows that some users do have issue while others able to use it after reinstalling and refreshing the app.
It’s on the top priority ticket, which we are working however can not offer a timeframe atm. Sorry for inconvenience and thanks for patience.
We’ll update asap on the matter.

kind regards,
Dumitru.


#9

To close the loop on this zeroqode forum, I just wanted to let you know that I received your reply on the Bubble forum indicating that an upgrade (version 1.43) is available that addresses my problem. This update does appear to be working in my development version. I have pushed your update to my live app and will let you know if there any additional problems. Thanks for your help.


#10

Good to hear!
If you like our plugin, could you please rate it by going to Plugins tab in Bubble editor? You can find the plugin by name and give it as many stars as it deserves :slight_smile: The more feedback we get, the more motivated to build great plugins :slightly_smiling_face:

Thanks! :pray:


#11

Display only mode - stretch to fit content doesn’t seem to be working in the new version. Please let me know if you need a loom video of this. I have deleted and replaced the rte element on the page to no effect before contacting you.


#12

Hi there! @accounting

Sorry for late response, we’ll check this out. Thanks.