Templates Plugins Courses

Amazon like template

Hi I’ve bought the old version of the amazon like template.

The customisation is almost finished, but found a bug that the test user cannot save the address in the check out page, if the user didn’t key in such info in his own user page.

I didn’t really change any logic in this function and have compared against the original template work flow – it’s the same. Can someone help?

Hello, @nic.wei66
Thanks for reaching out.

We have reproduced the mentioned steps within our Demo Page and this error did not appear on our side.
Probably, this error occurred on the Bubble platform side ( not in your template ).

We kindly propose you wait a bit and in case this issue will persist - to let us know.

Thanks for your understanding.
Best regards,

Hi Ecaterina,

This issue has persisted for at least two weeks. I’ve just tried again, same old problem. Not sure if it is due to any conflict with other setup or not. But no issue alert shown.

Btw, I’ve bought the old version amazon like template. Am I entitled to upgrade to the latest version, for selected function only, since I’ve customised quite a bit?

Hello, @nic.wei66
I’m sorry to hear that.

We kindly ask you to provide us the screenshots from the Browser console, where we can discover the exact error.

Unfortunately, but you can’t upgrade only certain features within the template. The only possibility is to get instruction for fixed bugs from our development team, which will need to be reproduced.
However, we always recommend upgrading the products after the release of the new version.

Looking to receive the screenshots from you.
Best regards,

Hi Ecaterina,

I’ve tried to save the address in both the check-out page and buyer profile page, neither can save and popup the same bug message I showed you earlier.

I’ve also downloaded the new version and compared the workflow, they are the same. I’ve even copy and paste the exact same section with workflow. No help.

Wondering if possible to schedule a screen sharing session with your team? It might be more effective than screenshot?

Hello, @nic.wei66

In order to speed up the process of identifying the reason for the mentioned issue, can you please add our Support Team email to the list of collaborators to your application?
This will allow us to check your settings and run some tests to fix the mentioned problem.

To add our Support Team as a collaborator, you need to do the following steps in the Bubble Editor:

Settings > Collaboration > Add email [email protected]

Note: avoid the warning message regarding the plan, as we are an agency and you can easily add us to your collaborators.
Also, we kindly ask you to provide us the details, like the title of the page, where this issue is reproduced.

Looking to hear you soon.
Regards,

Hi Ecaterina,

Have added the support team in my app:

The address saving issue is in the checkout page and profilebuyer page.

I’ve asked the same question in bubble forum, some suggest “it’s because you have a custom domain on the app without valid google API keys to handle geographic addresses. You should notice this if you enable the debugger.” I’m not sure if that’s the cause, becoz I have keyed in the Google API Keys and I don’t think this address function require geolocation/ map service.

Hello, @nic.wei66

We have analyzed your application and unfortunately, there is an issue with your Google API keys, as was advised to you earlier.
Please allow me to recommend you analyze this documentation and create new keys for your application: https://docs.zeroqode.com/plugins/google-sheets-and-charts-service-plugin/obtaining-service-account-keys

Hope it will help you.
Best regards,

Hi Ecaterina,

I’m following the steps in the instruction. However, get stuck in:

Obviously the picture sample is not working. I cannot find the this Iss field in Bubble editor. It is under which category?

Or do I need to download any API?

Hello, @nic.wei66
I’m sorry for this inconvenience with the screenshots.

Please forgive me for misleading you regarding the configuration of the keys for the Google API. :pray:

You don’t need to install any additional plugins or create Google Service keys. It’s completely my bad, I’m sorry for this. The thing you need to do to make it work is to configure your Google API keys, which are located in your app’s Settings > General.

Please, follow the instructions in this article for creating them: https://bubble.io/video-course/how-to-setup-google-api-keys-1612384311603x783404397562167300

Please try it and let me know about the result.
Best regards,

I have already watched this tutorial and keyed in all Google API Keys accordingly. If your support team check the setting, they will definitely see it’s there. To double confirm the correctness of the keys, I just copy and paste the keys again. Still can not save the address!

Hi I’ve figured out the solution with Bubble support. So no worries.

Meanwhile, after all system alerts are resolved. I tested to place an order. So far seems smooth, but after the oder is paid and placed, it is not shown in the buyer’s account - my orders:

I believe there’s a missing step in the workflow after the buyer click “ok, I got it” in the Thanks You popup. None of the steps here mentioned it will update the order status:

Can you advise?

Hello, @nic.wei66
Happy to hear that you have fixed some of your issues within the application.

We have checked both applications ( our Demo page and your application) and all is working properly.
The setting is identically for the “Orders”, so it seems that the order was created incorrectly and should be approved by the seller.

Please find the screencast from our Demo Page, where you can see how to order creation occurs:

We kindly ask you to record a video with all steps, which are reproduced, to investigate your case.

Looking to hear you soon.
Best regards,

hi, the operation steps is recorded as follows:

After order is placed and navigate to the My Order page, none is reflected there.

What do you mean by " it seems that the order was created incorrectly and should be approved by the seller"?

Can your team help investigate?

Btw, the ordered product is not shown in SellerProfile either.

Don’t know how an order is “correctly” created. I just follow the steps as a normal buyer. No workflow in this part is modified.

Can you support team log in to my app and check? Thx

Hello, @nic.wei66
I’m sorry for the late reply.

Please allow me to note that I am a support team representative and have personally logged on to your app :slightly_smiling_face:

We have analyzed one more time some features within your app and found out that you try to use our keys for the Stripe payment system ( which is one of the components for a checkout process).
I’m afraid that none of the options relating to payment will work correctly.

Please allow me to recommend you following this documentation for creating your Stripe account and test/live leys accordingly:


https://docs.zeroqode.com/templates/marketo-markeplace-like-amazon-template/setup-guide#payments
https://docs.zeroqode.com/connecting-stripe-payment-using-stripe-plugin

Please make all these steps and try one more time the Checkout session within your app. :pray:

Looking to hear you soon.
Best regards,

hi I’ve double checked the steps following the instructions and even get the testing seller stripe ID double checked by Stripe.

No help at all.

  1. Product uploaded and approved:

After a product is uploaded by the testing seller and approved by the admin, the approved item is not shown under the seller profile’s “My Product”.


  1. After order is placed,

the purchased item is neither shown in buyer’s page nor seller’s page

The testing stripe account of the testing seller has be been approved by stripe.


Can your team log in and check again? The first bug doesn’t seem have anything to with Stripe at all.

Hello, @nic.wei66
Glad to hear that you had created your Stripe account.

Please allow me to note that due to the fact that the bug is reproduced on the Checkout page, having the correct Stripe account is an important enough point.

As an exception, we will check your application again to find the reason for the mentioned situation.
I will revert to you immediately after checking.

Best regards,

@nic.wei66

Allow me to mention that we have started to check your application, however, it seems like there are issues with the Stripe account ( indicated keys).

I understand that it can be confusing, but can you please provide me the credentials for your Stripe account to investigate appeared issue from all sides :pray:

In case you agree with it, please provide us information about your account by email: [email protected]

Looking to hear you soon.
Best regards,

Hi Ecaterina,

I’ve just emailed you the API keys screenshot. Not sure if that’s what you asked for. Let me know if need anything else.