Templates Plugins Courses

Anything To Image Tutorial

Just bought the “Convert Anything To Image” plugin and I didn’t found any tutorial about it, just the live demo at Bubble editor wich I tried to reproduce the same at my project but it’s not working.
Is there a tutorial available or somebody that could explain to me step by step (baby steps) how it works?

Hello @guilhermemaracaipe

Thanks for reaching out! Unfortunately, we don’t have a tutorial for however, the Editor Page should give you insight on how it is set and should be used.
Editor Page: https://bubble.io/page?type=page&name=index&id=pwc-anythingtoimage&tab=tabs-1

In order to convert an element to image or pdf, you should place Plugin Element on page:

Group it with the same element you want to convert.

Assign an Element ID Attribute to respective element which you want to convert

Use action Make Image or Convert Image to PDF in the workflow to the targeted Element ID, to convert it.

When the conversion is over, use the Plugin’s state to retrieve the type of file to be displayed (saved to db, etc.)

image

Get the output result

Hope this helps. :pray:

Regards,
Dumitru.

1 Like

Thanks Dumitru, it helped a lot!
I finally managed to make it work but some components gets distorted and some lines are appearing, do you know why this is happening and how to solve it?

@guilhermemaracaipe sorry for the trouble :pray:

Can you please provide more details, like the setup of your page, what are the steps to reproduce this issue, is it a pdf or image , etc so we could help you better?
Thanks.

1 Like

Yeah, sure.
I’m trying to convert that components to an image and that component is a Group displayed by a FloatingGroup.
When I click at the “Finalizar” button it must convert that Group (not the FloatingGroup) and all on it.
The first image that gets distorted is a Image component and the second one is a PictureUploader.
The lines I have no idea where’s comming from.

I was using a custom style both on PictureUploader and Image component and I changed to the Standard Style and the lines just changed:

Also a border from an inner group has displayed and it wasn’t supposed to.

@guilhermemaracaipe

Thanks for the info, maybe you could provide you style settings, how exactly are the elements in your setup/workflow, if there are any conditions which may interfere etc

We also check this out and try to debug it and provide an update on the matter, asap.

Alternatively, you could try adapting the style of elements to another one.

Thanks for understanding.
:pray:

1 Like

Hello @guilhermemaracaipe

We’ve tried to recreate your use case and could not reproduce the issue, can you please add us as collaborators [email protected] in your application if possible to check closely.
Our developers had checked.
One cause may be the picture uploader element which gets an image which somehow is edited and it is rendering this way

Thanks for your understanding.
:pray:

I don’t have the professional plan yet so I can’t add you as a collaborator :confused:

The plugins account is an agency plan account, so disregard the notification since it’s should be possible to add us.
Thanks.

1 Like

Didn’t knew that, done!

Thanks for access, is it possible to set a demo page for our developers to check exactly the same scenario which you’ve had issue with?

Since it is not possible to edit the application and login into the app to test in the step by step workflow.
If possible create an user so we could login into application with.
Thanks

1 Like

Sorry for that, I’ve enabled your access to create user account at platform.

Hello, @guilhermemaracaipe. Let me please jump in here.

Thank you for adding our [email protected] as a collaborator of your app. This helps us to investigate the issue you have faced. Our dev team needs some time to search for the root cause of your issue, thus can you please have a little patience :pray:

I will inform you asap, when I have any useful info on your case.
Regards,

1 Like

Alright, thanks for the follow up.
Meanwhile I’ve just removed those components (Image and PictureUploader) and Ungrouped those other ones and the bug is gone, it will do the trick untill you guys fix it.
Here’s the output without the bug:

@guilhermemaracaipe,

Our dev team was trying to reproduce the issue you have, within your app, but it was not possible to succeed in this process because of a few things.

First of all, you did not show the table in which you upload images, using Picture Uploader, and then, you removed this element from your page.
Second of all, the most probable reason why this issue occurs is the way you upload the image or the uploaded image itself (image type, size, etc).

Our team tested the Picture Uploader and Anything to Image plugin collaboration and did not reveal issues, alike to yours or any at all.

Would you kindly try to change the way you are uploading the image files and use different image types in order to reveal the root cause of your issue?

Hope it helps :pray:
Regards,

Hello. I have purchased this ZEROCODE PLUGIN and waisted 2 entire days to realize that this Plugin has very very strange behaviors on the PARENT GROUP parameters. It looks like it kills all references of the Parents Group item and makes all workflows not working (specially on the Pictures)

I REALLY NEED Assistance from Zerocode to make it works… I have tried more than 1000 configurations and I have now the CERTITUDE it’s not a problem of PLUGIN parameters (*) … but this PLUGIN has a wrong impact on the PARENTS GROUP references of the groups involved. (And the Picture within the Parents Group are not updated after generating one Image)

How can we proceed to make it work?

(*) And please DO NOT say to follow the Bubble example as I have done it 1000 times… I have shown the PLUGIN generates a mess within the Parent’s Group parameters and workflows.

Thanks for your efficient support. Pierre

Hello, @3whiteshirts. Thanks for reaching out.

We will be glad to help you if you share a bit more information what kind of a trouble you have faced, using our plugin. The more details with screenshots and steps to reproduce we get - the faster response and assistance you can get.

As I can see, our plugin works well on the demo page and does not cause any errors (in debugger or browser console). Perhaps some troubles occur because of the plugin in your environment or Bubble setup. We can try to invesrigate your case and provide some insights if you share with us the details of yout issue.

Thank you :pray: