Templates Plugins Courses

AWS File Upload - Server responded with 0 code


#1

Hi,

A few days ago I bought the AWS File Upload plugin. Today I integrated it with the directions in the provided guide, but every time a file is uploaded I keep getting the message ‘Server responded with 0 code’. I’ve got the default (all public access) CORS policies and ACL setup, as specified in the Zeroqode guide.

What can I do to fix this?


#2

can you please post a screenshot of the error you are getting?


#3

25%20pm


#4

Hi @dylang

Could you please post screenshots of your setup/workflow/plugin setup, aws and your app to help us debug it. thanks for understanding.

KR
Dumitru.


#6

@dylang
Could you please post Plugin Uploader’s proprieties as well as the console logs? thanks.


#7

I’m also having the same problem.


#8

then same here: Could you please post Plugin Uploader’s proprieties as well as the console logs? thanks.


#9


#10

Hello, @tkassis

Please double check our setup documentation - https://docs.zeroqode.com/plugins/aws-file-uploader-plugin
And demo page setup: https://bubble.is/page?type=page&name=aws-uploader&id=zeroqode-demo-02&tab=tabs-1
try reproducing all the setup and document actions, and test them out.
Also would recommend you try, uninstalling and reinstalling the plugin, place a new element of file uploader on page and give it a try.
Thanks.

Lately if everything was set as in our demo/doc method and still getting an error while uploading files, provide some screenshots better a video of you setup and screenshots from browser’s console log (ex:)

Also from current setup, I see you’re uploading file sizes bigger when in our demo, you should check your AWS S3 plan setup which should be able to upload sizable files.
Thanks.

Best,
Dumitru.


#11

Hi Dumitru,

I followed the documentation exactly. I did it several times. Been trying for the past 4 days but no success. Here is a video of the error (including console): https://youtu.be/88qL3WvndCU

Thanks!


#12

Hi @Dumitru I found what the problem was. It was a mispelling from my end. I had typed ‘ue-east-1’ instead of ‘us-east-1’ for the region in the plugin settings. All I needed was a good night’s sleep to catch that! (I think I checked the spelling about 10 times when I set it up).


#13

I can relate to that :slight_smile: unfortunately syntaxis check is still required with no-code building in rare scenarios like these :slight_smile:

If you like our plugin, could you please rate it by going to Plugins tab in Bubble editor? You can find the plugin by name and give it as many stars as it deserves :slight_smile: The more feedback we get, the more motivated to build great plugins :slightly_smiling_face:

Thanks! :pray: