Templates Plugins Courses

AWS Uploader - Can't Delete File


#1

Hey,

Thanks for making the AWS uploader tutorial, I followed it all and was able to upload files to my bucket successfully.

When I run the delete file action, nothing happens. All access is set up like in the tutorial. And the URL is correct, just the action not working for me.

Any idea what it might be?

image


#2

Hello, @marcus.

Please be sure to configure the plugin settings. From your screenshot seems like you’re missing the API Key setting.
More correctly check the identity pool id which probably you did not set.

Also please refer to our plugin setup guide workflow in demo: https://bubble.is/page?type=page&name=aws-uploader&id=zeroqode-demo-02&tab=tabs-2
as how it is set and should work.
Hope this helps.

Regards,
Dumitru.


#3

I already set the keys
It shows “enter API key” because the live keys aren’t set, only the test ones are.


#4

Hi again, I still have this issue.

This is the error I’m getting in the dev console when trying to delete a file:

image

This is my CORS Policy, It’s just the default one for now.

image

Again, I can upload files just fine.


#5

Hi, @marcus.

Sorry for a delayed response, seems like it slipped my attention. We’re looking at the issue in place and be back to you asap.
Thanks for understanding.


#6

Hi @marcus.

We double checked the plugin actions, delete action is working fine. Would recommend you double check the configuration of AWS and try setting the for both live and dev aws keys in plugin setting.
Presume you could check the CORS policies (https://aws.amazon.com/premiumsupport/knowledge-center/no-access-control-allow-origin-error/) and open access to delete action, since looking at the console screen provided the bucket blocked the delete request so plugin is not the issue.
Also please check the documentation: https://docs.zeroqode.com/plugins/aws-file-uploader-plugin
Thanks for understanding

Regards,
Dumitru.


#7

Hi,

Thanks for those actions, I have tried them and I still have this problem.

Yes, I tested your demo and the plugin seems to work fine.

Can you send me the CORS policy you used in your Amazon AWS account? If my CORS policy is the problem and I’m only copying from your documentation: (https://docs.zeroqode.com/plugins/aws-file-uploader-plugin) then maybe that is wrong somehow? Maybe Amazon changed something in an update.

Just want to try every option here.

Thanks.


#8

Any update on my question above?


#9

Hello, @marcus.

Sure, of course please see our permissions policies for bucket.

Sorry for late response. Hope this helps.
Thanks.