Templates Plugins Courses

AWS Plugin - Unable to delete file

Good morning,

I have been using AWS plugin for a few days now. Everything is working fine, i can upload files and access them, but i can’t delete them.

When i Do the workflow Delete file with the file url (passed dynamically or I copy/pasted it), nothing happens.

I checked the documentation several times, did all the process 3 times, it’s still not working. I don’t have any error in the console though

I have been reading the plugin topic + a couple that I found :

Please find below a couple of screenshots to show my configuration :

Bucket policy

CORS

Workflow (either dynamic value, which is an uploaded aws file url, or statically, where i take the url of the file and paste it there)
Capture d’écran 2021-04-14 à 08.54.15

Is that the url or the key we have to paste ? In the doc it says url but the label says key, and i can find 2 different values in my dashboard :

(Bonus question, i tried both and none of them are working)

Thank you

Have a nice day

Hello, @mickael.vermand
Thanks for using our plugin.

First of all, allow me to recommend you check the API Key setting. More correctly check the identity pool id which probably you did not set:

Also, as we can see from your last screenshot, you use the wrong Key in the fiend.

Action “Delete file” should be used in order to delete one file from an S3 Bucket. Action Properties are next: Key - URL of the file to be deleted

Please find the documentation on this matter: AWS File Uploader Plugin - Zeroqode Documentation

In case you want to Delete Files (list of files), please analyze the action properties here: AWS File Uploader Plugin - Zeroqode Documentation
image

Please use our Demo Page in order to set up correctly the Workflow for the “Delete file” action: zeroqode-demo-02 | Bubble Editor

Please check these settings and let me know if all is working.
Regards,

Hello @Ecaterina,

Thank you for your answer.

As I wrote in my first post, i can upload files properly, so i think the settings (keys) should be fine. You can check it out on the screenshot below :

About my last screenshot, the dynamic value I use is an URL, i did another screenshot to be more explicit :

Capture d’écran 2021-04-14 à 13.29.47

This is the exact url of the file (i double checked on my S3 console)

Hello, @mickael.vermand
Thanks for provided details.

It is most likely that when you set the Key-value to “Parents Group’s Chapitre’s Video’s URL” and trigger the delete action, the removal of the “Video File’s URL” does not happen.

Allow me to suggest you change the Key-value to something else (keeping the relation to the file you want to delete) - set the Key value requesting to the table where your video file URL is placed (Input where your file is placed).

Or you may set the Delete file workflow as it is shown on the plugin demo page - this option will work for sure.

image

Please try to change the Key-value and let me know if it works now.
Regards,

Thanks again.

I tried the exact same setting that on the demo : an input containing a file url. But it’s the same, nothing happens.

I don’t even get an error, nothing. It’s like i’m not even clicking on the button :slight_smile:

Hello, @mickael.vermand
Sorry for this inconvenience.

As I see from your screenshot, you are using the Parent’s Group, but not an Input with URL’s value.

So, if you are willing to Delete files, you need to “call” these files value:

After the workflow has run, the indicated files will be deleted from the S3 Bucket.

Please try to change it exactly as on my screenshots and let me know if all is working now.

In case if you still will encounter your issue, please share with us the screenshots of your workflow and current settings of the plugin elements and we will investigate your use case.

Best regards,