Templates Plugins Courses

Bubble page to pdf

Hi
I have successfully been using this plugin for a live app for the last 6 months and it has just stopped working - it gets to the point of converting the pdf but never completes. I have not changed anything in the process.

https://www.dearnside.blackboxapps.com/version-test

We have the same problem here!
The plugin just stopped working today!
It does not present an error message, but it does not generate the PDF.
The problem occurs in both the Live and Dev versions.

1 Like

@simoneosborneshaw, @ribeiro.osmar, thanks for reaching us out, friends.

I’m afraid, we do not encounter any alike issues at the moment. The plugin works well on our test demo page and our user’s apps (which we had a chance to test just now), on the latest version, and on the 1.27 version as well.

It seems like those were temporary issues with the plugin’s server-side. Can you please check now and tell me if you still face this trouble? Please make sure you have given a few seconds to the plugin to generate the page. :pray:

Regards,

The latest version is not 1.27, it is 1.49 as you can see in the image below.

In the demo page they are using the “testing” version and it is different from the last version available.
In the last available version, there are no such fields marked in the image below, only in testing.

I am still facing the same issue in both dev and live i have tried both the 1.27 version and the 1.49 version.

Kate, any solution?
We have customers waiting for this in the live version!

same here - my users are getting frustrated

@simoneosborneshaw, @ribeiro.osmar,

We are always struggling to help all our users, but in cases when the user’s cases are impossible to recreate on our side or the details they provide are not enough for recreating the faced issue - we have to request access to those user’s apps to check the work of the product.

Please provide the access to your application for our support account [email protected] to let us be able to test the plugin within your app and find the root cause of the issue you have faced.

I’m afraid, it is impossible to find the solution for a case that is not investigated properly.

Thanks. :pray:

Hi Kate,

That would be great if you could look into it - I have added the support to the users, i really hope you are able to help

Thanks

1 Like

It seems to be again a problem with CORS as you can see in the image below extracted from the console.
We’ve been through this problem before.

1 Like

ok do you have a link on how i resolve this

@simoneosborneshaw

Thanks for it! Just checked - the plugin is unable to convert the page pdf due to the CORS policies:

Learn more about it:

Our developer team can check this moment to provide more details for the issue resolving, but from the article I’ve sent it states that the issue can be resolved from the user’s side.

To be able provide you more details, our dev team needs some time for the investigation.
Regards,

One more thing. The page you have, might throw the CORS error if it contains some data that is restricted from the public view. Removing of those restrictions will do the trick and help the plugin to have the access to the page’s content and convert it successfully.

To make sure the plugin works in your app - create a test page with a few elements and add the convert to pdf workflow. I’ve created the test page called zq_test inside @simoneosborneshaw’s app - and the plugin works OK.

ok so i must have something restricted i will check that out thank you

1 Like

@simoneosborneshaw,

You’re always welcome! The issue must be in your application icon and these images:


image
Perhaps the access rights to those images were restricted/ made private. If you remove them, the page will be converted.


@ribeiro.osmar,
I’m sorry, but at the moment I have nothing to suggest you else from the above. I will open the investigation ticket for our developer team to prepare the explanation how to add Heaters properly and the possible workaround for this case. But it might take some time. I will do my best to get back to you tomorrow with this. Apologies for the delay due to the time zone difference.

:pray:

Regards,

@kate

The problem was occurring due to the images.
I removed them one by one and the CORS problems are gone … but I need the images in the PDF …

Even after removing the images and ending the CORS problems, it still did not generate the PDF.

Now this problem appears below:

@ribeiro.osmar,

Thank you for provided details. We will investigate them and get back to you asap.

Thank you for understanding. :pray:

@kate
Thank you so much yes i removed the images and now it works. Strange that that suddenly happened but glad it is resolved.
Thanks again for all your help

1 Like

@simoneosborneshaw,

We have made a small fix that does not require the plugin version update. Can you please check it within your app? I suppose you should try to convert the page that includes the images it was containing before.

Please check and let me know if you don’t mind.
Thank you :pray:

Hi Yes i was able to add the images again with no issues.

1 Like