Templates Plugins Courses

Community Web App like Yelp Course | Lesson 8

Dear Zeroqode Team,

I have an issue with Lesson 8th on Yelp Course. I followed everything according to the teacher of the class. But unfortunately when I click Update Biz and write the name of the company it doesn’t show me on the input fields.

Please urgent help required.

Hello @Car-Listing,

Could you please check once again if you have set-up the “AutocompleteDropdown Name of Business” element and “update a posting” group as shown in the tutorial. Besides, that the company you are searching for should be already created in the database, you can check if the company exists in Data>App data> All Businesses.

And one small clarification, to make things clear. The input fields are not populating or you just don’t see the company name in the list when you write its name in “Name of Business Search”?

Best Regards,
Alex

Please check these screens I did what is shown there. Can you help me through anydesk or similar programs, which I can share my screen better with you?

Kind Regards,

On the above screenshots, everything seems to be set up correctly. What about “update a posting” group did you set up the data source there? Also, the business you want to be displayed does have the needed data saved in the database? (address, phone, websites, etc.)

Regarding screen sharing apps, unfortunately, we are using only the forum for support. But here you can upload also videos. Also, if after the check it will still not work I will ask you for access to the app. But at the moment please check questions from above.

Best Regards,
Alex

Dear Alex,

Thanks a lot.

Please find the screens below I followed everything. When I type the name of the company it shows and I click and I even tried writing full name and press but still it is disappearing somewhere.

@Car-Listing can you please add [email protected] as collaborators to your app. There you will see a notification about the limitations of your plan, please disregard it. In order to add us as collaborators please go to Settings > Collaborations.

Best Regards,
Alex

Dear Alex,

Thanks for prompt response. I added given email as collaborator, please kindly advice me for the next steps.

Kind Regards,

@Car-Listing thank you for providing the access we will investigate what may be the issue and will come back with an answer.

Best Regards,
Alex

Dear Alex,

Please confirm if i did everything correct or should i write Bubble Team?

Kind Regards,

Hello @Car-Listing,

I wanted to make sure that everything is correct and also checked the issue with our devs. From what we see settings are correct and there is a bug with the search box. In the current circumstances, the best solution would be to reach Bubble Team. Here you can report the bug:

Best Regards,
Alex

Dear Alex,

Thanks I did it. Looking forward their response.

Wish you a great day ahead!

1 Like

Dear Alex,

While they are looking for the bug I found work around which worked fine.

When I do through parent group’value it don’'t work. That is why i work around with putting every input column Search Box’s Value instead parent group which did the work and i resolved. And then i change it on the workflow where I put the change the thing to the Search Box Value and it saved new data in database. Now whenever i type new business name and press enter it shows me data within this way.

Thanks in all case for your help and I hope this workaround will save some students time.

Kind Regards,

Hello @Car-Listing,

Thank you for describing the workaround that you found. Glad to hear that you managed to fix the issue on your side. I hope Bubble will manage to fix the bug.

Best Regards,
Alex

Hi there,

Just to jump in here as I have now reached this lesson.

It seems that this is still a bug with bubble. I have tried the workaround suggested above and that isn’t working for me either.

It’s really frustrating because it seems that when I enter data in the search box I can see the fields populating for a split second before disappearing. Do you know why this may be?

I really want to continue this course but I’m worried this will hold me up!

Best,

Liam

Hi, there!

Thanks for reaching out!

So, to help you better and in order to check all the settings and workflows, could you please add our [email protected] account to your collaborator’s list in Settings -> Collaboration so we could check the issue inside your application. Plus, please tell us the name of your Bubble application and page name where you develop it, it would be way easier for us to help you solve the issues.

Note: avoid the warning message regarding Professional plan, as we are an agency and you can easily add us to your collaborators.

Best, Julia.

Hi Julia,

Thanks for reaching out. I have added [email protected] as a collaborator. The page in question is called Admin. The issue is pretty much the same as what has been said above.

Best,

Liam

1 Like

Hi, @liam1!

I have tested your app and indeed the search box doesn’t work, it seems like it wasn’t fixed yet. But anyway, I have replaced initial content in the inputs for Searchbox’s value and it works.

Note: the Data source of the Updating a post group should be cleared.

Also, please indicate in the workflow of the button- “Update”, in a first step- Things to change from Parent Group’s business to Searchbox’s value

Hope this helps!
Best, Julia.

Hi Julia,

Thanks so much for your help here. I appreciate the explanation!

As you can see I’ve moved on with the course and I’m making good progress.

Thanks again.

Best,

Liam

2 Likes

Hi, @liam1!

So, glad to hear that :slightly_smiling_face: You are always welcome and hope you’ll achieve a great result in the end! :wink:

Best, Julia.

1 Like