Templates Plugins Courses

📈 Documents Viewer - New Plugin from Zeroqode

Documents Viewer allows you to easily preview Microsoft and Google documents inside your app without downloading the files. You can open them through dynamic or static links in the input fields. The plugin comes with two elements: Microsoft Viewer and Google Viewer.

Type of supported files:
Microsoft Viewer - (’.ppt’ ‘.pptx’ ‘.doc’, ‘.docx’, ‘.xls’, ‘.xlsx’)
Google Viewer - (.JPEG, .PNG, .GIF, .TIFF, .BMP), (WebM, .MPEG4, .3GPP, .MOV, .AVI, .MPEGPS, .WMV, .FLV), (.TXT), (.CSS, .HTML, .PHP, .C, .CPP, .H, .HPP, .JS), (.DOC and .DOCX), (.XLS and .XLSX), (.PPT and .PPTX), (.PDF), (.PAGES), (.AI), (.PSD), (.TIFF), (.DXF), (.SVG), (.EPS, .PS), (.TTF), (.XPS), (.ZIP and .RAR)

Important Note: Google Viewer works only with public documents that have docs.google.com urls.

Live demo: https://zeroqode-demo-17.bubbleapps.io/documents_viewer
Plugin page: https://bubble.is/plugin/documents-viewer-1561452651815x527935611742978050

Please support us with a retweet

Levon Terteryan

Founder @ Zeroqode

zeroqode-for-web-160x120

Bubble Templates

Zeroqode Blocks

Bubble Plugins

Bubble Courses

Convert Web to iOS & Android

No-code Development Services

Hi @levon

Both the Microsoft Viewer and the Google Viewer work fine when the file I’m trying to preview is open to the web.

However, as soon as I add any kind of Privacy Data Role, the Google Viewer can no longer preview the file (the Microsoft one seems fine). Is that expected behaviour?

Cheers
Travis

Hi Travis
i believe so, if it’s not possible to open from the web then how the plugin will be able to see it?

Thanks @levon,
You’re right - same issue with the Microsoft viewer:
Screenshot_3
Sorry, I hadn’t thought through how Microsoft & Google’s file preview services worked - of course they need access to the file to display it.
I’ll have to find another solution though because I want to preview files inside my private app.
Cheers
Travis

1 Like

Just purchased this and tried to get a PDF to display as shown in the list of supported files and I get two system error:

  1. The plugin Documents Viewer / element Google Viewer threw the following error: TypeError: Cannot set property ‘url’ of undefined
    at eval (PLUGIN_Documents-Viewer-update–Google-Viewer-.js:1:26)
    at https://dhtiece9044ep.cloudfront.net/package/run_debug_js/31e1eb5bbbc2f9a4888e20f22c4412bb6ad2aad3c471758e7e675346ebe24c64/xfalse/x5:18:444330 (please report this to the plugin author)

  2. The plugin Documents Viewer / element Google Viewer threw the following error: ReferenceError: Vue is not defined
    at eval (PLUGIN_Documents-Viewer-initialize–Google-Viewer-.js:1:110)
    at https://dhtiece9044ep.cloudfront.net/package/run_debug_js/31e1eb5bbbc2f9a4888e20f22c4412bb6ad2aad3c471758e7e675346ebe24c64/xfalse/x5:18:444097 (please report this to the plugin author)

SAA

Hello @sanastasi, thank you for reaching out!

Could you please add [email protected] as collaborators to your app. It will help to understand the causes of the issue and find the solution ASAP. In order to do that just go to settings > collaboration and insert [email protected].

Thank you in advance!

Best Regards,
Alex.

Hi, I’m not able to show any google file
Tried to use the share link:

https://docs.google.com/document/d/16rRZ78w8cAm2t18_B67yL5FXu2DOUqYaXgH4xTHl6PE/edit?usp=sharing

and the publish on internet link:

https://docs.google.com/document/d/e/2PACX-1vT2au6sf6Nlt9qQzlOHcaV76LYStdRmRTtoY8oKvvYacK0hGzlqkZYstYEQbiczZnw_GIoMj2F6SJfx/pub

it is even not working in the Zeroqode Plugin Demo page:

https://zeroqode-demo-17.bubbleapps.io/documents_viewer

when I enter the publish code in the plugin on my APP:

2PACX-1vT2au6sf6Nlt9qQzlOHcaV76LYStdRmRTtoY8oKvvYacK0hGzlqkZYstYEQbiczZnw_GIoMj2F6SJfx

Then I can see the document in the APP as I’m logged in my Google Account.
My users can’t see the document.
When I send the complete link by email they can see it.

What is going wrong??

Hi @marco, thanks for reaching out. I’m afraid it is a plugin issue. Let us better investigate it and I’ll get back to you with a solution as soon as possible. Thank you for feedback!

Hi @marco, I’m reaching out to notify that there is a problem with displaying Google, indeed. However, it is not a plugin issue, it’s related to Docs itself that we cannot help with, unfortunately. You can check the plugin to see that it displays well an external document with this link https://file-examples.com/wp-content/uploads/2017/02/file_example_XLS_10.xls on our demo app also https://zeroqode-demo-17.bubbleapps.io/documents_viewer. Thank you for patience and understanding :pray:

I’m getting very inconsistent results using this plugin.

Loading can be quick sometimes and slow others… even for the same document.

Typically I have to click around multiple documents to get them to show… then once they’re showing they seem to be OK until you realise that its not updating consistently resulting in users looking at the wrong document.

Is there any way to fix this or is it just unreliable due to the constraints of using googles plugin?

As a minimum we need the ability to reset the viewer before loading up a new document so that users aren’t left looking at the wrong documents… at least that way they’re looking at nothing rather than the wrong document.

I have recorded a video which I can DM if required.

Cheers

Hi, @shaun, thanks for reaching out!

Unfortunately, we cannot influence Google file Viewer, because the result of its work doesn’t depend on the plugin itself, but on Google viewer. For a better experience, we recommend using URL for public files from google drive in order to preview the files correctly. In another case, it might view documents, might not. Apologies for the inconvenience. :pray:

Best, Julia.

Hello @levon,

I love the documents viewer, but I can’t get it to work on a phone (works perfectly on my computer or ipad). Is this a limitation or is there specific settings I need to adjust to make it work on a phone? If it should work, what settings should I adjust?

Thanks!

Hi, @oscar.rene.romano!

Thanks for reaching out!

Actually, you don’t need to adjust any specific settings in the plugin to make it work on mobile devices. I’ve checked the plugin on mobile and it works properly. Could you please clarify what device, browser/OS have you used while testing? Also please share the screenshots of the result or clarify what exactly doesn’t work? Is any error appearing? Any additional info would be super helpful! Thanks.

Best, Julia.

@julia.minacova Thank you so much for getting back to me so quickly! I’ve been using Chrome on my Macbook Air to build the app on bubble. I tested it with Chrome on my Macbook Air, iPad and iPhone, but it’d only work on my Macbook Air and iPad. I have attached a screenshot of the screen on my Mac and one on my iPhone so you can see how the viewer works just fine on one but not the other. Hopefully you can help!

@oscar.rene.romano thanks for the info. Could you please additionally provide browser/OS versions. Also, what viewer have you tested: Google or Microsoft?

Looking forward to hearing from you!
Best, Julia.

@julia.minacova I’ve been testing the Microsoft viewer on the following devices, browsers, and OSs: my Macbook Air (Big Sur V. 11.1) via Chrome (Version 88.0.4324.146 (Official Build) (x86_64)) and my iPhone Xs Max (OS 14.4) via Chrome (Version 87.0.4280.77).

Thanks again for your help with this! Would make a big difference if I could get it to work on mobile devices.

Appreciate it!
Oscar

Hi, @oscar.rene.romano!

Thanks for the additional details. Let us investigate this carefully and I’ll get back to you asap with an update. Thanks for understanding :pray:

Best, Julia.

1 Like

Hi, @oscar.rene.romano!

Its been a while, so apologies for the slow reply. :pray: We have investigated this case and it turns out that Word preview APIs are currently not supported on Mac, iOS, or on the Web: https://docs.microsoft.com/en-us/office/dev/add-ins/reference/requirement-sets/word-preview-apis .
The case that it works on a laptop can be explained that iOS has made updates which allow this work while a Microsoft cannot guarantee operation, unfortunately. Anyway, we’ll keep monitoring and once any updates appear we’ll take into account that. Apologies for the inconvenience!

Best, Julia.

@julia.minacova Thank you so much for getting back to me! That’s really unfortunate, but at least now I know and can adjust course accordingly. Please let me know if you hear of any changes to this moving forward.

Have a good one!

1 Like

Hi, @oscar.rene.romano!

Yes, sure and thank you for the understanding! If any changes are, I do let you know!

Best, Julia.