Services Plugins FAQs

Drag & Drop to Reorder RG - Not dropping on mobile

Hello Team,

I am able to drag with touch on a mobile but it doesn’t drop. Element just goes back where it was.

Thoughts?

Cheers, Kurt

Hello @kurt1,

Thanks for reaching out!

Unfortunately, the issue is not reproducing on our side. Could you please check the mobile settings in plugin element and give it another try?

Summary

If the issue persist, please let us know on which devices the issue is happening. Any screenshots/additional explanations will be highly appreciated. :pray:

Best regards,
Gulce

Hello Zerocode Team,

I have exactly the same issue : drag and drop works very well on desktop but the drop function doesn’t work on mobile.

I’ve followed this process :

  • checked the settings of the draggable element : exactly the same as you did on the screenshot above.
  • checked the settings of the RG Element + Draggable element of your demo editor (Sorting Mode)

It works 100 % perfectly on destop (drag + drop) but not on mobile (drag only :face_with_raised_eyebrow: )

Moreover, could you please confirm that the drag/drop function works (on front) without workflow event ?
Cause I work with API (on Firestore) and I’d like the order change to be registered only with a register button (otherwise, Bubble will call the API for every single change and my app’ will crash )
Cause when I look your demo on debug, the action of change trigger a WF event : is the WF event necessary to change only the front (not in the database/API) ?

Thank in advance

Best regards

Audrey

Hello @audrey.gouzer,

Thank you for reaching out to us.

I’m sorry to hear about the issues you’re experiencing with the plugin. To better assist you, could you please provide more details about your use-case?

Specifically, which device and browser are you using? Have you tried accessing the plugin on other devices? Is the behavior consistent across different devices?

Please ensure you are using the latest version of the plugin. Could you also try using our demo page on your device to see if the drag and drop will work well for you there?

Additionally, could you share screenshots or a screencast showing how you have configured the element in your app, the repeating group, any workflows attached to it, and what exactly happens on your device when you attempt to drag and drop? These details will help us understand and reproduce your setup on our end.

Could you please provide more details on what exactly do you want to achieve? You can set the element to only drag and drop without any workflow, however saving the new order in the database would require a workflow.

Thank you once again and I look forward to your reply. :pray:

Best regards,
Stefan

1 Like

Hi @Stephan,

Thank you for your very quick answer.

It seems that the problem comes from the fact that I work with an API (via Api connector).
I made the test by using the database Bubble for the data of the RG : absolutely no problem on mobile devices (smartphone and tablet) with the same settings of the plugin element.

a) Destop : the plugin works very well, either by calling data from the database Bubble or the API (sorry I don’t know how to add a video/screencast right there)

b) I’ve got the problem of not dropping only on mobile device (tablet + smartphone) when my data comes from my API (not from the database)

c) I use Chrome on my smartphone and tablet

d) I use the last version of the plugin : I made the settings of the plugin element exactly as in the demo editor of the plugin


I hope that I’m clear my the situation (with the screencast it would be more clear : I can send it by e-mail)

Thank you !

Best regards

Audrey

Hello @audrey.gouzer,

Thank you for your message and for providing the details.

To share the video, you can either record it using Loom and share the link with us, or upload it to an online service like “https://www.transfernow.net/” and send us the link. Alternatively, you can also reach out to our support team directly at support@zeroqode.com.

Based on the images you shared, it appears you have populated the “Things” and “Sort data” fields in the element[image], which are typically used for automatically saving the new order in the database. In your case, if you’re using data from an API call, you won’t need these fields, and they could be causing the issue.

Could you please try removing them and let us know if that resolves the problem?

Thank you once again, and I look forward to your reply.

Best regards,
Stefan

1 Like

Hello @Stephan,

Fantastic !!!
Thank you so so much for your fast and relevant answer : issue resolved in just 2 seconds :pray:

The fields ‘Things’ and ‘Sort data’ have to be empty by using data from API :ok_hand:

Have a very nice week-end

Best regards

Audrey

Hello @audrey.gouzer,

Thank you so much for your message and feedback. :pray:

Great to hear that it successfully solved the concern you had, please feel free to reach us anytime you have a question, inquiry, or an improvement idea, it’s always a pleasure to cooperate.

By the way, if you enjoy the plugin and would like to support us, we would be immensely grateful if you could share your experience by leaving a review. It not only supports us but also helps the wider Bubble community in making informed choices.

To rate our plugin, simply visit the Plugins tab in your Bubble editor, find the plugin by name, and share your experience through the rating system.

Thank you once again and wish you a great week ahead! :star2:

Best regards,
Stefan

1 Like

Hello Stephan,

It seems that my problem isn’t totally resolved for the mobile device.
I made the tests above on a test page of my app and it works very well on destop and mobile with my API, with the fields ‘Things’ and ‘Sort data’ empty.

But by introducing the plugin element on my app with exactly the same settings of the plugin element - fields ‘Things’ and ‘Sort data’ empty - the same problems appear : it works very well on destop but not on mobile (the drag operation is ok but not the drop)

I send you the videos by e-mail

If you can give me some clue to investigate where the ‘conflict’ can provide from, it would be nice

Thank you :pray:

Audrey

Hello @audrey.gouzer,

Thank you for reaching out.

I’m sorry to hear that you’ve encountered this concern again. To better understand what happened, could you provide more details? Specifically, when you mention introducing the element into your app, do you mean that you’ve added it to another page, or that you added it to a wrapped app?

Regarding the videos, yes, you can send them to our support email as per your convinience, please include your email address in your message so we can identify that they are coming from you. Also, ensure the video clearly shows the exact setup of the plugin element and the Repeating Group (RG).

Thank you, and I look forward to your reply to assist you further.

Best regards,
Stefan

Hello @Stephan

Thank you for the revelant answer as useful : I’ve just sent to the support an additionnal e-mail with

And to asnwer your answer : I added the element to another page of the same app (I always create a page to test a plugin) :slight_smile:

I hope your team has got as much as informations as needed

Thank you

Audrey

1 Like

Hello @Audrey,

Thank you for your message and for your cooperation.

I’ve searched and attempted to locate the email you mentioned but unfortunately couldn’t find it—I even checked the spam folder just in case. Could you please double-check if you sent the messages to our support@zeroqode.com? You might also consider adding my email, stefan.chiciuc@zeroqode.com, in the CC to ensure it’s received. Alternatively, please try resending it in case it was somehow deleted.

Additionally, if you could share your email address here, it would help us locate your message more easily in case we missed it. :pray:

Thanks for your understanding. I look forward to your response.

Best regards,
Stefan

Hello Stefan,

Thank you : it seems that the files are too heavy for Outlook (even if there are zipped or not so heavy : i’ve got systematically an error message) so I’ve just sent another mail with a Wetransfer link to the support.

Hope you will receive it : and I transfer it on your personnal e-mail stefan.chiciuc@zeroqode.com

Thank you for your relevant answers as useful

Best regards

Audrey

Hello @audrey.gouzer,

Thank you for your message.

Yes, we have succesefully received your email with the attached videos and screenshots. After further testing with your setup and various settings on our side, we have not been able to reproduce the issue on our side.

To better understand the problem and find a resolution, could you please add our Support Team email to the list of collaborators in your application and share the app’s link with us? This will allow us to examine your settings and replicate them on our end to pinpoint the problem.

To add our Support Team as a collaborator, please follow these steps in the Bubble Editor: Settings > Collaboration > Add email support@zeroqode.com.

Additionally, please provide instructions on how to reproduce the issue on our side, including the name of the page where the plugin element is located, group, repeating group, plugin element configuration, and the associated workflow. A short description of where to click and any test user credentials to log in will help us troubleshoot the reported issue. If possible, please attach a short Loom video (screencast recording) providing this guide.

Thank you for your understanding and cooperation.

Wishing you a great start to the week!

Best regards,
Stefan

1 Like

Hello Stefan,

Thank you for the relevant answer and the energy deployed to resolve the problem.
The fact is that my Bubble plan (Personal plan) doesn’t allow me to add a colaborator …

And I don’t have the necessary perspective on Bubble administration to offer another way

Is a video call by sharing my screen could be possible in the next few days ?

Best regards

Audrey

Hello,

I hope that your received my e-mail with the Wetransfer link.
I seems that I can’t e-mail the support : here is the error message I received (in french / translation below)

"Delivery failed for these recipients or groups:
support@zerocode.com (support@zerocode.com)
We were unable to return your mail. The recipient’s mail system refused to accept a connection from your mail system despite several attempts to deliver your mail.
Contact the recipient by another means (for example, by phone) and ask them to inform their email administrator that their email system seems to refuse connections from your email server. Provide the error details below. It is likely that only the recipient’s mail administrator can resolve the issue.
For mail administrators
No connection was successful because the target computer actively refused it. This is usually due to an attempt to connect to an inactive service on the remote host (without running server application). "

Here is the link Wetransfer which expire on 04th July : https://we.tl/t-5ntfq1AvQq

Best regards

Audrey

Hello @Audrey,

Thank you for your message.

We received the details you provided earlier on the email, and after further testing, I managed finally to reproduce the problem. It appears that the problem occurs when there are other draggable elements on the page besides the one used for the current RG. This behavior is indeed unusual and shouldn’t happen.

I have forwarded this information to the development team for further investigation and resolution. I will inform you as soon as we have any updates.

In the meantime, if you have any other questions or need assistance, please let me know.

Thank you, and have a great day!

Best regards,
Stefan

1 Like

Hello Stefan,

Thank you ! I am glad that the source of the problem has been identified and that the technical resolution is under study :pray:

So I wait for your return :ok_hand: (I will be on holidays next week for 10 days so don’t worry if I’m not reactive to answer

Have a nice day too !

Best regards

Audrey

1 Like

Hello @audrey.gouzer,

Thank you for your message. :pray:

Yes, the development team is currently looking into it, and a resolution should be ready for your review when you return.

Thanks again, and have a great holiday ahead! :star2:

Best regards,
Stefan

1 Like