Templates Plugins Courses

Eaty delivery template - search function problem

Dear support and community,

We are a currently a team developing a bubbe-based MVP using ‘Eaty Delivery’ template from Zerocode.
Having set the template we followed instructions from Zerocode as per the guide :
https://docs.zeroqode.com/templates/eaty-food-delivery-uber-eats-template/setup-guide

Unfortunately it appears that :
(i) On our development version once plugins are set-up, the search function from index page seems broken and return the message: "Sorry, we ran into a temporary bug and can’t complete your request. We’ll fix it as soon as we can; please try again in a bit! "

(ii) On our live version (untouched from the Zerocode initial template) return the same problem

Thus, we tried on a third version to uninstall Google Plugin + OneSignal completely and the search function is back again.

I understand that this issue may be frequent has been reported in previous Topic on different templates and received support assistance :


Any kind of assistance or expertise on this issue would be highly appreciated

Many thanks !

Hello, @hekafab
Thanks for reporting your issue.

Please allow me to mention that currently, there may be such bugs on the Bubble side. They are not reproduced from our side.

Additionally, please check the documentation for the Google Plugin and OneSignal Plugin and carefully verify all used keys for your application.:

https://docs.zeroqode.com/plugins/google-plugin

https://manual.bubble.io/core-resources/bubble-made-plugins/onesignal-web-notifications

As a solution, you indeed can remove these plugins and reinstall them repeatedly. It should help you.

In case if you will face its issue repeatedly, please share with us the screenshots of your current settings for these elements.

Hope it will help you.
Best regards,

Hi Ecaterina,

Many thanks for your reply.

To bring further details, we finally double-checked our settings on all version ( i / ii / iii above post) and the problem persists with or without the Plugins (as indicated above) installed. So the problem may unlikely be caused by both plugins.

Additionally, we discovered that not only the search function is affected by this error but also ALL actions from the app (admin actions CRUD for instance).
See below the error :

Hi Ecaterina,

Finally we successfully managed to solve part of the problem after - as your recommended - having repeatedly reinstalled plugins.
However we still struggle on the restaurant_search page for which, despite geoloc/google API working and responding really well, does not list the nearby restaurant we stored in our database.
In our attempts, we made sure of :
(i) Typing an address detected by google in the search bar ;
(ii) Registered several restaurants near the address typed in (i) in the database (same street);
(iii) Set a radius of a radius for both courrier and customer of +2000/3000 ;
(iv) Set opening time to the maximum (every day from 12 AM to 11 PM) for everyday of the week ;

Well… no results show up in the template… any ideas ?

Merci !

Hello, @hekafab
Happy to hear that you were able to fix some of your issues.

Please find below my advice in order to fix your issue:

  1. First of all, allow me to recommend you to change your Radius and to make it smaller. A big Radius can reproduce an issue even though you will be in its area (note that Radius in the DB is indicated in KM). https://prnt.sc/12aoy3r

  2. After it, please make sure that you checked our current settings on the Demo Page for the Restaurant search function:


  3. Make sure that your searching criteria are correct:

Please check these points and let me know if it works now.
Regards,

Hello @Ecaterina,

Many thanks for your reply.
Upon your advices, I reviewed the following :

  1. I played with the radius. Initially, courrier radius was set to 1000 and customer radius was 1500 ; I tried with minimum values such as 200/300 and greater aswell 2000/3000. But it does not provide any results in the restaurant_search.

    Please note that in order to try our search we are using an account which address is in the same street of the restaurant in the database (we only changed the addresses of the restaurants already in the template).

Additionally we tried modifying the GoogleDirection API column (as the previous code is not the one from ou GeoAPI set in our app settings). Without more success.

  1. We reviewed the current settings on Restaurant search function, as per the below :


  2. Unless mistaken, searching criteria seems fine :

What to you think ?

Thank you !

Hello, @hekafab
Thanks for the details.

In case if you configured correctly the searching function, the main issue is in the Keys, which you use for the searching function.
Please verify the Google Keys and the Map keys, if required in the plugin’s Tab.

Best regards,

Thank your @Ecaterina

So we indeed followed the process indicated per the documentation (https://docs.zeroqode.com/plugins/google-plugin ).

As indicated in my comments above, we were able to set up the API and therefore make our first deployment on live version.

From our Google dashboard we are able to monitor our app’s activity (see below)

Therefore we do not think that the problem is hiding in our API keys but rather from the template itself.
Furthermore, no restaurant are showing up in the index page (not only in restaurant_search)

Is there any further plugins that we might have missed ?

Hi

Related to my post above, I would like to bring further details as it seems that the search is not reacting in orverall. For instance even by trying to ‘view all’ function brings the user to a blank results on the search page.

From this perspective it is reasonable to assume that it might come from the template.

Hello, @hekafab
Thanks for the details.

Allow me to note that we have tested the Demo Page of the template and it works properly. So, the issue is reproduced not from our side.

In case if the searching function not working in your application, unfortunately, we suppose that issue is related to your keys.

You can add our Support Team email to the list of collaborators to your application and provide me a link to your application. This will allow us to check your settings and run some tests to fix the mentioned problem.

To add our Support Team as a collaborator, you need to do the following steps in the Bubble Editor:

Settings > Collaboration > Add email [email protected]

Note: avoid the warning message regarding the plan, as we are an agency and you can easily add us to your collaborators.

Looking to hear you soon.
Regards,

Unfortunately we attempted to solve the issue again during the weekend without further success.

We have added [email protected] to our app for assistance, many thanks

Dear Zerocode team,

Did you had the chance to look at the template in our app ?
We are still unable to process these basic features for a week now. We would appreciate your support on it.

Many thanks

Tristan Mahe

Hello, @hekafab
Sorry for my late reply.

By this message, I would like to inform you that we have fixed the issue with the searching function within your app and all is working properly.

Please note that the main issue was filtering, which that you have applied on the “Restaurant search” page.

You already indicated the Hours of the Work in your application, so you don’t need to apply additional filters for reaching :

We deleted some of them and your searching function works well with any restaurant from your DataBase.

If you like our template you can rate it by going to the Template tab in Bubble editor. Find the template by name and give it as many stars as it deserves :blush:
I will be happy to receive your feedback!

The more feedback we get, the more motivated we are to build great templates :pray:
Thanks!

1 Like

Dear Ecaterina,

Many thanks for your prompt reply and action. We are happy to see that our template seems fixed. Thanks a lot.
Just a last word so that to fully understand : the fact that advanced list filter where implemented prevented the search to pass these arguments ?

Thanks a lot to you and the team.

Best
Tristan

Hello, @hekafab
I’m happy to hear that all is working properly🙂

The main problem was not with the advanced search, but with the fact that you had used the “status” of the restaurant twice, i.e Closed\Open.
In the database for each restaurant, you specified the opening hours that were displayed on the search page:

So, since you created a complex searching filtered, your application wasn’t able to define information at all. That’s why we deleted filters, related to the status of the restaurant.

In case of any additional questions will appear- please let us know.
Best regards,