Templates Plugins Courses

Eaty login page

I’m having an issue with the login page for restaurant and courier users. After sign up, request is sent and accepted no email is being sent to the user to set up a login or password. How do I do this?

Thank you

Hey, @Builder1254!

All functionality for signing the users up is in the template. If you will refer to our Demo and will test it out, you will get emails with credentials for both the courier and the restaurant.

I also have recorded a short video for you, using our Demo, to show in the workflow how this functionality had been set up: Loom | Free Screen & Video Recording Software

You can also refer to this template’s Documentation, to make sure you’ve set up everything correctly.

If there are any other questions, drop us a line here.

Best regards.

Hi Elena,

I have followed the video you sent to me and all the workflows are the same.

I have been approving the restaurants in the data section, requests and verifying through there versus the admin page. I’m guessing that is the reason why it is not working?

If that is the reason, how do I access the admin page in preview mode? Every time I click preview in admin it brings me back to the index page in bubble.

Thank you,

Joe

Hi Elena,

Sorry for the second message, but I keep getting this error message when I try to use the “courier sign up.” How do I fix this? I attached a screenshot.

Thank you
image

Hello, @Builder1254!
Let me please jump into your conversation and sorry for the late reply. :slightly_smiling_face:

Yes, you are correct. If you are approving restaurants/users from the App Data section, this change won’t be reflected in the template workflow and the template won’t understand when to send the confirmation email to your users. So it’s better to approve users from the admin page only.


You should make sure you are logged in as a user with admin rights.


Sorry for the second message, but I keep getting this error message when I try to use the “courier sign up.” How do I fix this?

I presume this issue appears because you might not set it yet, or you have set incorrect Google API keys in your application. Please take a look at this article to get your Google API keys:


I hope it helps! :slightly_smiling_face:

I figured out how to approve the restaurants and how to access the admin page. Thank you for that information.

However, I am still having the same issue with the courier page. I followed the video you have sent and made sure everything is correct. I keep getting a general error. I attached the exact screenshot of the issue.

@Builder1254,

Can you please also show me the screenshot of the browser console, when you are getting this error? At the moment, it is not enough for indicating the root cause of this issue, only by the “general error” screenshot :slightly_frowning_face:

Before reporting this bug to Bubble Support (as the error recommends), let’s see what your browser console error list is containing.

Hope to hear from you soon! :slightly_smiling_face:

Hello,

I have took screenshots of the browser console. I believe maybe the issue is with my restriction with the API URL, but I made sure to put the * after the URL like the video explained and the API does not work when its unrestricted (I get an error code for that too). I followed the video exactly like it shows. ( I attached a screenshot of the set up of the API’s)

Thank you, Joe



@Builder1254, thank you for the screenshots :pray:

From the error message you receive (Google Maps JavaScript API ReferenceNotAllowedMapError), there might be a few root causes:

  1. you have not set up your Google Billing
  2. you should enter your website URL without capitals (https://diversity-bites1.bubbleapps.io/*)

Please check this Error Messages article by Bubble and follow the troubleshooting flow at the beginning of the article. It should help you understand where to “dig”, cause I have no information if you have set Billing or not, and other additional minor points:

Here is another thread that might be useful:

Please check the Google’s guide and let me know if there’s anything else I can help you with.

Hello,

Thank you for this information. I got it to work now. It was the capital letters in the URL.

Thank you for all of your help. I really appreciate it.

Have a good weekend.

Joe

1 Like

@Builder1254,

I’m glad it helped, you are always welcome! :grin:

Thank you and have a good weekend too.

Hi Kate,

I am sorry to bother you again, but I am having an issue with the restaurant again. I can successfully request, approve a restaurant, and the email is being sent to restaurant with the login information, I can login as the restaurant owner. For a few minutes, I was able to access the add menu area and categories. However, I am unable to add a category or add a meal. I know this might happen due to the stripe error, but I have taken care of that. I attached a screenshots of the error.

Thank you,

Joe


@Builder1254,

It might be an app glitch. Have you tried to press the OK button on the appeared popup? Then you have to click “Add Category/Add Meal” button once again to make it work. I had the same warning popup even if I have connected Stripe. After I pressed OK - the Category repeating group appears. The same relates to the Meals menu.

We will check this moment with the dev team but meanwhile, please try the option I’ve suggested (if you haven’t tried it yet). I hope it helps.

Have a good weekend. :slightly_smiling_face:

Hi Kate,

I did what you said and it works. However, the meal is not displaying in the available section. I took screenshots of the test restaurant I made.

Thank you,

Joe


Hi Kate,

I hope you had a good weekend! Did you happen to hear back from the Dev team? I still cant figure out why the meal is not displaying.


@Builder1254,
Sorry for the late reply :pray:

Our developer team has fixed that glitch with the notification popup for the “add new meal/menu item” step. We simply removed an action “show the popup”, when it is not needed. Now the popup appears only when the user has not connected his Stripe account.

You can create a new template copy to test changes and compare the workflow setup.


On the step of adding a
new meal, there’s a checkbox “Unpublished”. If you tick it, your meal will get the status “Published” and will be visible on the restaurant page:


Hope it helps :slightly_smiling_face:

Hi Kate,

Thank you for this information. Honestly, it was the unpublished button. I thought it meant something else that is my fault. Does Zeroqode offer any customization for the template or can you point me in the right direction in order to do customization?

Thank you,

Joe

Hi Kate,

Sorry for the second message.

For some reason when I click on the dishes it will not add to the cart now (it shows no errors I’ve copied the template and looked at the workflows and I don’t see any difference. I have not messed with any of the workflows for this. I think the template is great, but when I first bought the template everything was functioning properly. I don’t know why I am having all these issues now. I attached screenshots.

Thank you,

Joe


@Builder1254,

I have tested the reported case on our demo page and it seems like everything is working fine. Will it be comfortable for you to record a video reproducing your case? Also, please include into the video part where the details of your restaurant (and the particular meal) are showed. Perhaps the root cause is there.

Or you can add our [email protected] account as a collaborator of your app (where Stripe is set up correctly) to let me check the workflow on my own.

Regards,

Hello,

I am trying to figure out how to do a video record on my computer. If not I will grab another device to do it. However, in the meantime I just wanted to send you this screenshot because the group available dishes is clicked workflow didn’t seem right its blank. I checked the other template that I downloaded and the workflows look the same. I also checked your demo and it is working fine, so I don’t know. Please let me know if this workflow is correct.

Thank you