Services Plugins FAQs

🖇 Group to PDF and Image - New Plugin from Zeroqode

This plugin convers any group (element) to PDF and Image with a super high quality. Set the ID attribute of the element you want to convert and trigger plugin action,and you will get an image or PDF.


Live demo:


Group to PDF and Image | Plugin for Bubble by Zeroqode


No-Code App Plugins for Bubble | Zeroqode

Anastasija Volozaninova
Executive Assistant @ Zeroqode
#1 Bubble Publisher and Developer


:file_folder: 165+ Bubble Templates
:mortar_board: 35+ Bubble Courses
:gear: 300+ Bubble Plugins
:iphone: Convert Bubble app to iOS & Android
:man_technologist:t4: No-code Development Services

I’m trying to use this to create certificates of completion for people who attend my courses.

My group is 1080 x 730 with a 90% width/height. That seems to make it a full landscape page with the ‘certificate’ group centred on the page nicely. I have a background image on the main group and the content is generated dynamically with the name, course, trainer, date etc.

After about an hour of testing combinations, it looks like background images mess up the rendering. The first time I generate the file:

Screen Shot 2023-01-27 at 8.21.10 AM

The next time:

Inline styles don’t render properly either:

Screen Shot 2023-01-27 at 8.15.00 AM

This generated white text.

Is there a reset or something that needs to happen after each generation of a PDF? Best I can tell, when I make changes to the page and render a PDF it works perfectly the first time, and then if I reload the page and generate it again, it’s completely messed up.

1 Like

I have the exact same issue and it basically makes the plugin unusable. Did you find a solution yet?

not yet, I posted this in the Bubble support forum as well and they replied that they’re looking into it.

I’ve left a review and messaged them yesterday, including the link to this thread, which has been seen by the team, about this same issue. I hope they will fix it asap.

Hello, @nathan2, @agiledood and @hiawwlet.
Thank you all for reaching out and reporting this to us.

Let me please check the issue with the development team. We apologise for the possible delay in response - it might happen due to our workload. :smiling_face_with_tear:

Thank you for understanding :pray:

@agiledood ,

I have tried to recreate the use case you have, as I understood it. I have a repeating group, inside of which there is a group for a certificate. It has a background image and a dynamic “name”. I generate a PDF file of 3 pages and it seems to be just fine. Please take a look:

All styles seem to be present on the resulting file, no issues with the document display.
Can you please share here, or via DM your setup screenshots (as detailed as possible)? Or add our as a collaborator of your app so I can check it from there.

@nathan2 , @hiawwlet ,

Could you please share the details of your setup too? I need to be able to verify if this is because of the plugin itself, or because some third-party plugin of your app or custom CSS/HTML is interfering with the plugin’s work.

Thank you kindly :pray:

It works the first time for me as well. The second time I try to generate it, that’s when it doesn’t work. If I make a change to the app and force it to reload, it’ll again generate properly the first time, but every time after that, it doesn’t pick up the styles.

@agiledood ,

I’m afraid, this behaviour is not reproducing on my side. Each time I click the “PDF” button to generate a file (within the same page session) - the result is normal. I tried Chrome/Safari browsers on mac and iPhone 11.

Can you please tell me what browser/device you used? And if you can, please add our support email to your app collaborators to check it within your test environment.



I replicated your workflow in my test app - still the same, no issue like you have.
Can you please tell me what browser/device you used? And if you can, please add our support email to your app collaborators to check it within your test environment.

Thank you.

Chrome on Mac. Tried Safari as well and it doesn’t generate properly at all. I added support to my instance. There is a page called ‘certtest’ you can use. If it’s easier to do this over Zoom or something, I’m ok with that.

1 Like

Thank you for the prompt response! Added your email as a collaborator!
In my case it happens with every 3rd-4th attempt and particularly when my team was testing it for their own use.

Also, is there a way to hide the preview entirely before the final image is generated?
When I try to do that, an error is thrown.

1 Like

@agiledood ,

I have created a zq_test page in your app. Please check it.



I have created the zq_test page in your app too. Everything seems to work well.

Please check my test page. I used Google Chrome, MacBook.

It looks like your test page uses fixed containers, I’m guessing that’s the fix? Would be great to update the docs with that info (unless it’s there and I didn’t see it…). I assumed the fixed dimensions of the outer container would make it render fine.

Thanks for your help!

1 Like

I got these two outputs for some reason on the new page as well.
I think you might need to test it against some new file uploads and text.

Also, I wanted to know if there was a way to directly download the picture to the user’s device instead of opening it in a new tab?

Following up here to see if there’s been an update


Apologies for the delay. I will get back to you shortly today.