Templates Plugins Courses

Has anyone tried the Create and Manage Spreadsheets plugin?

I just got this today and am totally stuck how to get it to actually work. I haven’t seen any documentation on how to set it up. I added the spreadsheet element to my page, but only get this and don’t see how to add rows/columns/etc. like this show in their demo

This is a link to to plugin.

Hello, @tmmerlo
Thanks for reaching out.

Please allow me to mention that the Spreadsheet Element - is a plugin element, which includes the sheet ( as on your screen).

After placing it on your page, you should configure the plugin’s actions, like “Add row”, “Add column” and others.
Please use our Demo Editor Page and just replicate all settings to your application:

Also, please find the screencast below:
https://www.loom.com/share/3b05ca68753a4c9ca2c2c276df6976f2

If I can help you with some additional information - please let me know.
Best regards,

Thank you for your reply. I appreciate it.
The PWC Spreadsheet demo link does not work. It says “The current user does not have permission to view this document.”
Also, I cannot hear any sound in the loom video, so that is not super helpful.

Am I supposed to create all of those “add row” etc. buttons myself? I don’t have any of them. Here is what I see on my editor page


Thank you for your help.

Hello, @tmmerlo
Thanks for your reply.

Please allow me to mention that there is no sound in the video. I just pointed out the elements you need to pay attention to.

Exactly. You should manually re-create the buttons within your application in order to work with them.

Please note, that the plugin element, which you placed on the page, includes the functionality of the plugin, but in order to use it, you should create additional tools. So, in your case, you should create the buttons, as demonstrated on our Demo Page:



In case you will face additional difficulties with it - please let me know.
Best regards,

wow, that’s really not how it is presented on the plugin page. It would have been nice to see some sort of documentation about this before I purchased to plugin so I knew what I was getting myself into.

Thanks for your help. I’ll see what I can do.

Hello, @tmmerlo
We are sorry for this inconvenience :pray:

Please allow me to mention that you can find the documentation for the plugin here:

The plugin contains Spreadsheet visual element which should be used on the page. So, the plugin actions should be created by the user, as it is indicated in the documentation.,

In case I can help you with configuration and you have some difficulties - please let me know.

Best regards,

I saw that page already, thanks. It doesn’t really give any instructions or tutorials and as I previously mentioned, your link to the version on the bubble editor doesn’t work. I’ll try and figure it out but you might want to reconsider how this is presented.

Hello, @tmmerlo
I apologize for the situation you have faced with the configuration.

We checked access to this link (read-only mode) and now, you will be able to analyze all the settings :slightly_smiling_face:: Pwc-spreadsheet-demo | Bubble Editor

Thanks for your feedback. We will consider it for the future updates of the documentation for this plugin :pray:

Please verify if you can enter it :pray:
Best regards,

Hi Everyone, new to bubble and setting up my first API workflow.

Would really appreciate any help as I am well and truly stuck on one item.

I am trying to setup excel Zeroqode - Create and Manage Spreadsheets plugin on my page. When i analyse the editor for the plugin for create a new sheet…the request data’s body stingifiedData field is present. I have setup the plugin in my app essentially just like the example editor however when i input “Request Data’s…” no item for "body stingifiedData is coming up. Where does body stingifiedData come from and how come it isn’t appearing in my list of options?

many thanks,
Michael

image

@Ecaterina desperately need your help please.

1 Like

Hello, @michael.s.disalvo
Thanks for reaching out and for using our plugin.

I’m afraid that the current plugin version hasn’t requested Data Call, namely “Create a new sheet”.
Here you can find the list of all available actions within the plugin:

Exactly, for this reason, you can’t receive the Live Stringify JSON Data.
Please note that the plugin performs the following actions:

  • Add Rows

  • Add Columns

  • Get Cell Value

  • Post Sheet Data (JSON object is sent to your workflow endpoint to store values & formats)

  • Load Data (Load the JSON object of values and cell styles)

  • Clear Sheet

  • Get CSV File (saves to your Bubble app)

Sorry for the inconvenience.
Best regards,

@Ecaterina But look at all the data fields that detected on request data for the demo editor version…

@Ecaterina Compare this to the data fields in the purchased version. My plugin purchased isn’t complete. It isn’t what was provided as the demo.

Disappointing. What is Zeroqodes solution?

Hello, @michael.s.disalvo
Sorry for this inconvenience :pray:

Please allow me to check this difference on possible API Workflow Request data internally and to revert on Monday with a response.

On top of that, I need to highlight that even on our Demo Page you can see that there is no possibility to “Create a new sheet” within this plugin.

Your experience is really important for us, thus I will revert to you as soon as will discuss it with the team.

Best regards,

Thanks @Ecaterina, greatly appreciated.

I wont necessarily need “create spreadsheet’ action as plug-in has ‘post data’ functionality and I can just create sheet through backend workflow.

It’s just that the paid plugin doesn’t have the data field to be able to post the data I require to create my sheet. Once I create a button for ‘load data’ it calls up the JSON I pushed to my database from my ‘Post data’ action. However given the paid plugin doesn’t have the available data, I get a faulty spreadsheet when I press ‘load data’ button on my live version.

Hello, @michael.s.disalvo

We analyzed your request once again and compared it with your screenshots. Can you please let us know if this checkbox is clicked?

It seems like your Headers are not activated, that’s why some Requests are not available for you.

Please check it and let me know about the result.
Best regards,

Thanks @Ecaterina I still only get the field i did before after including headers.

Hello, @michael.s.disalvo
Sorry for this trouble.

Due to the fact that we have some additional questions regarding your settings, can you please add our Support Team email to the list of collaborators to your application and provide me a link to your application? This will allow us to check your settings and run some tests to fix the mentioned problem.

To add our Support Team as a collaborator, you need to do the following steps in the Bubble Editor:

Settings > Collaboration > Add email support@zeroqode.com

Note: avoid the warning message regarding the plan, as we are an agency and you can easily add us to your collaborators.

Looking to hear you soon.
Regards,

Hi Ecaterina, Thanks so much for your help. I have just added Zeroqode as a collaborator for my app Builtex4. The page that the spreadsheet sits on is “Budget”.

1 Like

Hello, @michael.s.disalvo

I hope you checked your DM and found my message regarding the issue.
After my investigation, the issue was found and now, you will be able to find all required Data after correct initialization of the Data:

Best regards,