Templates Plugins Courses

Maps Extender Issues


#1

Hi all, I’m using the google map extender plugin. Generally the things it can do are great, but am having some issues in a number of areas.

  1. Reset Map error / Map callback error
    I’m using the following workflow (- open popup - reset map - add directions. ) so I can add directions to different destinations on a map. Without a reset, 2 direction routes overlay each other when the destination is changed. But, having a reset is creating a callback error. This is the case on the first click, but often works on the second click.

  2. UI - is there a way of turning off the UI - i.e. zoom functons and satellite while still allowing pinch zoom and markers to be present?

thanks guys


#2

anyone here that can help. I’m having some instances when the map does not load until the 2nd time I press the button. It’s making the plugin almost unusable as doesn’t work first time


#3

Hello @j.worthington,

Thank you for reaching out and reporting the issues.

We will inspect the issues you are facing and will come back with an answer ASAP.

Best Regards,
Alex


#4

Hello once again,

To solve the first issue please add a pause before the resetting action. You can set the pause even to 0 ms. It is needed to make the loading process consecutive. So, your workflow should look like this.

And yes, it is possible to turn off the UI, for that you have to check the “Disable Default UI” box from the plugin’ element.

Best Regards,
Alex


#5

Thanks, this completely worked.
I have a few situations using the same map for reseting and adding a new route when the route sometimes doesn’t loads, but it seems to be intermittent. I’ll check this and shout if it happens further

thanks


#6

Glad to hear that the issue is solved. Also, we published an updated version of the plugin with a few bug fixes. Please update the plugin to the latest version (1.14.0).

Regards,
Alex.


#7

Hi Alex, thanks for the help so far. I’ve got another one for you here that I can’t get around. Not urgent by any means.
I’ve been trying to set and display walking distance and walking duration (set to imperial), but the output is not correct. I think imperial is literally displaying feet and duration as seconds, not miles like 1.2 or minutes. I can’t seem to change this anywhere on bubble, map, or mapextender.

image
image
image