Templates Plugins Courses

Modular Text & Docs Editor


#1

Hi

I purchased this plugin recently and have 2 questions. How do I display the content after I saved it in the formatting I applied during the creation. I can display the saved data but it does not look like the styling I used.

Any Help will be appreciated, Regards
Sean


#2

Hello @sean1,
For displaying data, you have to use another EditorJS element, with initial content defined as database field where you saved your data.

I hope it helps you, if not don’t hesitate to contact us.
Thank you.
BR.


#3

@Nikita.S I just looked over this plugin, which on the surface seems great. Unfortunately, delete doesn’t work properly. Any delete key will delete the entire block in the example on the demo page. That makes the plugin virtually unusable.

The editor would need to be able to support deleting a single character and Undo for it to work for any real scenarios. Hope that feedback’s helpful! I’d happily buy it if it had those features working properly.


#4

Hey @chris1, just tested it on our demo page, it seems to work fine, I made a video for you, please check it out here.

I hope you really will be satisfied with this plugin.

Let me know if I didn’t understand the issue, and provide me with the video what did you mean.
Thank you,
BR,
Nik.


#5

Thanks for the quick reply @Nikita.S!

While the backspace works for list items, code snippets, and tables (sometimes, but not always), it doesn’t work for Headings or paragraph text.

Here’s a video:

As you can see, I only hit backspace a few times, as I was trying to remove characters, and it ended up removing all of the elements very quickly. Making matters worse, there is no undo.


#6

Hello there @chris1, I can’t reproduce the issue on my side with the backspace, so on tell me please which browser and OS do you have?

Thank you,
BR,
Nik.


#7

Hi @Nikita.S, I’m using Chrome (latest) on a Mac (latest OS).


#8

Okay I will try to reproduce it on MAC, and will be back with the response ASAP.

Thank you @chris1.
BR.


#9

So on @chris1, regarding the backspace issue, I can’t reproduce this issue, you can check it here. I was testing on Mac via Chrome as you can see, and the undo feature works fine inside one module, but if you deleted the module you can’t step back from there, cause the logs are saved for each module separately.

I have only one idea why it may break, right now I was tested with Grammarly enabled and also have few issues, not with backspace but it may be not predicted scenario, cause Grammarly add some changes to the source code HTML, please disable Grammarly for demo page and try again to test Modular editor.

Hope it helps,
Thank you,
BR.
Nik.


#10

Thanks so much for working through this, @Nikita.S! It was indeed a Grammarly issue (at least in the demo). I’ll buy this and give it a try. Thanks again :wink:


#11

Glad to hear it @chris1.

Thank you,
BR,
Nik.


#12

@Nikita.S :wave:Just subscribed to this plugin. Two things:

  1. Is there any way to do read-only mode or disable the editor in certain situations? Disabling the editor is a necessity unless I can display the content in a normal Bubble element and have it render the same.
  2. I’m having trouble with re-rendering the content (once saved, which is working correctly). Here’s a video showing the render problem. It saves, but after a page refresh it doesn’t show up (even though I confirmed it’s saved in the DB):
    https://www.dropbox.com/s/nfhbwchk0q20w3x/Screeny%20Video%20Nov%2015%2C%202019%20at%209.32.30%20AM.mov?dl=0
    There are no actions for “Set Content” of the editor on page refresh or on a Workflow action. That may be the culprit.

Thanks!


#13

So on @chris1, could you be so kind and provide the same video with step-by-step mode in debuger, in this case I will have possibility to check all the actions which are implemmented in your app, to reproduce this bug, and to find out how to walkaround this issue.

Thank you,
BR,
Nik.


#14

@Nikita.S Here you go!

It’s a little long, but at the end you can see that the DB shows the correct content after a page refresh but the editor itself doesn’t render that content:


#15

@Nikita.S I found something rather strange. When the debugger is on and I run “Step-by-Step” and refresh the page, the content correctly renders from the DB when I go to the appropriate page.

When I do the exact same thing without the debugger turned on, it doesn’t. Any ideas why that could be?


#16

@chris1 I guess it may be the delay of getting data from DB, so the plugin recieves data slower then renders, I think if you put pause before next action on 1000ms it will renders fine, may you try this?


#17

@Nikita.S Good suggestion. When, exactly, would I put the delay? After the page is refreshed? I can’t put one in between when the user clicks refresh and the refresh happening, as that’s controlled by the browser.

I’ve tried a few different scenarios with no luck.


#18

@chris1, the first action on Page Load, did you tried this one?


#19

@Nikita.S Yep, that didn’t work for me.


#20

How is set up field Initial Content of your Editor element?

Does it same with ours? https://prnt.sc/pxh57p