Templates Plugins Courses

Need help for Ride share app


#1

Hello…im really going crazy…my experience is limited…to start all my api keys were working and probably still are because the count is going up on the client and server side on the google cloud platform…but when i try to set the price per kilometer (for example 0.25) in the app data and then run the app in the rider part…it always comes up “the cost is 0” …i tried everything can you please help me? And the other main thing is the admin panel…everytime i click it,says “[email protected]” etc etc…how can i change the email there?
PS: i restored all the deleted fields in the app data,maybe i done something wrong…but i think you can see that through the app…i registered it on the site…can you please help me?
Best regards in advance.
José Simões


#2

Hello @josesimoes1987, thank you for reaching out, and sorry for any inconvenience.

Could you please share a screen of browser console when this page is opened, also, do you encounter any bugs while opening it through preview mode?

Could you please specify what exactly the message is saying and where are you clicking when the problem appears. It will be very helpful if you can specify the name of the page and the button.

Best Regards,
Alex


#3

Hello…the admin problem is on the landing page…if you press the “admin” button,that message comes up.
The message saying the trip cost is zero is when you signup a rider and make a destination selection,it should come up something like a total of 0.25 …but you guys are the developers…im sure you know this…still i provide the screen cap.
Thanks in advance.
José Simões


#4

@josesimoes1987
In order to access the dashboard with the admin button, the user needs to have admin status. In order to assign admin status do that you will have to open tab Data > App Data > All Users then find the user you want to provide admin rights and press edit button https://prnt.sc/rbehs4
In the window that will open you will have change User Type to “3”

Regarding the second problem, the console screenshot will help a lot as it can point to the cause of the issue.

Best Regards,
Alex


#5

i know that…but if there is no user selected or signed up or anything and someone just presses the admin panel it will come up that message…the info you gave me, i already knew but thanks.


#6

For the cases when the user is not logged in, is triggered the following workflow you can change the user that will be logged in for that cases in action 2 of the workflow.


#7

Thanksssssssssssss i love you mate…ahaha…sorry but i messed up the database playing around in the beginning…maybe i should start from scratch and do it better now…but can you help me with the ride price? and by the way,is there any problem with bubble? i can acces my landing page…but cant signup anyone…bubble sent me an email saying it was the domain set up…i sent a print “from the app settings” showing the domain set up correctly…it has been working for 2 days and now is off,its strange…i know its not a part of the question…but can you help?
Thanks


#8

Glad that the answer helped! Starting from scratch definitely will help if you made a lot of changes in the DB.

With the ride price, we will definitely find a solution. Please try to provide the screenshot of the console while that page is open. Maybe, there are some errors that will help us to understand what is the cause of the issue.

And with Bubble, yes a few hours ago we also faced some issues but now everything seems to work properly.

Best Regards,
Alex


#9

Sorry i thought i provided…i have this screenshot…when you say “console” can you be more specific please? sorry…kind of new to web dev…
if i delete my app i dont have to pay again 29 a month right? i just delete this one and can start another one on my personal plan right? thank you so much for being fast in response…really thanks


#10

If I am getting it right based on how your window looks, you are using Chrome Browser, in this case in order to open the console is needed to press Ctrl+Shift+J if you are using Windows or Command+Option+J if you are using macOS. The console looks like this https://prnt.sc/rbfq9n

And yes, you can create another app from the template being on a personal plan. It is important to be on the same account from which the template was bought.

Best Regards,
Alex


#11

HeYYYY i just did what you said and changed my plan…didnt work…changed it back…NOW I GOT BILLED 2 TIMES 29$!!! is this a scheme where no one help and keep charging??? please give me back my money,that is not right


#12

i saw you were writing…gave up on answering?..thank you very much…its only 58 usd…i will surely cancel all services…i see what’s going on here…thank you very much…


#13

@josesimoes1987, No, I did not give up on answering.

You can create an unlimited number of apps form the template here and here on the part of Developer license is specified that you the number of apps that can be created is not limited. The creation of the apps from templates also works on any plan. So, this was exactly what I mentioned earlier:

Seems like there was a misunderstanding regarding the application creation process from a template. I’ve mentioned above that being on personal plan, you can create another application from the template however the decision of deleting your application from the created template was on your discretion solely, which I did not advise.
I am really sorry for the incident :pray:

Unfortunately, we cannot provide a chargeback because all payments are done through Bubble. Here you can find more details regarding Bubble Billing Please request the chargeback directly from them as only they can do it. Here is the address on which you can reach bubble support. https://bubble.io/contact

Best Regards,
Alex


#14

i didnt delete it…thank god…and i already talked with bubble,they were very kind,now i have everything up and running except…the cost part lollll…thats my golias…i will leave some screenshots here in hope you can help me,once again thank you for the efforts


#15

@josesimoes1987

I am really glad to hear that the problem was solved. Also, thank you for sharing the screenshots. Unfortunately, I will have to ask you to take one more screenshot that will help to locate the problem. Please, open the page that is shown on the fourth screenshot. And there please open the console and make a screenshot. In the console may be errors that will let us know what are the causes of the issue. Here is described how to open the console:

Thank you in advance!

Best Regards,
Alex


#16

Hello again,i forgot to say its firefox,here are the screenshots,i took the whole console in 3 screencaps,thank you for the help. :slight_smile:


#17

Are these the correct screenshots you wanted?


#18

I tried to do the same on google chrome because maybe it helps you and here it is the screenshot…supposedly there is a API key in the element but that is not mine and i dont see how to change it anywhere…correct me if im wrong,and please help :slight_smile: ahah thanks.
Best regards


#19

sorry…it is my key…dont understand it then…


#20