Templates Plugins Courses

Need help for Ride share app


#21


#22

@josesimoes1987,

Yes, that is what I was looking for. Thanks!

Considering the error that is shown the cause of the issue is the API key. A few things that are needed to take into account:

  1. Google services will take 10 minutes to make the services available for new API KEY created. So please make sure you have waited enough time.
  2. It is needed to enable all needed Libraries for the key.

Here is a step by step instruction of how to get a key with all needed libraries enabled:

In order to get the API keys will be needed to execute the following steps:

  1. Open this link: https://console.developers.google.com (and make sure you are logged in)
  2. Create a project by clicking here https://prnt.sc/r7v0w6 and then in the window that will open click on “New Project” https://prnt.sc/r7v45v and click on “Create” button https://prnt.sc/r7v6mi
  3. Once the project is created open Library by clicking on its tab https://prnt.sc/r7v78f
  4. In the opened tab, use “Search for API & Services” https://prnt.sc/r7v96c for finding the libraries that are needed to be to enable. (in the following steps will be shown an example of how to enable the one library and with the following one you just will need to repeat steps from 4 to 8).
  5. Click on the found library https://prnt.sc/r7vbrz
  6. Press Enable button https://prnt.sc/r7vc7b (please consider that you may need to wait until the Enable button will appear)
  7. Go back to search page https://prnt.sc/r7vci2
  8. Go back to step 4 and search for the following library.

The list of libraries that are needed to be enabled include:

  1. Geolocation API
  2. Maps SDK for Android API
  3. Roads API
  4. Places API
  5. Maps JavaScript API
  6. Maps Embed API
  7. Time Zone API
  8. Distance Matrix API
  9. Maps SDK for iOS API
  10. Maps Elevation API
  11. Directions API
  12. Maps Static API
  13. Geocoding API
  14. Street View Static API

Once all libraries will be enabled, open Credentials tab https://prnt.sc/r7vzsp
Click on “Create Credentials” button https://prnt.sc/r7w086
Select “API Key” option https://prnt.sc/r7w0pz
And then send to us the key from the field “Your API Key” https://prnt.sc/r7w1dz

Best Regards,
Alex


#23

oh ok…you know the problem…in the settings part of the api,if you go to general,and then on the api docs (geocode and maps) they only tell you to setup client and server with 4 api…you are telling me a lot more…i know that it is the generic something…but then the link should be more explicit…thank you a lot…i will try now and give you some feedback.
Thanks a lot.
José Simões


#24

Ok, looking forward to hearing from you! I hope the issue will be fixed.


#25

Hello…it was fast ahahah sorry but there are 3 apis missing that you said…they cant be found on google cloud platform…can you tell me why? thank you…as you can see i enabled almost all…but maps elevation,and timezone api dont show up… :frowning:


#26

Even though i want to know if i can get the elevation and timezone…i must say it is working… :slight_smile:


#27

@josesimoes1987, unfortunately, I have no idea why some libraries are not shown for you. Maybe Google has some geographical limitations for some services. In order to find out that you will have to reach google support directly. Anyway, the Libraries needed for calculation of rout was enabled and the problem is solved.

Thank you for your understanding and sorry for any inconvenience!

Best Regards,
Alex


#28

heyyy mate no no…dont be sorry…im sorry if i sounded rude somewhere along the way,i know you understand that someone who spent money would normally feel like this and maybe that’s why you were so cordial and professional,but on my side i can say that it gives me the trust to continue using your services and scaling them without concerns,thank you very much for everything and hope we can keep this relation going and growing,have a good day.
Best regards.
José Simões :slight_smile:


#29

I am really glad to hear that you came to such pleasant conclusions. Yes, of course, I do understand everything and I am really happy that you didn’t give up and decided to continue. In case of any other questions please let us know and we will be happy to help.

Best Regards,
Alex


#30

Thanks…but i think i have one last twitch…sorry ahahah can you please take a look at these screen caps and tell me what im doing wrong? i want the cost to show 2 decimal places and euros.
Thank you


#31

@josesimoes1987
Please make sure you have also edited the element on the design part.

Also, please check if the data are saved correctly in the DB is correct, from what I can see you set up correctly the format of cost. But anyway just to make sure everything is ok.

Best Regards,
Alex


#32

Cool thank you,fixed it…but…now the distance is not working…whatever i put in as location it gives me the right price but doesnt change the kilometers…


#33

and please can you tell me something…im getting all kinds of errors just by switching colors…literally just by switching colors…how is that possible?
Thank you


#34

im sorry to be such a pain in the ass…but can you explain me something…i was switching and customizing my app and nothig was wrong…all of a sudden when i switch pages…everything is going crazy and giving up errors…the only thing im changing is colors…im not even touching the workflow…strange…can you help?
Thank you


#35

So,i “fixed” the mistakes with the knowledge i have…and i think im going to have a lot of problems…for example…now i cant start the ride from the passenger side…it just loads…and doesnt start the search for a driver…can you help? thank you


#36

I know it says the api is incorrect…it makes no sense because before all i could start the ride…and i had less aplications running…so…please help me man…i told you i give you all the passwords in private if you want access that you dont have but please fix it for me…it will take me a year i think if this keeps up showing errors…im even begining to think you are just messing it up…because after all bubble control the DB…and everything was going ok…i told you that…one hour later…just changing colors…20 some errors…come on…im not a pro developer but i work with cybersecurity at a noob level…give me some credit…


#37

Hello @josesimoes1987,

Regarding errors that started to appear on your side, they are caused by changes you are making in the template. Please consider that even if you don’t change anything on the workflow tab. Deleting or changing the elements on the design part also can impact the workflow and the logic of the template. All errors that I see on your screen are new and do not appear in the original template. Additionally, we have no access to your app and have absolutely no possibility to somehow mess up something on your part. Even though Bubble hosts everything on their servers we are a different company, an agency that is providing services based on Bubble technology. So we have no access to your app.

For template customization, we highly recommend having at least average knowledge of Bubble. As you have seen earlier we do provide support for fixing the bugs from the original template. At the same time customization purposes, we have a separate service. If you would want to request such services please Send us a request and one of our managers will get back to you. https://dev.zeroqode.com/?scroll=getstarted To get you the effort estimates we need to have the requirements about the project shared first.

In case you want to do everything by yourself that is also absolutely ok but please make sure you understand how to do that. You can find out more about Bubble by checking their documentation: https://bubble.io/documentation
Also, we have courses that may help you learn and master Bubble much faster. Please check it out here https://lab.zeroqode.com
And checking the documentation of the template also will help as you there can understand how it is structured, here you can find it: https://docs.zeroqode.com/templates/ridely-ride-sharing-like-uber-template

Best Regards,
Alex


#38

Ok… Thank you… So can you tell me if there is a way i can reset my template without being charged again in bubble editor?
Thanks


#39

@josesimoes1987,

According to bubble documentation, users can apply the template only when the app is created. For additional details please reach bubble directly as they can provide better assistance in this regard.

Best Regards,
Alex


#40

Ok… So i cant reset my template without paying extra… Nice…