Templates Plugins Courses

Salesforce API with Bubble

Hello

I’m trying to setup Salesforce API with Bubble, but i always get the error
error=redirect_uri_mismatch&error_description=redirect_uri%20must%20match%20configuration

On Salesforce-connected App, my callback url is set as :
https://mydomain.bubbleapps.io/api/1.1/oauth_redirect

(note : when using your Salesforce API Plugin test platform , it works perfectly)

Thanks for your help

Hi @michael.kazmierczak,

Thanks for using our products. Perhaps you can give it a try again to our docs as everything is up-and-running. Could you please make sure that everything is configured properly by also checking our demo editor here to preview how plugin is working.

However, if you still have the same or any other issues after configuration, please share more details like screenshots and/or screencast of your app, workflows, what you’re trying to accomplish with this plugin, the exact steps to reproduce this issue, browser and OS version you’re using to develop your app. This way, we can get a better troubleshooting, then provide working solutions asap.

Best,
Alex

Hello,

thanks for your quick reply !

When going to your doc page, all screenshots have “broken links”. Could you fix them ?

When going to your live demo, it works for me : i can connect and i can see my contacts.

So i’ve just copy/paste your login button, and added a Signup/login with salesforce worfklow.
When clicking on this button (dev or prod version), the page becomes blank with just one line on top : “error=redirect_uri_mismatch&error_description=redirect_uri%20must%20match%20configuration”

On Salesforce-connected App, my callback url is set as :
https:// mydomain .bubbleapps.io/api/1.1/oauth_redirect

Regards
Michael

Thanks for feedback @michael.kazmierczak,

I’m afraid the images are not broken on our side. Perhaps you can try to use a different browser? However, no worries, just to speed things up so you can make it work on your side as well, here are the screenshots:

image

image

image

The issue seems to be at this point. You just have to insert your Live and Test URLs.

If you’d like to replicate our demo, please make sure that everything is set up properly as per demo, then give it a try again by setting the appropriate Collback URLs as well.

Hope it helps.

It works !!!
Thank you very much.
2 errors :

  • the second callback url for version-test
  • i didn’t select “access to your basic information”

Easier with the screenshots for sure. They were hidden by my “Privacy badger” plugin in Firefox, sorry about that.

Thanks again !
Michael

Thanks @michael.kazmierczak for feedback, I’m glad you’ve managed to make it work on your side as well. If you like our plugin, could you please rate it by going to Plugins tab in Bubble editor. You can find the plugin by name and give it as many stars as it deserves. The more feedback we get, the more motivated we are to build great plugins!