Templates Plugins Courses

Setting up Algolia


#1

Hey there, I’m trying to setup Aloglia, and use Zeroqode’s plugin. I’m really confused about a couple things, and can’t find the answers in the documentation:

  1. The Zeroqode doc simply says, “add records to your table.”

How do I do that? I can’t find it in either set of documentation. Is there a screenshot or example? Am I meant to know JSON to accomplish this?

  1. The API keys the plugin asks for do not appear under my API keys in Algolia. Maybe Aloglia updated since the doc came out? There is only “search only API key” and “admin API key”, then “monitoring api key”. I don’t see what the plugin asks for anywhere (X-Aloglia-Shared Headers, and X-Application-ID-Shared-Headers).

Any help would be much appreciated!


#2

Hello, @jeremiah.

Let me clarify and offer answers here:

  1. By adding records, we meant add data to your app in Algolia’s dashboard for searching.

  2. The “search only api key” is used for api key calls, the “admin api key” is used for update and delete actions. Also you need the “app_id” for the application you set the Algolia. All keys and id could be found in Algolia Dashboard.
    See our demo setup: https://bubble.is/page?type=page&name=algolia_search&id=zeroqode-demo-11&tab=tabs-1

Regards,
ZQ Team.


#3

Thanks for the response @Dumitru! To further clarify on 1. Adding records - I had tried that, and clicked “add manually”, and Algolia presents you with a black screen (which looks like a code editor). I entered my Data type, but they don’t seem to provide a format for what to write, it’s just a blank screen. So, for example, I wrote, “projects” or “my_data_type” , both of which would correspond to my Data Type in Bubble. But it doesn’t accept that, or provide information for how to fill it out.


#4

Hi.

Sorry, seems like you need to know the syntax for adding the data I missed that (you could check more about it in algolia’s doc: https://www.algolia.com/doc/api-client/methods/indexing/).
Here’s an example:

  1. Adding records for indexing:

  2. Here’s the added record in preview:

Hope this helps.

Regards,
ZQ Team.


#5

Thanks for the help @Dumitru! I was able to create the record, and setup all documentation plus view the live demo, but unfortunately nothing is showing for me.

I suspect I missed something. How do we tell Algolia what data type to connect with the Bubble DB? For example:

In Bubble, my Type is “Business” and field is “businessName”.

In Algolia, my paramater is “businessname”.

When setting up the plugin, I only see the options to choose from my Bubble type:

Could that be causing the problem? I’m not seeing any results whatsoever.


#6

For anyone who stumbles on this with the same issue, it’s still not displaying the field names, just unique IDs, but for me it helped to make a button that when pressed, “updated Algolia item” to verify the API was working correctly.

It was, and copied my data over no problem, so from there I knew I was pulling it correctly. Again, I’m stuck with the same issue as others are having on this thread - Algolia Search - Failed to show field - but I can at least get it to display correct unique IDs.


#7

Hi, @jeremiah

Could you please post more details, screenshots/video of your setup, workflow and page design.
As well the settings from Algolia dashboard, so we could help you better.
Thanks for understanding

Regards,
Zeroqode Team.


#8

Hi @Dumitru, yes, happy to share. Basically, I’ve literally mirrored what the Zeroqode demo has, and what the documentation shows:

A group, which houses the search input, Algolia search element, and repeating group. I’ve blotted out my Algolia index, but I can assure you that it’s the correct index name, all lowercase. To re-iterate, the problem is that I can only get the column name IDs to display, not the text of it. For example, it won’t show “ABC Business” it shows “1234456x34598” (the ID).


#9

Hi again @jeremiah.

Could you please try change the columns data type in a different order:

and test it out.
I would need to test this out since I think i reproduced the issue, but I’m not sure why it is happening yet.
Also could you please show your database setup in bubble. Thanks for your help and feedback.

Regards,
ZQ Team.


#10

@Dumitru I tried switching the columns, but it didn’t work.

In my DB, there are two types I’m trying to search:

  1. Business

  2. Location

One “Business” can have many “locations”. I’m sourcing the Business (Type)'s Name (Field), and their Location(s) (separate data type).

Here is an example of how it synced with Algolia:


#11

@jeremiah could you please add [email protected] and [email protected] as collaborators in your app so the devs could look at it and try debug it.
Also would recommend, you clone the page to another page for demo purposes with same setup/workflow and pinpoint to the location.
Thanks for understanding.


#12

yes @Dumitru - have just added. Please can you use the page “algolia_demo” ? That is the same search environment created for testing.


#13

Hello @jeremiah

We pushed an update to Algolia plugin now it is easier to match the data fields by manually writing them in the new Manual Fields where simply write your Algolia index fields for searching. No need to create database in Bubble to match the one in Algolia.

See the app we tested it and now it gives the results which match Algolia index:

In due time we’ll improve the documentation and couple more features as well so that users will get an ease of use experience.

Regards,
ZQ Team.


#14

@Dumitru Huge thanks to you and the team! This is awesome.