Templates Plugins Courses

STRIPE GET DATA plugin deprecated, what should I do now?

CONTRACTOR template, STRIPE GET DATA plugin: I’m now setting up the stripe APIs on the Contractor Thumbtack template as per the docs, and when I try to find it in the template under plugins, it is not there, it has been deprecated, yet it still it is in the docs. It tried to add this plugin, but it’s not available anymore. What is the way around it?

https://docs.zeroqode.com/templates/contractor-services-like-thumbtack-template

Hi @peter.grabec,

Thanks for reaching out. It looks like Stripe Get Data plugin was removed from marketplace, indeed. And our docs that were dependent on it should be updated. I’m afraid there is nothing we could do to this plugin, however let us better check how to work this around and I’ll get back to you as soon as possible.

Thank you in advance for understanding.

Best,
Alex

1 Like

Hi @alexander, Thank you for looking into it for me. Hopefully the zeroqode team will be able to work this around.

Hi @peter.grabec,

I’m reaching out to notify that we have fixed the issue with this missing plugin and also updated our documentation for Contractor template. Please check it again and create a new app using this theme in order to use the updated version.

Thank you for patience :pray:

Best,
Alex

1 Like

Hi @alexander,

Thank you for fixing the issue with the missing plugin. I really appreciate your time, dedication, and effort. I have checked the updated documentation, and created a new app using this theme. Just to verify with you - I know it’s basic but I just want to make sure - before I start customizing this template again: When I created this new app in Bubble, at the very start it offered me from the dropdown menu to use a template, from which I have chosen the Contractor template. I believe that would already be the updated Contractor template in there right?

Kind Regards,

Peter Grabec

Yes @peter.grabec, this is the way!

Hi @alexander,

It seems that we still have an issue with the Stripe Get Data deprecated plugin.
There have been 14 errors, I managed to solve 3 of them by reverting Stripe.js back to a previous version 1.9.139 as per the Zeroqode update in their template docs:
https://docs.zeroqode.com/templates/contractor-services-like-thumbtack-template

I am unable to solve the 11 remaining issues though, please view the attached screenshots of the template and my development version - I’m comparing the two of them, trying to match my development version with the template: trying to choose “Stripe Get Data” from the dropdown menu of my development version. However since the plugin “Stripe Get Data” is not being used, it is not available in the dropdown anymore. (I hope my understanding is correct, please correct me if I’m wrong)

There is also a Group missing value when I checked the Workflow (screenshot attached)

Would you be able to advise on the next step?

Many Thanks

Peter Grabec

Hi @peter.grabec, thanks for your feedback. Please let us check on it and I’ll get back with an update on this matter asap!

Thank you @alexander,

What’s interesting though is that if I revert my Development version to a previous Savepoint, and deploy it to Live version, all the errors will disappear;

and even if I revert the Development version back to the latest version, and deploy it, the errors will not be there either.

That will all stay good, until I go to the Design tab and open the professionalpage. Suddenly, all issues will come up again.

Hi @peter.grabec, let me give some insights in order to help.

First, it is important to mention that we have removed the Stripe Get Data plugin, because it was deprecated, meaning it is not used anymore within this template. The data call which was accomplished by Stripe Get Data, has been rewritten and integrated into the API Connector.

Second, yes it is required to use the mentioned version of Stripe.js based on documentation.

As for the popping issues, here are screenshots of how things should be configured for the App Fee value and others as well.

The Parent Group:

Payment ID:

Customer:

Service Provided:

Amount:

App Fee:

For the App Fee text element, you can remove its Group element (that is trying to retrieve Stripe Get Data calls) which it is placed in, so its Parent Group will be the whole group element as for the rest of text elements.

Date:

Additionally, we are going to lunch an updated version of this template as well, including all bug fixes. So, it would be possible to create a new app with updated template and perhaps compare your existing application, to check on all popping issues that you have. :pray:

Thanks!

1 Like

That’s great @alexander,

Thank you for shedding some light into these issues, now I have a better understanding. I much appreciate the above detailed guidance you gave me. After the changes we’ve now made, the Stripe data calls are now up and running.

Can you please let me know, once the updated version of the template with all the bug fixes is out? That way, as you’ve suggested, I can compare it to my app if need be.

Kind Regards,

Peter Grabec

Hi @peter.grabec,

We have already pushed an update to our template. You can create a brand new app using this theme and give it a try.

Additionally, if you like our template so far, could you please rate it by going to Template tab in Bubble editor. You can find the template by name and give it as many stars as it deserves. the more feedback we get, the more motivated we are to build great templates!

Thanks :pray:

Hi @alexander,

It’s certainly been a steep learning curve for me learning how to modify a template, setting up various features, and discovering bugs, especially these Stripe issues have been a handful … and as I thought we are nearing the (successful) end, there is one more bug to solve (hopefully the last one), here we go:

The webhooks are throwing 3 errors!

The webhook has been initialized successfully, but as soon as I,d saved the API Workflow Request data, these 3 issues immediately popped up.

I wanted to make sure the changes I made in my app has not caused it, so I have also tested it on the latest updated version of the template (without any modifications) to eliminate that.

I have even employed the services of an agency to tackle this bug, since this was beyond my current knowledge, yet even they were unable to fix it. It appears that some of the requested data is not contained in the “account.updated” event (object requirements eventually due is missing), and the “Background check - individual verification status” is also throwing an error.

We have spent a fair bit of time to solve it, trying numerous different things, I boiled it down to a simple overview in the attachments.

I hope you’ll be able to work it out.

Kind Regards,

Peter Grabec

Hi @peter.grabec,

Thanks for your feedback. You should be good to go by now with your application, but with a couple of instructions to check.

So, when you Request Data from your endpoint, you actually have to make some changes to the user in your Stripe dashboard (e.g. change his name or any other field, at least something), then you save it, get back to your Bubble application with the requested data. After that, when you receive the resulted URL, you’ll have to remove the /initialize from this URL in your Stripe dashboard.

Hope it helps.

Thank you @alexander,

It seems very simple. I tried to follow your instructions, but the 3 errors still remain.

Perhaps the reason might be that I might have deleted some of the test customers in my application test database, but they still remain in Stripe. What I mean is that the data that is returned from stripe tries to locate the particular customer in the application database in order to update the particular fields, but it cannot find it, so it throws these errors (well, they remain present all the time)
(I hope my understanding is correct, if not please correct me.)

Presuming that is the case I’l l now need to update my application test database to match the stripe customers, right? Would that help?

What puzzles me though is that when I tried to replicate the Endpoint accountverification workflow, (since I deleted it in order to temporarily get rid of the errors), I could not replicate it, because the “object requirements eventually due” were not available from the dropdown ( as I indicated in my previous message). So what I did was go to the latest template, and copy-pasted the workflow.
What would be the reason for this not being available from the dropdown, and how was the workflow created originally then?

Thank you.

Peter Grabec

Hi @peter.grabec, thanks for your feedback. Please let us check on it again and I’ll come back with another update on this matter asap. :pray:

Thank you @alexander.

Correct me if I’m wrong. This is a Stripe Connect account. What appears to be happening is that the data received in the Stripe “account.updated” event that the application is calling, is of a business type, however what the bubble application is expecting is data of an individual type stripe account, something like “person.updated”? event. I called this event as well, but the data returned wasn’t matching the one that we expected either.

Would perhaps Stripe recently changed the data that is contained in the “account.updated” event, or have I missed something else, and the issue is completely elsewhere?

Hi @peter.grabec,

This shouldn’t be the causing issue.

Please check the following loom video, were you can see the exact steps that have to be made https://www.loom.com/share/e8e5234810db4c10ac71e1daf5a288af and make sure to try it again, as this one should help. Then, try to replicate in your app and test it again.

However, if you have the same issues, we’ll take a look inside your application.

Hope it helps. :pray:

Hi @alexander,

Thank you for the additional information, and the link to the short customized video, very easy to follow. I followed it step by step a few times, yet still didn’t manage to fix it. We are still at the same issue that I mentioned a couple of times already, the “object’s requirements eventually due” is just not available to choose from (the dropdown menu).
I’ve spent so much time on this issue, even employed an agency to deal with it - which was a rather pricey exercise), yet no result. If I had any hair left on my head, I would be pulling it out by now :grinning:

Can you please let me know how to lodge a bug report so that you can have a look inside my application?

Many Thanks Peter Grabec.

Hi @peter.grabec,

Thanks for feedback. No worries! As mentioned, we are going to check this issue inside your app in this case. Please go to Settings - Collaboration tab within your editor. Add our [email protected] account to your collaborator’s list. Also, please tell us your app name and page name where this problem occurs on test.

Note: avoid the warning message regarding plan, as we are an agency and you can easily add us to your collaborators.

We’ll investigate it inside your app and get back to you with a feedback asap.

Thank you in advance for patience. :pray: