Templates Plugins Courses

Stripe plugin setup and error in Uplance


#1

Hey support, a question for the uplance template stripe plugin.

I have filled out the client ID, secret key and publishable key in the plugin page, then why the debugger still asking me to update the keys?

Also, for the payment setting in the employer’s page, under “Group user” > “Group user credit card information” > “initial content”, it says parent’s group is missing value.

I tried to open a new template a see the original setting, it’s “parent group’s retrieve a customer sources data’s last4…”

I don’t have that option in my app, not sure why, since I only added landing pages and changed the font style of the template, so this shouldn’t happen.

Any advice?


#2

Hey there @hanlinde26, We will check your request, and I will update you of a matter ASAP.

Thank you,
BR,
Nik.


#3

Meanwhile could you please provide us more details like Screenshots of your errors, WF settings and so on.

Thank you.


#5

@Nikita.S

Here are the screens for the error message.


#6

@Nikita.S

Here is the screen for the Stripe plugin, there are 2 Stripe plugins that need to set up, both have the same info need to input.

The only thing I don’t understand is the Authorization (shared headers) field, not sure what it is. Another Strip doesn’t have that field but is “Live Client ID” instead.


#7

Okay @hanlinde26 , regarding the Authorisation, you have to fill it as it presented here “Bearer [Secret key]”, I think after this the issue with Stripe keys will be solved.

Thank you.
BR.
Nik.


#8

@Nikita.S Thank you, I have noticed the “version” is different, the default uplance is using 1.71. The latest is 1.9x. So do I have to stick with the default version?


#9

Hey @hanlinde26, the issue is in the Stripe, by the major update in 2019-02-19 they changed the API keys, you can check it here, that was a cause of updating of Stripe JS plugin which we are using in our template. This plugin Update have led us to this issue. That’s why you have to use the latest version, and then to fix all the issues manually.

That’s why for understanding full situation tell me please when you have created your Stripe account?

Thank you.
BR,
Nik.


#10

@Nikita.S

Thank you for the explanation. I created my account probably in April or May this year.


#11

Okay @hanlinde26, looks like you may have a new type of API key which isn’t supported by the plugin version which is set in our template, you should be able to fix this by making changes to Stripe related WF actions, with displayed issues.

Unfortunately, it seems to be the only way to solve the problem.
I can suggest you to address your questions to this thread so they could provide you with better guidance regarding these issues.

Thanks for understanding,
BR,
Nik.


#12

@Nikita.S Thank you, so the issue is about the Authorization (shared header) that causes the error message in the first screenshot? ( the missing thing)


#13

@hanlinde26, Yep this is a problem.


#14

@Nikita.S Thank you. I happened to have an old 2017 created Stripe and I used that API for the plugin, problem solved!

The least, the debugger still saying the similar error message, please see attached images.


#15

That’s great news @hanlinde26, which version of the plugin do you have now?


#16

@Nikita.S I use the default, 1.71


#17

Okay @hanlinde26, let’s fix them all))

First of all, to solve the first issue you have to change the type of content, this group is the place where we have to implement all the changes.

  1. Main container - Group User settings.
  2. Next container - Group User settings.
  3. Last container - Group User settings.
    Inside this container, we also will change something:
    1. Stripe RG settings.
    2. RG content group settings.
    3. Card number text settings.
    4. Card exp date settings.
    5. Change card button action

When you will be done with those steps, let me know was it helpful, and what issues did you face else .

Thank you,
BR.
Nik.


#18

@Nikita.S Thanks a lot! However, the setting I have are exactly the same as you provided, the current error I have are all in the “group retrieve a customer source data”. I have attached a screenshot below, the highlighted 2 items have the same message: Parent groups thing(More…)

Thanks :smiley:


#19

@Nikita.S Another question, how to set up a login for admin and make sure the template won’t have any access for the user to log in as admin?


#20

Okay @hanlinde26, we will check now this group.

Please check does the data type for group User card info is set like here.
Then please check does the Group Retrieve customer source data is set like here and here.For both groups which you highlighted.

Hope it helps you.

Regarding the admin page security, I will be back to you ASAP.
Thank you,
BR,
Nik.


#21

So on @hanlinde26, for making secure your admin dashboard you have to create this kind of action on Page loading.

If you like our plugin you can rate it by going to Plugins tab in Bubble editor. Find the plugin by name and it give it as many stars as it deserves :slight_smile: The more feedback we get, the more motivated we are to make things better in Bubble.

Thank you,
BR,
Nik.