Templates Plugins Courses

Uplance Template - How to accept or decline a proposal?


#1

Hey Support,

I have created a Freelancer account to apply for a job post from the Employer. In the employer’s “job offer” tab under “Proposals from users”, there’s no place to accept or decline, any advice?

Thanks!
Hank


#2

Hello @hanlinde26,

Thank you for reaching out and reporting the issue. We will inspect the problem and will do our best to have it fixed ASAP. I will keep you posted.

Best Regard,
Alex


#3

Thank you @alex.grimacovschi

This is a bit urgent so please provide an update as soon as possible.

Thanks!


#4

Hello @hanlinde26,
Sorry for the delay in replying.

Our developers are investigating the template, unfortunately, it is needed additional time to find the solution. I will provide the solution as soon as it will ready.
Please accept my apologies for the inconvenience.

Best Regards,
Alex


#5

Hello,

We checked the template and there was a bug that caused an error in logic. With a few adjustments, it is possible to make it work properly. So it is needed to do the following:

  1. Find Group jobOffer with the button “Accept” and delete the conditional.
  2. Change the conditional form the button “Accept” to the following.

After you have to go to the tab with workflows and make changes the workflow related to the action button Accept is clicked. Further, you will find the screenshots of the workflow.
First Workflow

  1. https://prnt.sc/qersrr
  2. https://prnt.sc/qerr66
  3. https://prnt.sc/qerrgu
  4. https://prnt.sc/qerrqe

Second Workflow

  1. https://prnt.sc/qerryr
  2. https://prnt.sc/qers8r

Please let me know if you will need any additional assistance.

Best Regards,
Alex


#6

Hi @alex.grimacovschi

Thank you. Regarding the second workflow, mine is a bit different from yours, do I have to delete the unmatched steps?

Thanks!


#7

Hello @hanlinde26,

Yes, you have to make your workflow as presented on the screenshot and delete the steps that unmatch.

Best Regards,
Alex


#8

Hi @alex.grimacovschi,

I have followed the steps you provided and the job accept and decline buttons are still now showing up. Even worse, when using the freelancer account to click the job listing, the detail listing popup won’t work anymore. Probably is something missing?

Thanks!


#9

Hello @hanlinde26,

Strange I have tested the solution and it was working properly. Could you please add [email protected] as collaborators to your app? That will allow me to check your app directly. To do that you will need to open the tab settings > collaboration and add [email protected].

Thank you in advance and sorry for the inconvenience!

Best Regards,
Aled


#10

@alex.grimacovschi Thank you. Just added.


#11

Hello @hanlinde26,

Thank you for providing access to your app.

Regarding the issue with the pop-up on the find_job page. The actions described previously cannot impact this functionality in any way. If you will check the workflow tab of the find_job page you will see that there are two Events “When Group Job is Clicked”. Probably you created the second one by mistake. To fix that just delete the event that has no actions in it.

About displaying the buttons. Unfortunately the conditional of the group wasn’t deleted that’s why the buttons weren’t showing up. This was step 1 from the description from above. Probably I didn’t explain myself clearly enough. Please open the Group jobOffera and remove the condition.

I hope this time everything will be fine. Please let me know if you will have any other questions.

Best Regards,
Alex


#12

@alex.grimacovschi

Thank you, it did fix the issues. However, after the employer “accept” the proposal, I can’t click the job and go to the time log page, it just shows the “popup jobOffer”.

Another question, is it possible to let the user manually log the work hours instead of a timer?


#13

Hi @hanlinde26,

Please make sure you have reproduced entirely step 2. Including the property Text - View details. As presented on the screen when the condition is true the field text should be View details.

Regarding manual inserting the working hours, it is absolutely doable. You can add an input field and insert data from there. Please consider that you will have redesign the workflow to populate the data in the database.

Best Regards,
Alex


#14

@alex.grimacovschi Thank you!

For step 2, the condition is the same and I have added the text “view details” but the button still doesn’t work.


#15

I checked once again your app. In the second redesigned workflow you have selected the wrong Accept Button seems that you have two buttons with the same name. Please select the one named “Accept” without uppercase.

I hope this time everything will work properly.


#16

@alex.grimacovschi Thank you, it works, finally! :slight_smile:

Your team is awsome!


#17

Glad to hear that. :slight_smile:
Thank you for your patience. Happy Holidays!


#18

Hi @alex.grimacovschi!

So I have tested the next step, which is to approve the work hours and close the job. There are several issues encountered:

  1. After approving all the hours, there is no way to pay in the “billing methods” tab.
  2. When clicking the “close project” button in the project detail page, it shows a popup asking if I am sure to end the contract, the confirm (submit) button won’t work.

Also, have you updated the previously fixed issues to the Uplance template? Or is there updated version of the Uplance template? I am wondering why I just copy the whole template and without changing the flow or condition, there are so many glitches and errors in the app, but the online demo works fine.

Thanks!


#19

Hello @hanlinde26,

We will check with our developers what is the cause of the problems encountered by you.

Yes, we did update the previously fixed issues to the Uplance template. Regarding the issues that you have but in the demo version doesn’t appear most probably there were some changes to the on your side that caused it. Our demo version is exactly the same one that is sold. We will check the issues and will come back with a solution.

Best Regards,
Alex


#20

@alex.grimacovschi, Got it. Thank you.

Waiting for the updates! Thanks!