Templates Plugins Courses

Zeroqode Native Apps


#21

Hi Cecilia,
our native solution (https://zeroqode.com/native) can help you with that and we have managed to submit a few Bubble apps to appstores. basically you buy the package, then modify some of its elements (like URL of your app, icon, splashscreen and more complex ones if needed) and then you compile the package for submitting to the store. You can watch the videos on the page or ready this thread for more details. Our developers will also guide you if you face any difficulties along the way (until submission to the stores).
Please let me know if you have any questions.
Thanks

Levon Terteryan
Founder @ Zeroqode & Bubblewits

let’s stay in touch on twitter!

zeroqode-for-web-160x120

Bubble Templates
Bubble Plugins
Bubble Courses
Convert Web to iOS & Android
No-code Development Services


#22

Hi
I’m new to creating apps, I purchased the Zeroqode Native Apps and I started working on the Zeroqode Workspace on Xcode. But I am getting error messages that aren’t allowing me to compile and build the app. Any help with this would be greatly appreciated.

Here are the messages:

  1. Block implicity retains ‘self’;
    explicity mention ‘self’ tp indicate this is intended behavior

  2. This block declaration is not a prototype
    MBProgressHUD.h

Thanks


#23

Hi there,
i will ask our devs to help you out here


#24

Hi,

Make sure you open the white icon, the SuperView.xcworkspace. Just make sure you did everything as on quick guide video.

That should work, but if for some reason this is not working, here is a little help you can try just in case:

This project is created using CocoaPods, this is a common problem with projects created with it, this is normal on different mac’s. You can solve it trying few next steps, one of them has to work:

open the white SuperView.xcworkspace icon, not the blue one and try again

make sure you have an Xcode version 9.x and above.

make sure the deploymain target is set to run on one of the simulators

press SHIFT + CMD + K and run the app (CMD + R), if this doesn’t work, try next step

press SHIFT + CMD + ALT + K, press Clean button and run the app (CMD + R), if this doesn’t work, try next step

Install CocoaPods on you Mac OS

a. In Terminal, type: sudo gem install cocoapods
b. Position the Terminal on root folder of the project
c. run this line of code

A.
rm -rf ~/Library/Caches/CocoaPods; rm -rf Pods; rm -rf ~/Library/Developer/Xcode/DerivedData/*; pod deintegrate; pod setup; pod install;
d. This will remove all pods from your mac, clean the whole pods directory, remove cached files from Xcode and install new project from scratch. When this is done, open the white SuperView.xcworkspace icon and try running the app again

If this doesn’t work, write again and we will see what can be done.

Best


#25

Hi,

I tried following the steps you gave me to try and fix the problems I’m having with my Zeroqode native app and the previous error messages have disappeared from my project but they were replaced by new errors that won’t allow me to build the app. Once again thank you for all the help with this.

Errors in Xcode:

  1. The use of Swift 3 @objc inference in Swift 4 mode is deprecated. Please address deprecated @objc inference warnings, test your code with “Use of deprecated Swift 3 @objc inference” logging enabled, and then disable inference by changing the “Swift 3 @objc Inference” build setting to “Default” for the “Zeroqode” target.
  2. /Users/mdawg/Downloads/Zeroqode_iOS/Product/Zeroqode/Pods/MBProgressHUD/MBProgressHUD.m:1279:113: Conflicting parameter types in implementation of ‘showAnimated:whileExecutingBlock:completionBlock:’: ‘MBProgressHUDCompletionBlock _Nullable __strong’ (aka ‘void (^__strong)()’) vs ‘void (^__strong _Nullable)(void)’
  3. /Users/mdawg/Downloads/Zeroqode_iOS/Product/Zeroqode/Pods/MBProgressHUD/MBProgressHUD.h:72:46: A parameter list without types is only allowed in a function definition

Thanks


#26

Hi,

Can you select the target and set swift 4 compiler as default.

Like this https://i.stack.imgur.com/7JcQ5.png

Best regards


#27

Hi,

I set the swift 4 compiler as default and that fixed one of the errors but these 2 errors still aren’t fixed.

Thanks


#28

Hi,

Is there anyway you can help me fix these 2 errors I still have in the message above?

Thanks


#29

asked the dev to get back to you, sorry for a delay


#30

just sent you a pm with a link to the updated version of the wrapper, please download it and give it a try. thanks


#31

Hi,

I’ve tried what you suggested and it corrected my previous errors, but now I have this error that won’t allow me to build in Xcode. I did some of my own research since I’m new to all of this I haven’t been able to find an answer that I understand. I’m not sure what I’m doing wrong that’s giving me all these different errors.

Thanks


#32

Hi,

Were you able to get in touch with your developers to help me with that last ERROR message?

Thanks


#33

Hello, sorry for a delay, I now pinged the developer again to get back to you.
Please accept my apologies for the delay here.


#34

Hi,

Sorry you had to wait, I was on a vacation few days and I don’t have anybody to replace me. I will send you a new project using pm.

Best


#35

Hi,

Thank you for the update, I ran the updated project and I ran the code that was given but I am still getting errors with the project and messages in the terminal. Here’s an image of exactly what I’m getting in Xcode and Terminal I hope this can help. If I can’t complete my project do you guess offer a service where I can pay the developers to complete it for me?

Thank You


#36

Everything looks fine.

On the left side, those are just warnings, I can’t see any errors. Just run the app.

Best


#37

Hi,

Thank you, but I tried running my app on a iPhone connected to my Mac and the app splash screen appears for a brief moment on the iPhone and I get a message on Xcode stating " Finished running Zeroqode in IPone".

Thanks


#38

Perfect, everything is working then.

Best regards


#39

Hi,

The problem is that the splash screen comes up and disappears quickly and the app closes on it’s own. I added my website’s url to the app but it doesn’t show up when I’m running the app on a IPhone but it works fine on the Xcode simulator. What could be causing the app to not work on the IPhone but work on the simulator.

Thanks


#40

I don’t know what can be the problem. Can you run the app on device and send me logs of the crash?

Best regards