Templates Plugins Courses

ZQ Rich Text Editor - New Plugin From Zeroqode


We have just published a very powerful Rich Text Editor Plugin

This Rich Text Editor can be easily converted to read only mode for your users, so you can be always sure that they see the text structured the way you planned while writing.

Easy switch to read only, display mode, limited number of characters, saving content in browser storage before publishing, hashtags and mentions are just the key features, that make writing content as easy as possible.

Simply place the plugin on the page, set up the properties and your users will start writing amazing stories.

Check out the plugin page https://zeroqode.com/plugin/zq-rich-text-editor-1527080205468x894712503856267300

and a demo - https://plugintests.bubbleapps.io/rte

Levon Terteryan
Founder @ Zeroqode & Bubblewits


Bubble Templates
Bubble Plugins
Bubble Courses
Convert Web to iOS & Android
No-code Development Services


Hi @levon,

I tried to use the new editor but I can’t get it to work.

I get this error in the debugger.


Hello, Kelly, most likely you have enabled some options without providing parameters for them (like if you enable mentions you need to indicate the data source where the data for those mentions should be retrieved from etc.) but we have not updated the plugin so if the parameters are empty then we’d assume the options are not enabled. Please update the plugin version and let us know if it works. If still doesn’t please past a few screenshots of your editor configuration. Thanks!



Thanks for the quick reply. I have still been playing with it. Your correct mentions is not configured correctly.

I can’t seem to get them working ether.

I have an object that contains community users which is a list of User Objects.
Each User has a Username
Datatype for Username is text
The column is Username
Everything is blue, but the editor does not show up

When I just do a search for Users as the source I get different error.

Is there a documentation page or sample read-only editor page for this?

Thanks in advance for you help.


We are preparing documentation for this, but meanwhile, in the mention source choose search for users’ unique ids.
make sure also to install the latest plugin version and then refresh the browser.
please let us know if it works.


also in the datatype field you should indicate the table name (for examples “users”) not the field type


Excellent, that did the trick.


Ok got mentions, hashtags all working. Its even displaying my old HTML content from previous RTE I was using.

But can’t get it to save the input now on the workflow.

Also, how can I get the display version to link to mentions?

I thought I had it but the mention is not clickable on within the Display Comment


HI we just updated the demo page with deeper explanation of each field, that is used in the Rich text editor. Please check that out here:

To get back to your question, Please make sure, that you are using the “display only” mode, as the mention clicks are allowed only there.

From what I see on your screenshot, the “mention click” returns client “unique ID”, while you do search for “username”. Please try to change it to the "SEARCH FOR “User” WHERE “Unique ID” IS “Return of clicked mention”, and let me know about the results.



Thanks for the update & more detailed instructions. :slight_smile:

I am still having problem understanding how to get mentions to display & be clickable.

Could you post screenshots?
What do I search for in the Display Mode RTE Mentions area?
What do I search for in the workflow upon click?

Thanks in advance. :smile:


Please see the following screencast with step by step:
Clicking on the mention will fire event in the workflow.

  1. Firstly click to empty event in workflow editor to add new one.
  2. From the menu hover over the element tab and choose the “RTE - Mention is clicked”.
    *You can see here also another events, that you can use in workflow.
  3. From the list choose the RTE editor, that is settled to “display only”.
  4. In this newly appeared workflow you are allowed to do whatever you consider necessary, with clicked mention.


Hi All,
We have performed some updates in the Rich text editor.
Please update to it’s latest version

Zeroqode team


Ok. I got mentions working.

The new upgrade added some issues.

  • Sometimes the HTML of the RTE is not passed to the workflow to save, so its blank
  • When I make another input on the same page, it does not update to the new text I put in the RTE but rather just keeps posting my first comment over and over. Even when I reset RTE input


We have difficulties, to reproduce the issue. Can you please add us as collaborators ( [email protected] ) to your app, so we can fix it for you?



Absolutely added you. Will send PM with more details.


we have deployed a new version that should solve the issues that you mentioned.


We have just pushed an update to the plugin and it now supports Google Fonts


Having an issue: Content generated by Rich Text Editor is displaying HTML tags (i.e


I attempted a test article (article being one of my data types with text fields) in my app. The result:


The problem is that you are sending the Output HTML to a Bubble text element. You should either use it in Bubble’s HTML element or in our plugin with the “display only” mode switched on.


That solved the issue - thank you. However, there appears to be another issue:
The RTE is not passing content/value when I attempt to make a change to an existing thing.
I’m using RTE to allow users to publish articles. I also have a workflow that will allow user to edit the article. The edit workflow is where I have the issue. A step in the workflow is to change existing article, with the body of the article being the RTE’s value. That value is never passed, and the edited article’s body becomes blank. When I look at the debugger in Bubble, it shows the RTE expression as being blank, even though there is content present in the RTE.