Templates Plugins Courses

AWS Uploader - Server Responded with 0 Code

Hi,

I’ve configured my AWS account and bucket exactly as described in the documentation here. I set up a sample page on Bubble with only one element, the AWS ‘File Upoader’. When I try to upload a test image I get the following error:

image

What could possibly be the problem?

This is my bucket policy:

Did you ever figure out the issue @tkassis? I am also experiencing the same issue. I followed the instructions closely.

Any input @zeroqode1 or @levon?

Yes, it turned out to be a typo from my end. I had misspelled the region in the plugin settings in Bubble. Double check that you didn’t mistype anything.

Sadly mine is all spelled correctly (As far as I can tell). My region is spelled correctly. I still get the error every time I place and image in the uploader.

21%20PM

Laughing at myself right now…I actually had the region as us-east-1 and it needed to be us-east-2. I both love and hate development.

2 Likes

If it makes you feel any better my typo was ua-east-1 instead of us-east-1. I checked it probably around 20 times yet I never caught the mistake!

2 Likes

Ha it does! I basically just trial and error until something works.

Hi guys, I’m getting the same error and I have checked for typos many times.

I’m also getting one other issue: I can upload files using the No GUI uploader, however they seem to be limited at about 4mb in size. Anything larger just doesn’t show up in my S3 bucket, even though it looks like the upload was succesful.

I am able to upload larger files directly to my bucket on the Amazon interface so there don’t seem to be any limitations there.

My bucket is connected properly because I can get a list of files using the S3 objects.

Any ideas @zeroqode1 or @levon?
Thanks

Hello @kieran,

We checked the plugin and it is working properly. Could you please check if you did set up everything in accordance with documentation: https://docs.zeroqode.com/plugins/aws-file-uploader-plugin

If this will not help then you can add [email protected] as collaborators to your app and we will check what is the problem.

Regards,
Alex

Thank you. I have followed the documentation as closely as possible but no luck.
I have added you as a collaborator but not sure if it worked because it says you can only add collaborators if on a professional plan.
Let me know if you are able to access it, if not I will change my plan temporarily (I have a discount code).
The page I’ve been testing uploads on is called test_upload
Thanks again!

Thanks, we got the access. We will inspect the issue and will do our best to provide an answer ASAP. I will keep you posted.

Best Regards,
Alex

We checked the plugin in your app and with our keys, it is working properly. Seems that there is an access issue related to the account setting which we cannot change. Please try to reproduce once again the steps described in the documentation and pay special attention to:
3. IAM Security Roles
4. AWS S3 Bucket located on the desired Server
Permissions.
I hope this will help you!

Regards,
Alex

Thank you Alex. I appreciate you taking the time to test it.
For some reason the NoGUI uploader is now working on files up to about 30mb, but above that nothing happens.
I am still getting the " Server Responded with 0 Code" when I use the AWS File Uploader element - this has never worked for me.
It also only works if I have my S3 bucket set to allow all public access which isn’t ideal.
I have checked and re-checked your instructions and tried to follow them closely, although there are parts where it is a little unclear, particularly regarding allowing public access or not.
I am not sure if there’s anything else you can do - is there a way I can give you access to my S3 bucket so you can have a complete look at it?
Thanks again,
Kieran

Yes, you are right the S3 Bucket should be set to public overwise the plugin will not have acces to data. Here is the reference from the documentation:

image

I would like to help you better help with making the plugin work on your side but accessing your S3 account is beyond the limits of our support. Please just repeat the steps from the documentation and if everything will be set up correctly the plugin will work.

I hope for your understanding!
Alex

I’m running into the same issue as Kieran: I can upload with the No GUI Uploader but not the GUI Uploader. When I try to upload with the GUI Uploader I get a “server responded with 0 code.”

I’m about to go back and check settings again (now fourth time time).

I agree with Kieran that instructions are unclear regarding public access. Below is a screenshot where users are told that we’re making the bucket public only for a moment. This implies that the bucket can be make private again once other changes have been made.

Here’s another example of conflicting instructions that appear in different sections of the documentation.

CORS configuration example:

  • “Additional Security” section of the documentation suggests to use the configuration shown in the screenshot.
  • “AWS S3 Bucket located on the desired Server” section of the documentation gives copy and paste string that does not match the screenshot.

Bucket Policy is another example. Different instructions in the Additional Security and AWS S3 Bucket Location.

I had to include https://mydomain.com in my CORS config to get the No GUI Uploader to work. Documentation only calls for https://mydomain.bubbleapps.io.

Otherwise I’m 99% sure that I’ve got everything set up as shown in the Additional Security section of documentation.

Any suggestions?

Hello, @tjc4. Thanks for reaching out.

To make GUI Uploader work properly, as on our demo page, you need to follow all instructions, noted in the plugin documentation. For example, set the S3 Bucket available to the Public. Please try this option, it should help.

I will discuss this point with my colleagues and we update the Addition Security section to make it be more obvious, without misunderstandings :pray:

Agree, in the AWS S3 Bucket located on the desired Server section screenshot a mismatching (comparing with other screenshots) Bucket name is indicated. I will discuss this point, and Bucket Policy as well, with my colleagues and we will update/make notes to this section to avoid misunderstanding. Thank you!

This is a test example of the app domain - https://zeroqode-demo-02.bubbleapps.io.


We have indicated it because this is the credentials of our test app (which is designed for informative/test purposes). I suppose it is apparently understandable, that for your own app you need indicate your app’s domain name. How can you make your app work under our test app domain? :slightly_smiling_face:

Please read carefully the Additional Security section (esp 3,4).

Thank you for your detailed request. I will inform you once there be any changes regarding the plugin documentation.

Regards,
Kate

This response (to @tjc4’s concise and direct explanation of the issues they’re having) is absolutely atrocious and unacceptable. This plugin isn’t a free tool/utility. It’s a paid piece of software that should come with some sort of minimum support/working documentation, to which both your answer and the docs online fall far short of.

I’m experiencing the exact same issues as detailed by tjc4. Please work on this and issue some updated guidance.

Hello, @mkrandel. Thanks for reaching out.

Apologies, I’m not intended to be atrocious in my reply. The plugin documentation reflects the prerequisites, steps, and guidance on how to set up and use the plugin, by following which you should not face problems with its work.

In cases when you have some errors, we are glad to assist you to resolve them and the first thing that we refer - is plugin documentation. If you followed it carefully and made no mistakes in spelling, but still have this " Server Responded with 0 Code" - then please add our [email protected] email as a collaborator of your app. We will check the plugin work with our test keys.

Please do not be mistaken, we are grateful for the notes, given by @tjc4 - if the described points in plugin documentation are critical for some users, we definitely should fix them.

Thank you for understanding.
Regards,
Kate

I’ve followed your directions to a tee (both the original version and the one with enhanced CORS/Bucket policy security.

The NO GUI element works, BUT THE UPLOADER WITH GUI DOES NOT WORK.

Can someone on your team please fix this?