Templates Plugins Courses

AWS Uploader - Server Responded with 0 Code

Hi,

I’ve configured my AWS account and bucket exactly as described in the documentation here. I set up a sample page on Bubble with only one element, the AWS ‘File Upoader’. When I try to upload a test image I get the following error:

image

What could possibly be the problem?

This is my bucket policy:

Did you ever figure out the issue @tkassis? I am also experiencing the same issue. I followed the instructions closely.

Any input @zeroqode1 or @levon?

Yes, it turned out to be a typo from my end. I had misspelled the region in the plugin settings in Bubble. Double check that you didn’t mistype anything.

Sadly mine is all spelled correctly (As far as I can tell). My region is spelled correctly. I still get the error every time I place and image in the uploader.

21%20PM

Laughing at myself right now…I actually had the region as us-east-1 and it needed to be us-east-2. I both love and hate development.

2 Likes

If it makes you feel any better my typo was ua-east-1 instead of us-east-1. I checked it probably around 20 times yet I never caught the mistake!

1 Like

Ha it does! I basically just trial and error until something works.

Hi guys, I’m getting the same error and I have checked for typos many times.

I’m also getting one other issue: I can upload files using the No GUI uploader, however they seem to be limited at about 4mb in size. Anything larger just doesn’t show up in my S3 bucket, even though it looks like the upload was succesful.

I am able to upload larger files directly to my bucket on the Amazon interface so there don’t seem to be any limitations there.

My bucket is connected properly because I can get a list of files using the S3 objects.

Any ideas @zeroqode1 or @levon?
Thanks

Hello @kieran,

We checked the plugin and it is working properly. Could you please check if you did set up everything in accordance with documentation: https://docs.zeroqode.com/plugins/aws-file-uploader-plugin

If this will not help then you can add [email protected] as collaborators to your app and we will check what is the problem.

Regards,
Alex

Thank you. I have followed the documentation as closely as possible but no luck.
I have added you as a collaborator but not sure if it worked because it says you can only add collaborators if on a professional plan.
Let me know if you are able to access it, if not I will change my plan temporarily (I have a discount code).
The page I’ve been testing uploads on is called test_upload
Thanks again!

Thanks, we got the access. We will inspect the issue and will do our best to provide an answer ASAP. I will keep you posted.

Best Regards,
Alex

We checked the plugin in your app and with our keys, it is working properly. Seems that there is an access issue related to the account setting which we cannot change. Please try to reproduce once again the steps described in the documentation and pay special attention to:
3. IAM Security Roles
4. AWS S3 Bucket located on the desired Server
Permissions.
I hope this will help you!

Regards,
Alex

Thank you Alex. I appreciate you taking the time to test it.
For some reason the NoGUI uploader is now working on files up to about 30mb, but above that nothing happens.
I am still getting the " Server Responded with 0 Code" when I use the AWS File Uploader element - this has never worked for me.
It also only works if I have my S3 bucket set to allow all public access which isn’t ideal.
I have checked and re-checked your instructions and tried to follow them closely, although there are parts where it is a little unclear, particularly regarding allowing public access or not.
I am not sure if there’s anything else you can do - is there a way I can give you access to my S3 bucket so you can have a complete look at it?
Thanks again,
Kieran

Yes, you are right the S3 Bucket should be set to public overwise the plugin will not have acces to data. Here is the reference from the documentation:

image

I would like to help you better help with making the plugin work on your side but accessing your S3 account is beyond the limits of our support. Please just repeat the steps from the documentation and if everything will be set up correctly the plugin will work.

I hope for your understanding!
Alex