Templates Plugins Courses

Need help with Algolia Filter Setup

Hi there,

I have created a search using Algolia search successfully but I am having difficulty sending through filters. I have a Group that stores an id ‘catid:10’ and in the filters I pull through the catid stored by the group.

When this is set as below, no results are returned even though there should be results displayed. If I remove the filter, the results are displayed just fine.

The v.2 demo does not have the filter functionality.

Screenshot 2020-05-07 at 21.38.10 Screenshot 2020-05-07 at 21.38.16

Regards,
Pieter

Hello @pieter, thank you for reaching out!

Could you please let me know which version of the plugin are you using? This can be checked on the plugin tab of Bubble editor.

Best Regards,
Alex

Hi there,

This is on the latest version - 3.10

@pieter, thanks for informing.

Could you please add [email protected] as collaborators to your app? This will help with finding the solution. If you will add us please let us know the name of your app and page where the plugin is used.

Best Regards,
Alex

Hi there,

Collaborator has been added to the app.

Name: gunfind-sa
Page: classifieds

Hi there,

Any update on this issue as yet?

@alex.grimacovschi ,

Just following up on this request again?

Hello @pieter, thank you for providing access to your app. Our team will check your app asap and will come back to you with an answer.

Best Regards,
Alex

@alex.grimacovschi, just checking if you’ve managed to find the issue as yet?

@pieter,

I was writing to you right now.
Our team checked your app and found that the issue with filtering is caused by a bug in the plugin. We already started to work on fixing the bug. Once the updated version of the plugin with fixes will be published we will let you know.

Best Regards,
Alex

Thanks @alex.grimacovschi

Any idea around timelines?

@pieter
Unfortunately, I cannot provide an estimate of when the solution will be available. Our team will do its best to provide the solution at the first opportunity.

Best Regards,
Alex

@alex.grimacovschi, just checking if the fix has been implemented as yet?

Hello @pieter, our team is still working on the fix. I will let you know once the updated version of the plugin will be published.

Best Regards,
Alex

Hello @pieter,

We pushed an update for the plugin that should address the issue you were facing. Please update the plugin to the latest version and give it a try.

Please note that in order to have filtering functionality working properly you should set up filters in your Algolia Dashboard. Here you can find how to do that. Also, the format of data used as filters changed, don’t forget to edit them accordingly.
image

Best Regards,
Alex